aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/angel17/rules.mk
diff options
context:
space:
mode:
authorkakunpc <15257475+kakunpc@users.noreply.github.com>2019-08-22 09:40:37 +0900
committerDrashna Jaelre <drashna@live.com>2019-08-21 17:40:37 -0700
commit63b96c34ce254f552cdb098060a9e7d7705263b2 (patch)
tree3ec9e159b2b19dd837975447ae87d23ce2395a2c /keyboards/angel17/rules.mk
parent94efa18c28c8c0e08526c9665a8f0d6a4e7d3e96 (diff)
downloadfirmware-63b96c34ce254f552cdb098060a9e7d7705263b2.tar.gz
firmware-63b96c34ce254f552cdb098060a9e7d7705263b2.tar.bz2
firmware-63b96c34ce254f552cdb098060a9e7d7705263b2.zip
[Keyboard] new keyboard "angel17" (#6542)
* add angel17 keyboard * fix rules.mk * change BOOTLOADER * set LAYOUT_numpad_5x4 * Update keyboards/angel17/rules.mk Co-Authored-By: Drashna Jaelre <drashna@live.com> * fix LAYOUTS = numpad_5x4 * update info.json
Diffstat (limited to 'keyboards/angel17/rules.mk')
-rw-r--r--keyboards/angel17/rules.mk46
1 files changed, 46 insertions, 0 deletions
diff --git a/keyboards/angel17/rules.mk b/keyboards/angel17/rules.mk
new file mode 100644
index 000000000..423ebddc5
--- /dev/null
+++ b/keyboards/angel17/rules.mk
@@ -0,0 +1,46 @@
+# MCU name
+MCU = atmega32u4
+
+
+# Bootloader selection
+# Teensy halfkay
+# Pro Micro caterina
+# Atmel DFU atmel-dfu
+# LUFA DFU lufa-dfu
+# QMK DFU qmk-dfu
+# atmega32a bootloadHID
+BOOTLOADER = caterina
+
+
+# If you don't know the bootloader type, then you can specify the
+# Boot Section Size in *bytes* by uncommenting out the OPT_DEFS line
+# Teensy halfKay 512
+# Teensy++ halfKay 1024
+# Atmel DFU loader 4096
+# LUFA bootloader 4096
+# USBaspLoader 2048
+# OPT_DEFS += -DBOOTLOADER_SIZE=4096
+
+
+# Build Options
+# change yes to no to disable
+#
+BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration(+1000)
+MOUSEKEY_ENABLE = yes # Mouse keys(+4700)
+EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
+CONSOLE_ENABLE = yes # Console for debug(+400)
+COMMAND_ENABLE = yes # Commands for debug and configuration
+# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+# if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+NKRO_ENABLE = no # USB Nkey Rollover
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+RGBLIGHT_ENABLE = no # Enable keyboard RGB underglow
+MIDI_ENABLE = no # MIDI support (+2400 to 4200, depending on config)
+UNICODE_ENABLE = no # Unicode
+BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
+AUDIO_ENABLE = no # Audio output on port C6
+FAUXCLICKY_ENABLE = no # Use buzzer to emulate clicky switches
+HD44780_ENABLE = no # Enable support for HD44780 based LCDs (+400)
+
+LAYOUTS = numpad_5x4