aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/aplx6
diff options
context:
space:
mode:
authorAplyard <40563350+Aplyard@users.noreply.github.com>2020-04-13 22:13:41 +0300
committerGitHub <noreply@github.com>2020-04-13 12:13:41 -0700
commit4bccde37d4148bdf0ee3676c9eed102639cfeb4a (patch)
tree108db12c042ff59b0be75fab718a26aab381c983 /keyboards/aplx6
parentf6b40da7f854d461f30a3e525f4e36e51dac5db4 (diff)
downloadfirmware-4bccde37d4148bdf0ee3676c9eed102639cfeb4a.tar.gz
firmware-4bccde37d4148bdf0ee3676c9eed102639cfeb4a.tar.bz2
firmware-4bccde37d4148bdf0ee3676c9eed102639cfeb4a.zip
[Keyboard] Aplx6 (#8727)
* Create test.txt * aplx6 * Delete test.txt * fff * Delete ffff * test compile * Create README.md * edited * requests * Update keyboards/aplx6/README.md * Update keyboards/aplx6/README.md * Update keyboards/aplx6/README.md * Update keyboards/aplx6/README.md * Update keyboards/aplx6/README.md * Update keyboards/aplx6/README.md * Update keyboards/aplx6/README.md * Update keyboards/aplx6/rules.mk * Update keyboards/aplx6/rules.mk * Update keyboards/aplx6/README.md * Update keyboards/aplx6/README.md * Update keyboards/aplx6/README.md * pins update * update * update pins * Update keyboards/aplx6/README.md * Update keyboards/aplx6/README.md
Diffstat (limited to 'keyboards/aplx6')
-rw-r--r--keyboards/aplx6/README.md41
-rw-r--r--keyboards/aplx6/aplx6.c19
-rw-r--r--keyboards/aplx6/aplx6.h12
-rw-r--r--keyboards/aplx6/config.h49
-rw-r--r--keyboards/aplx6/keymaps/default/keymap.c38
-rw-r--r--keyboards/aplx6/rules.mk33
6 files changed, 192 insertions, 0 deletions
diff --git a/keyboards/aplx6/README.md b/keyboards/aplx6/README.md
new file mode 100644
index 000000000..55e73ea2d
--- /dev/null
+++ b/keyboards/aplx6/README.md
@@ -0,0 +1,41 @@
+# Aplx6
+
+![Front](https://i.imgur.com/flhSvAG.png)
+![Back](https://i.imgur.com/PXqNmUh.png)
+
+A stylish (2x3) 6-key MediaPad for your music and browser shortcuts. Designed to be assembled as a sandwich with a blank PCB, using M2.5 screws and spacers, your choice of MX- or Alps-compatible switches, and 1N4148 diodes.
+
+
+## RGB Underglow (WS2812)
+
+Just wire them to any of the unused ProMicro pins. Don't forget to edit-uncomment the `config.h` and the `rules.mk` for RGB underglow support, or even add your own functions and modes. Used pins can be found in `config.h` or in the [KiCad Schematic](https://github.com/Aplyard/Aplx6/blob/master/kiCad/xd6.sch). All ProMicro pins can be found [here](https://golem.hu/article/pro-micro-pinout/) along with the +2 pins mod.
+
+* Keyboard Maintainer: [Aplyard](https://github.com/Aplyard)
+* Hardware Supported: Aplx6 PCB, Pro Micro (ATmega32U4)
+* Hardware Availability: [GitHub](https://github.com/Aplyard/Aplx6)
+
+Make example for this keyboard (after setting up your build environment):
+
+ make aplx6:default
+
+See the [build environment setup](https://docs.qmk.fm/#/getting_started_build_tools) and the [make instructions](https://docs.qmk.fm/#/getting_started_make_guide) for more information. Brand new to QMK? Start with our [Complete Newbs Guide](https://docs.qmk.fm/#/newbs).
+
+---
+****Designed in**:**
+[KiCad](https://github.com/KiCad)
+
+**Components Footprints & Libraries :**
+[keebs.pretty](https://github.com/egladman/keebs.pretty)
+[keyboard_parts.pretty
+](https://github.com/tmk/keyboard_parts.pretty)
+[ProMicro KiCad](https://github.com/Biacco42/ProMicroKiCad)
+
+**Usefull Links:**
+[Qmk Online Configurator](https://config.qmk.fm/#)
+
+**Alternatives of qmk that worked for me:**
+[Keyboard Layout Editor](http://www.keyboard-layout-editor.com/#/)
+[Keyboard Plate & Case Builder](http://builder.swillkb.com/)
+[Firmware Builder](https://kbfirmware.com/)
+
+---
diff --git a/keyboards/aplx6/aplx6.c b/keyboards/aplx6/aplx6.c
new file mode 100644
index 000000000..3a294c199
--- /dev/null
+++ b/keyboards/aplx6/aplx6.c
@@ -0,0 +1,19 @@
+/*
+Copyright 2020 April Aplyard <alex.fragiou@gmail.com>
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, either version 2 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#include "aplx6.h"
+
diff --git a/keyboards/aplx6/aplx6.h b/keyboards/aplx6/aplx6.h
new file mode 100644
index 000000000..6990d388e
--- /dev/null
+++ b/keyboards/aplx6/aplx6.h
@@ -0,0 +1,12 @@
+#pragma once
+#include "quantum.h"
+
+#define LAYOUT( \
+ k000, k001, k002, \
+ k100, k101, k102 \
+) \
+{ \
+ { k000, k001, k002 }, \
+ { k100, k101, k102 } \
+}
+
diff --git a/keyboards/aplx6/config.h b/keyboards/aplx6/config.h
new file mode 100644
index 000000000..8db06d93c
--- /dev/null
+++ b/keyboards/aplx6/config.h
@@ -0,0 +1,49 @@
+/*
+Copyright 2020 April Aplyard <alex.fragiou@gmail.com>
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, either version 2 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#pragma once
+
+#include "config_common.h"
+
+/* USB Device descriptor parameter */
+#define VENDOR_ID 0xE0E0
+#define PRODUCT_ID 0x0030
+#define DEVICE_VER 0x0001
+#define MANUFACTURER Aplyard
+#define PRODUCT Aplx6
+#define DESCRIPTION Aplx6 MediaPad
+
+/* key matrix size */
+#define MATRIX_ROWS 2
+#define MATRIX_COLS 3
+
+/* pin-out */
+#define MATRIX_ROW_PINS { E6, B3 }
+#define MATRIX_COL_PINS { F7, B6, F4 }
+#define UNUSED_PINS
+
+
+/* ws2812 RGB LED */
+//#define RGB_DI_PIN X
+
+//#define RGBLIGHT_ANIMATIONS
+//#define RGBLED_NUM X // Number of LEDs
+
+
+/* COL2ROW or ROW2COL */
+#define DIODE_DIRECTION COL2ROW
+
diff --git a/keyboards/aplx6/keymaps/default/keymap.c b/keyboards/aplx6/keymaps/default/keymap.c
new file mode 100644
index 000000000..4c4f612a3
--- /dev/null
+++ b/keyboards/aplx6/keymaps/default/keymap.c
@@ -0,0 +1,38 @@
+#include QMK_KEYBOARD_H
+
+#define _MAIN 0
+#define _FN 1
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+ /* Keymap __MAIN: Default Layer
+ * ,--------------------------------.
+ * | .------. |-----|-----|-----| |
+ * | | | |Play |VolUp| Fn | |
+ * | | Pro | |-----|-----|-----| |
+ * | | Micro| --------------------|
+ * | | | |-----|-----|-----| |
+ * | '------' |Prev |VolD |Next | |
+ * | |||||| |-----|-----|-----| |
+ * '--------------------------------'
+ */
+ [_MAIN] = LAYOUT(
+ KC_MPLY, KC_VOLU, MO(1),
+ KC_MPRV, KC_VOLD, KC_MNXT
+ ),
+ /* Keymap __FN: Second Layer
+ * ,--------------------------------.
+ * | .------. |-----|-----|-----| |
+ * | | | |Calc |PgUp |TRANS| |
+ * | | Pro | |-----|-----|-----| |
+ * | | Micro| --------------------|
+ * | | | |-----|-----|-----| |
+ * | '------' |MyPC | PgD |RESET| |
+ * | |||||| |-----|-----|-----| |
+ * '--------------------------------'
+ */
+
+ [_FN] = LAYOUT(
+ KC_CALC, KC_PGUP, _______,
+ KC_MYCM, KC_PGDN, RESET
+ )
+};
diff --git a/keyboards/aplx6/rules.mk b/keyboards/aplx6/rules.mk
new file mode 100644
index 000000000..d2d1078d3
--- /dev/null
+++ b/keyboards/aplx6/rules.mk
@@ -0,0 +1,33 @@
+# MCU name
+MCU = atmega32u4
+
+# Bootloader selection
+# Teensy halfkay
+# Pro Micro caterina
+# Atmel DFU atmel-dfu
+# LUFA DFU lufa-dfu
+# QMK DFU qmk-dfu
+# ATmega32A bootloadHID
+# ATmega328P USBasp
+BOOTLOADER = caterina
+
+# Build Options
+# change yes to no to disable
+#
+BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration
+MOUSEKEY_ENABLE = yes # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = no # Console for debug
+COMMAND_ENABLE = no # Commands for debug and configuration
+# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+# if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+NKRO_ENABLE = yes # USB Nkey Rollover
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+RGBLIGHT_ENABLE = no # Enable keyboard RGB underglow
+MIDI_ENABLE = no # MIDI support
+BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
+AUDIO_ENABLE = no # Audio output on port C6
+FAUXCLICKY_ENABLE = no # Use buzzer to emulate clicky switches
+HD44780_ENABLE = no # Enable support for HD44780 based LCDs
+UNICODE_ENABLE = yes # Unicode