aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/atreus62/keymaps/scheiklp/config.h
diff options
context:
space:
mode:
authorPaul Scheikl <paul.scheikl@kit.edu>2020-05-16 07:37:58 +0200
committerGitHub <noreply@github.com>2020-05-15 22:37:58 -0700
commitc6cf1ae4e71f6d520c415e02b6b50f482c936698 (patch)
tree9c4b77dbb1a776914ec2d30a0b25ce3caa23604a /keyboards/atreus62/keymaps/scheiklp/config.h
parent2c9ab8a606cd038785b75f0c2dd5469e63de189d (diff)
downloadfirmware-c6cf1ae4e71f6d520c415e02b6b50f482c936698.tar.gz
firmware-c6cf1ae4e71f6d520c415e02b6b50f482c936698.tar.bz2
firmware-c6cf1ae4e71f6d520c415e02b6b50f482c936698.zip
[Keymap] Added the K.O,Y layout for the xd75 and atreus62 boards (#9079)
* added koy layout to qmk on xd75 board * added koy keymap for the atreus62 board * reduced time for autoshift * added documentation * changed layer 7 to a tap toggle and adjusted mouse speed a little * Update keyboards/xd75/keymaps/ScheiklP/koy_keys_on_quertz_de_latin1.h * Update keyboards/xd75/keymaps/ScheiklP/koy_keys_on_quertz_de_latin1.h * Update keyboards/xd75/keymaps/ScheiklP/koy_common.h * Update keyboards/atreus62/keymaps/ScheiklP/koy_common.h * Update keyboards/atreus62/keymaps/ScheiklP/koy_keys_on_quertz_de_latin1.h * Update keyboards/atreus62/keymaps/ScheiklP/koy_keys_on_quertz_de_latin1.h * changed keymap to lowercase name to conform with qmk guidelines * Update keyboards/xd75/keymaps/scheiklp/rules.mk remove unnecessary rules * Update keyboards/atreus62/keymaps/scheiklp/rules.mk remove unnecessary rules * moved common files for koy layouts to the users folder and removed empty file * Update keyboards/atreus62/keymaps/scheiklp/keymap.c * Update keyboards/xd75/keymaps/scheiklp/readme.md * Update keyboards/xd75/keymaps/scheiklp/readme.md * Update keyboards/atreus62/keymaps/scheiklp/readme.md * Update keyboards/atreus62/keymaps/scheiklp/readme.md
Diffstat (limited to 'keyboards/atreus62/keymaps/scheiklp/config.h')
-rw-r--r--keyboards/atreus62/keymaps/scheiklp/config.h51
1 files changed, 51 insertions, 0 deletions
diff --git a/keyboards/atreus62/keymaps/scheiklp/config.h b/keyboards/atreus62/keymaps/scheiklp/config.h
new file mode 100644
index 000000000..dc7629b62
--- /dev/null
+++ b/keyboards/atreus62/keymaps/scheiklp/config.h
@@ -0,0 +1,51 @@
+/* Copyright 2017 Benjamin Kesselring
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+
+#pragma once
+// place overrides here
+#define AUTO_SHIFT_TIMEOUT 125
+#define NO_AUTO_SHIFT_SPECIAL
+#define NO_AUTO_SHIFT_NUMERIC
+
+// require two taps for a TT layer switch (default 5)
+#define TAPPING_TOGGLE 2
+
+// Mouse control
+// constant mode (velocity)
+#define MK_3_SPEED
+// KC_ACL0 < KC_ACL1 < unmodified < KC_ACL2
+
+// Cursor offset per movement (unmodified)
+#define MK_C_OFFSET_UNMOD 16
+// Time between cursor movements (unmodified)
+#define MK_C_INTERVAL_UNMOD 10
+/* #define MK_C_INTERVAL_UNMOD 16 */
+
+// Cursor offset per movement (KC_ACL0)
+#define MK_C_OFFSET_0 1
+// Time between cursor movements (KC_ACL0)
+#define MK_C_INTERVAL_0 32
+
+// Cursor offset per movement (KC_ACL1)
+#define MK_C_OFFSET_1 4
+// Time between cursor movements (KC_ACL1)
+#define MK_C_INTERVAL_1 16
+
+// Cursor offset per movement (KC_ACL2)
+#define MK_C_OFFSET_2 20
+/* #define MK_C_OFFSET_2 32 */
+// Time between cursor movements (KC_ACL2)
+#define MK_C_INTERVAL_2 16