aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/aves65/rules.mk
diff options
context:
space:
mode:
authorHund <Hund@users.noreply.github.com>2020-05-13 20:43:28 +0200
committerGitHub <noreply@github.com>2020-05-13 19:43:28 +0100
commit30a6f231bfc6b447e9b2c45b39527f0c0b9c909f (patch)
tree3b667fea20f9b7b426672866de3c37500319448b /keyboards/aves65/rules.mk
parent44ff14f290833a72f32c06901826f014d22ea810 (diff)
downloadfirmware-30a6f231bfc6b447e9b2c45b39527f0c0b9c909f.tar.gz
firmware-30a6f231bfc6b447e9b2c45b39527f0c0b9c909f.tar.bz2
firmware-30a6f231bfc6b447e9b2c45b39527f0c0b9c909f.zip
[Keyboard] Added support for Aves 65 (#8880)
* First commit. * Apply suggestions from code review Co-Authored-By: Drashna Jaelre <drashna@live.com> Co-Authored-By: Ryan <fauxpark@gmail.com> * Update keyboards/aves65/rules.mk Co-Authored-By: Joel Challis <git@zvecr.com> * Update keyboards/aves65/aves65.h Co-Authored-By: Joel Challis <git@zvecr.com> * Update keyboards/aves65/keymaps/default/keymap.c Co-Authored-By: Joel Challis <git@zvecr.com> * Update keyboards/aves65/rules.mk Co-Authored-By: Joel Challis <git@zvecr.com> * Changes. * Changes * Changes * Update keyboards/aves65/rules.mk Co-authored-by: Joel Challis <git@zvecr.com> Co-authored-by: Hund <hund@ubuntu.com> Co-authored-by: Drashna Jaelre <drashna@live.com> Co-authored-by: Ryan <fauxpark@gmail.com> Co-authored-by: Joel Challis <git@zvecr.com>
Diffstat (limited to 'keyboards/aves65/rules.mk')
-rw-r--r--keyboards/aves65/rules.mk34
1 files changed, 34 insertions, 0 deletions
diff --git a/keyboards/aves65/rules.mk b/keyboards/aves65/rules.mk
new file mode 100644
index 000000000..911c1d95a
--- /dev/null
+++ b/keyboards/aves65/rules.mk
@@ -0,0 +1,34 @@
+# MCU name
+MCU = atmega32u4
+
+# Bootloader selection
+# Teensy halfkay
+# Pro Micro caterina
+# Atmel DFU atmel-dfu
+# LUFA DFU lufa-dfu
+# QMK DFU qmk-dfu
+# ATmega32A bootloadHID
+# ATmega328P USBasp
+BOOTLOADER = qmk-dfu
+
+# Build Options
+# change yes to no to disable
+#
+BOOTMAGIC_ENABLE = lite # Virtual DIP switch configuration
+MOUSEKEY_ENABLE = yes # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = no # Console for debug
+COMMAND_ENABLE = no # Commands for debug and configuration
+# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+# if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+NKRO_ENABLE = no # USB Nkey Rollover
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+RGBLIGHT_ENABLE = yes # Enable keyboard RGB underglow
+MIDI_ENABLE = no # MIDI support
+BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
+AUDIO_ENABLE = no # Audio output on port C6
+FAUXCLICKY_ENABLE = no # Use buzzer to emulate clicky switches
+HD44780_ENABLE = no # Enable support for HD44780 based LCDs
+
+LAYOUTS = 65_iso_blocker