aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/bakeneko60/rules.mk
diff options
context:
space:
mode:
authorKoichi Katano <36572567+kkatano@users.noreply.github.com>2020-09-04 01:09:36 +0900
committerGitHub <noreply@github.com>2020-09-03 09:09:36 -0700
commitc1a6b5f430a46206ce98a3c52284725e80322a98 (patch)
treed298b5a2f724f766da8ce950d8bf2fc80ba5a0ad /keyboards/bakeneko60/rules.mk
parent25e93b4b677c85165f6996f3de96f260121f549a (diff)
downloadfirmware-c1a6b5f430a46206ce98a3c52284725e80322a98.tar.gz
firmware-c1a6b5f430a46206ce98a3c52284725e80322a98.tar.bz2
firmware-c1a6b5f430a46206ce98a3c52284725e80322a98.zip
[Keyboard] add Bakeneko 60 (#10212)
* Add Bakeneko 60 keyboard * Apply suggestions from code review
Diffstat (limited to 'keyboards/bakeneko60/rules.mk')
-rw-r--r--keyboards/bakeneko60/rules.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/keyboards/bakeneko60/rules.mk b/keyboards/bakeneko60/rules.mk
new file mode 100644
index 000000000..cc1b100ec
--- /dev/null
+++ b/keyboards/bakeneko60/rules.mk
@@ -0,0 +1,24 @@
+# MCU name
+MCU = atmega32u4
+
+# Bootloader selection
+BOOTLOADER = atmel-dfu
+
+# Build Options
+# change yes to no to disable
+#
+BOOTMAGIC_ENABLE = lite # Virtual DIP switch configuration
+MOUSEKEY_ENABLE = yes # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = no # Console for debug
+COMMAND_ENABLE = no # Commands for debug and configuration
+# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+# if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+NKRO_ENABLE = no # USB Nkey Rollover
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+RGBLIGHT_ENABLE = no # Enable keyboard RGB underglow
+BLUETOOTH_ENABLE = no # Enable Bluetooth
+AUDIO_ENABLE = no # Audio output
+
+LAYOUTS = 60_ansi_split_bs_rshift 60_ansi 60_tsangan_hhkb