aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/barleycorn/rules.mk
diff options
context:
space:
mode:
authoryiancar <yiangosyiangou@cytanet.com.cy>2020-08-25 04:37:01 +0100
committerGitHub <noreply@github.com>2020-08-24 20:37:01 -0700
commit5460489b5177245371d23b84b94673951866d003 (patch)
treede427ab289da564e53fd03870eb5a4bae71741ab /keyboards/barleycorn/rules.mk
parentecb212106950d4ffc5dca64fc06f031b6b12fcc1 (diff)
downloadfirmware-5460489b5177245371d23b84b94673951866d003.tar.gz
firmware-5460489b5177245371d23b84b94673951866d003.tar.bz2
firmware-5460489b5177245371d23b84b94673951866d003.zip
[Keyboard] Barleycorn (#10118)
* Initial commit * Barleycorn rename * Update readme.md * PR checklist fixes * Update info.json * Update keyboards/barleycorn/rules.mk * Update keyboards/barleycorn/config.h * Update keyboards/barleycorn/rules.mk * Update keyboards/barleycorn/config.h * Update keyboards/barleycorn/info.json * Update keyboards/barleycorn/info.json * Update keyboards/barleycorn/readme.md * Update keyboards/barleycorn/rules.mk * Update keyboards/barleycorn/rules.mk * PR review * Update keyboards/barleycorn/readme.md * Update keyboards/barleycorn/rules.mk * Update keyboards/barleycorn/keymaps/default/readme.md * Update keyboards/barleycorn/keymaps/iso/readme.md * Update keyboards/barleycorn/rules.mk * Update keyboards/barleycorn/readme.md * Update keyboards/barleycorn/rules.mk * Update keyboards/barleycorn/matrix.c * Update keyboards/barleycorn/barleycorn.c * added ansi/iso keymaps! * Update keyboards/barleycorn/info.json
Diffstat (limited to 'keyboards/barleycorn/rules.mk')
-rw-r--r--keyboards/barleycorn/rules.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/keyboards/barleycorn/rules.mk b/keyboards/barleycorn/rules.mk
new file mode 100644
index 000000000..be005ab29
--- /dev/null
+++ b/keyboards/barleycorn/rules.mk
@@ -0,0 +1,27 @@
+# MCU name
+MCU = atmega328p
+
+# Bootloader selection
+BOOTLOADER = USBasp
+
+# Build Options
+# change yes to no to disable
+#
+BOOTMAGIC_ENABLE = lite # Virtual DIP switch configuration
+MOUSEKEY_ENABLE = yes # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = no # Console for debug
+COMMAND_ENABLE = no # Commands for debug and configuration
+# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+# if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+NKRO_ENABLE = no # USB Nkey Rollover
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+RGBLIGHT_ENABLE = no # Enable keyboard RGB underglow
+BLUETOOTH_ENABLE = no # Enable Bluetooth
+AUDIO_ENABLE = no # Audio output
+
+CUSTOM_MATRIX = lite
+
+SRC += matrix.c
+QUANTUM_LIB_SRC += i2c_master.c