aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/candybar/lefty/rules.mk
diff options
context:
space:
mode:
authorTerryMathews <terry@terrymathews.net>2020-03-12 15:52:59 -0400
committerGitHub <noreply@github.com>2020-03-12 19:52:59 +0000
commit18bc5254932a842276627d8f055b6fb1d3345230 (patch)
tree0b8d831958384bb146dd0af751806e44cdbd691a /keyboards/candybar/lefty/rules.mk
parent4edb5a5e8c72e3be7fda20069941ea215cb49916 (diff)
downloadfirmware-18bc5254932a842276627d8f055b6fb1d3345230.tar.gz
firmware-18bc5254932a842276627d8f055b6fb1d3345230.tar.bz2
firmware-18bc5254932a842276627d8f055b6fb1d3345230.zip
[Keyboard] Candybar update (#8335)
* Candybar: split lefty and righty into subprojects. * Update readme.md * Update readme.md * Candybar: Moved STM32 library files into project root folder. * Update keyboards/candybar/righty/readme.md Co-Authored-By: James Young <18669334+noroadsleft@users.noreply.github.com> * Update keyboards/candybar/righty/readme.md Co-Authored-By: James Young <18669334+noroadsleft@users.noreply.github.com> * Update keyboards/candybar/righty/readme.md Co-Authored-By: James Young <18669334+noroadsleft@users.noreply.github.com> * Update keyboards/candybar/righty/readme.md Co-Authored-By: James Young <18669334+noroadsleft@users.noreply.github.com> * Update keyboards/candybar/righty/righty.c Co-Authored-By: James Young <18669334+noroadsleft@users.noreply.github.com> * Candybar: remove Boards directory so project uses one from drivers * Update keyboards/candybar/righty/readme.md Co-Authored-By: James Young <18669334+noroadsleft@users.noreply.github.com> * Update readme.md * Update readme.md Co-authored-by: James Young <18669334+noroadsleft@users.noreply.github.com>
Diffstat (limited to 'keyboards/candybar/lefty/rules.mk')
-rw-r--r--keyboards/candybar/lefty/rules.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/keyboards/candybar/lefty/rules.mk b/keyboards/candybar/lefty/rules.mk
new file mode 100644
index 000000000..cb1b83288
--- /dev/null
+++ b/keyboards/candybar/lefty/rules.mk
@@ -0,0 +1,24 @@
+# MCU name
+MCU = STM32F072
+
+# Build Options
+# comment out to disable the options.
+#
+# EXTRAFLAGS+=-flto
+LINK_TIME_OPTIMIZATION_ENABLE = yes
+BACKLIGHT_ENABLE = no
+BOOTMAGIC_ENABLE = yes # Virtual DIP switch configuration
+## (Note that for BOOTMAGIC on Teensy LC you have to use a custom .ld script.)
+MOUSEKEY_ENABLE = no # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = no # Console for debug
+COMMAND_ENABLE = no # Commands for debug and configuration
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+NKRO_ENABLE = yes # USB Nkey Rollover
+AUDIO_ENABLE = no
+RGBLIGHT_ENABLE = no
+SERIAL_LINK_ENABLE = no
+
+
+# Enter lower-power sleep mode when on the ChibiOS idle thread
+OPT_DEFS += -DCORTEX_ENABLE_WFI_IDLE=TRUE