aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/candybar/rules.mk
diff options
context:
space:
mode:
authorTerryMathews <terry@terrymathews.net>2019-01-19 01:19:14 -0500
committerDrashna Jaelre <drashna@live.com>2019-01-18 22:19:14 -0800
commitebec12fbe8bff9b657f3fe6abee67e37ef0a1ba6 (patch)
treeab24e1a85478e5d4de4c997416e63a074dc58c0e /keyboards/candybar/rules.mk
parentc4680a6460bcc0a3695f3e9232089374c40fc29c (diff)
downloadfirmware-ebec12fbe8bff9b657f3fe6abee67e37ef0a1ba6.tar.gz
firmware-ebec12fbe8bff9b657f3fe6abee67e37ef0a1ba6.tar.bz2
firmware-ebec12fbe8bff9b657f3fe6abee67e37ef0a1ba6.zip
[Keyboard] Initial support for TKC Candybar (#4881)
* Initial support for TKC Candybar * Correct FN layer issue Both shift keys were overloaded. Moved Caps Lock to FN + C. * Update keyboard description in config.h. * Info.json * Update project information * Update keyboards/candybar/readme.md Co-Authored-By: TerryMathews <terry@terrymathews.net>
Diffstat (limited to 'keyboards/candybar/rules.mk')
-rw-r--r--keyboards/candybar/rules.mk50
1 files changed, 50 insertions, 0 deletions
diff --git a/keyboards/candybar/rules.mk b/keyboards/candybar/rules.mk
new file mode 100644
index 000000000..d27bbe102
--- /dev/null
+++ b/keyboards/candybar/rules.mk
@@ -0,0 +1,50 @@
+## chip/board settings
+# - the next two should match the directories in
+# <chibios>/os/hal/ports/$(MCU_FAMILY)/$(MCU_SERIES)
+MCU_FAMILY = STM32
+MCU_SERIES = STM32F0xx
+
+# Linker script to use
+# - it should exist either in <chibios>/os/common/ports/ARMCMx/compilers/GCC/ld/
+# or <this_dir>/ld/
+MCU_LDSCRIPT = STM32F072xB
+
+# Startup code to use
+# - it should exist in <chibios>/os/common/startup/ARMCMx/compilers/GCC/mk/
+MCU_STARTUP = stm32f0xx
+
+# Board: it should exist either in <chibios>/os/hal/boards/
+# or <this_dir>/boards
+BOARD = ST_STM32F072B_DISCOVERY
+
+# Cortex version
+MCU = cortex-m0
+
+# ARM version, CORTEX-M0/M1 are 6, CORTEX-M3/M4/M7 are 7
+ARMV = 6
+
+# Vector table for application
+# 0x00000000-0x00001000 area is occupied by bootlaoder.*/
+# The CORTEX_VTOR... is needed only for MCHCK/Infinity KB
+# OPT_DEFS = -DCORTEX_VTOR_INIT=0x08005000
+OPT_DEFS =
+
+# Options to pass to dfu-util when flashing
+DFU_ARGS = -d 0483:df11 -a 0 -s 0x08000000:leave
+
+# Build Options
+# comment out to disable the options.
+#
+EXTRAFLAGS+=-flto
+BACKLIGHT_ENABLE = no
+BOOTMAGIC_ENABLE = yes # Virtual DIP switch configuration
+## (Note that for BOOTMAGIC on Teensy LC you have to use a custom .ld script.)
+MOUSEKEY_ENABLE = yes # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = yes # Console for debug
+COMMAND_ENABLE = yes # Commands for debug and configuration
+SLEEP_LED_ENABLE = yes # Breathing sleep LED during USB suspend
+NKRO_ENABLE = yes # USB Nkey Rollover
+AUDIO_ENABLE = no
+RGBLIGHT_ENABLE = no
+SERIAL_LINK_ENABLE = no