aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/chimera_ls/info.json
diff options
context:
space:
mode:
authornoroadsleft <18669334+noroadsleft@users.noreply.github.com>2018-10-22 14:18:47 -0700
committerDrashna Jaelre <drashna@live.com>2018-10-22 14:18:47 -0700
commit5dc41446aae0b429c72ca020cb20efb3356afee5 (patch)
treef76904f2c595d6786a9b81e15d282f9ee92ab9e6 /keyboards/chimera_ls/info.json
parente26a7b0ed8af7b6b4e99fee718ca265fcc8961f1 (diff)
downloadfirmware-5dc41446aae0b429c72ca020cb20efb3356afee5.tar.gz
firmware-5dc41446aae0b429c72ca020cb20efb3356afee5.tar.bz2
firmware-5dc41446aae0b429c72ca020cb20efb3356afee5.zip
Keyboard: Chimera LS refactor and Configurator support (#3715)
* Matrix/keymap refactor - Deleted `KC_KEYMAP` macro - Renamed `KEYMAP` macro to `LAYOUT_ortho_4x12` - Default keymap updated to current QMK standards - #include QMK_KEYBOARD_H - Refactored from `KC_KEYMAP` to `LAYOUT_ortho_4x12` macro - `action_get_macro()` deprecated in favor of `process_record_user()` `rules.mk` *not* updated to include `LAYOUTS = ortho_4x12` because I have no idea if and how that works on a split and/or wireless keyboard. * readme cleanup: markdown formatting * Add Configurator support * added support for ortho_4x12 layout * Macro and readme updates Macros updated to use `KC_NO` directly. Readme updates and cleanup.
Diffstat (limited to 'keyboards/chimera_ls/info.json')
-rw-r--r--keyboards/chimera_ls/info.json13
1 files changed, 13 insertions, 0 deletions
diff --git a/keyboards/chimera_ls/info.json b/keyboards/chimera_ls/info.json
new file mode 100644
index 000000000..077a76079
--- /dev/null
+++ b/keyboards/chimera_ls/info.json
@@ -0,0 +1,13 @@
+{
+ "keyboard_name": "Chimera LS",
+ "url": "",
+ "maintainer": "qmk",
+ "width": 13,
+ "height": 4,
+ "layouts": {
+ "LAYOUT_ortho_4x12": {
+ "key_count": 48,
+ "layout": [{"x":0, "y":0}, {"x":1, "y":0}, {"x":2, "y":0}, {"x":3, "y":0}, {"x":4, "y":0}, {"x":5, "y":0}, {"x":7, "y":0}, {"x":8, "y":0}, {"x":9, "y":0}, {"x":10, "y":0}, {"x":11, "y":0}, {"x":12, "y":0}, {"x":0, "y":1}, {"x":1, "y":1}, {"x":2, "y":1}, {"x":3, "y":1}, {"x":4, "y":1}, {"x":5, "y":1}, {"x":7, "y":1}, {"x":8, "y":1}, {"x":9, "y":1}, {"x":10, "y":1}, {"x":11, "y":1}, {"x":12, "y":1}, {"x":0, "y":2}, {"x":1, "y":2}, {"x":2, "y":2}, {"x":3, "y":2}, {"x":4, "y":2}, {"x":5, "y":2}, {"x":7, "y":2}, {"x":8, "y":2}, {"x":9, "y":2}, {"x":10, "y":2}, {"x":11, "y":2}, {"x":12, "y":2}, {"x":0, "y":3}, {"x":1, "y":3}, {"x":2, "y":3}, {"x":3, "y":3}, {"x":4, "y":3}, {"x":5, "y":3}, {"x":7, "y":3}, {"x":8, "y":3}, {"x":9, "y":3}, {"x":10, "y":3}, {"x":11, "y":3}, {"x":12, "y":3}]
+ }
+ }
+}