aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/clawsome/gamebuddy/rules.mk
diff options
context:
space:
mode:
authorAlisGraveNil <63020540+AlisGraveNil@users.noreply.github.com>2020-06-18 23:31:51 -0400
committerGitHub <noreply@github.com>2020-06-18 20:31:51 -0700
commit60be8d9f245c03db60e6297e357fec516b31bc62 (patch)
tree96c2735583f21237ea252ff84909e4d3c0fe5971 /keyboards/clawsome/gamebuddy/rules.mk
parent3f85e90126c37c5ee79be52ae5d764271d4a7734 (diff)
downloadfirmware-60be8d9f245c03db60e6297e357fec516b31bc62.tar.gz
firmware-60be8d9f245c03db60e6297e357fec516b31bc62.tar.bz2
firmware-60be8d9f245c03db60e6297e357fec516b31bc62.zip
[Keyboard] GameBuddy macropad (#9391)
* GameBuddy macropad * Update config.h * Update keyboards/clawsome/gamebuddy/config.h * Update keyboards/clawsome/gamebuddy/readme.md * Update keyboards/clawsome/gamebuddy/readme.md * Update keyboards/clawsome/gamebuddy/readme.md * Update readme.md * Update keyboards/clawsome/gamebuddy/rules.mk * Update keyboards/clawsome/gamebuddy/readme.md
Diffstat (limited to 'keyboards/clawsome/gamebuddy/rules.mk')
-rw-r--r--keyboards/clawsome/gamebuddy/rules.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/keyboards/clawsome/gamebuddy/rules.mk b/keyboards/clawsome/gamebuddy/rules.mk
new file mode 100644
index 000000000..44d0c26b7
--- /dev/null
+++ b/keyboards/clawsome/gamebuddy/rules.mk
@@ -0,0 +1,25 @@
+# MCU name
+MCU = atmega32u4
+
+# Bootloader selection
+BOOTLOADER = caterina
+
+# Build Options
+# change yes to no to disable
+#
+BOOTMAGIC_ENABLE = lite # Virtual DIP switch configuration
+MOUSEKEY_ENABLE = yes # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = yes # Console for debug
+COMMAND_ENABLE = yes # Commands for debug and configuration
+# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+# if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+NKRO_ENABLE = no # USB Nkey Rollover
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+RGBLIGHT_ENABLE = no # Enable keyboard RGB underglow
+MIDI_ENABLE = no # MIDI support
+UNICODE_ENABLE = no # Unicode
+BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
+AUDIO_ENABLE = no # Audio output on port C6
+FAUXCLICKY_ENABLE = no # Use buzzer to emulate clicky switches