aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/clawsome/sedan/config.h
diff options
context:
space:
mode:
authorAlisGraveNil <63020540+AlisGraveNil@users.noreply.github.com>2020-06-28 21:37:47 -0400
committerGitHub <noreply@github.com>2020-06-28 18:37:47 -0700
commit2c0201e80f7d1e477440c3a0cfcb9b90575a002a (patch)
treedcf90c5432aecc723f7163321a216a27f196efb6 /keyboards/clawsome/sedan/config.h
parent51509ec07bb6e442301c5a0b07638cd52ff89e38 (diff)
downloadfirmware-2c0201e80f7d1e477440c3a0cfcb9b90575a002a.tar.gz
firmware-2c0201e80f7d1e477440c3a0cfcb9b90575a002a.tar.bz2
firmware-2c0201e80f7d1e477440c3a0cfcb9b90575a002a.zip
[Keyboard] Coupe and Sedan keyboards (#9539)
* Initial upload - sedan and coupe keyboards * Update coupe.h * Update coupe.h * Update coupe.h * Update sedan.h * Update keyboards/clawsome/coupe/readme.md * Update keyboards/clawsome/sedan/config.h * Update keyboards/clawsome/sedan/config.h * Update keyboards/clawsome/coupe/config.h * Update keyboards/clawsome/sedan/readme.md * Update keyboards/clawsome/sedan/info.json * Update keyboards/clawsome/sedan/readme.md * Update keyboards/clawsome/coupe/readme.md * Update keyboards/clawsome/coupe/info.json * Update keyboards/clawsome/coupe/coupe.h * Update keyboards/clawsome/coupe/info.json * Update keyboards/clawsome/coupe/info.json * Update keyboards/clawsome/coupe/keymaps/default/keymap.c * Update keyboards/clawsome/sedan/info.json * Update keyboards/clawsome/sedan/sedan.h * Update keyboards/clawsome/sedan/rules.mk * Update keyboards/clawsome/sedan/sedan.h * Update keyboards/clawsome/sedan/keymap/default/keymap.c * Update keyboards/clawsome/sedan/keymap/default/keymap.c * Update keyboards/clawsome/coupe/rules.mk * Update keyboards/clawsome/sedan/info.json * Update keyboards/clawsome/sedan/info.json * Rename keymap.c to keymaps.c * Rename keymap.c to keymaps.c * folder name updated * updated keymaps * remove erroneously added files * extend keymap functionality * Update config.h * Update config.h * added URL on line #3 for image of Coupe * Added URL to line #3 * Update keyboards/clawsome/sedan/readme.md * Update keyboards/clawsome/coupe/readme.md
Diffstat (limited to 'keyboards/clawsome/sedan/config.h')
-rw-r--r--keyboards/clawsome/sedan/config.h47
1 files changed, 47 insertions, 0 deletions
diff --git a/keyboards/clawsome/sedan/config.h b/keyboards/clawsome/sedan/config.h
new file mode 100644
index 000000000..20d58d366
--- /dev/null
+++ b/keyboards/clawsome/sedan/config.h
@@ -0,0 +1,47 @@
+/*
+Copyright 2020 AAClawson (AlisGraveNil)
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, either version 2 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#pragma once
+
+#include "config_common.h"
+
+/* USB Device descriptor parameter */
+#define VENDOR_ID 0x7767
+#define PRODUCT_ID 0x8C78
+#define DEVICE_VER 0x0001
+#define MANUFACTURER AlisGraveNil
+#define PRODUCT The Sedan
+#define DESCRIPTION A QMK-powered 68% custom keyboard
+
+/* key matrix size */
+#define MATRIX_ROWS 5
+#define MATRIX_COLS 15
+
+/*
+ * Keyboard Matrix Assignments
+ *
+ * Change this to how you wired your keyboard
+ * COLS: AVR pins used for columns, left to right
+ * ROWS: AVR pins used for rows, top to bottom
+ * DIODE_DIRECTION: COL2ROW = COL = Anode (+), ROW = Cathode (-, marked on diode)
+ * ROW2COL = ROW = Anode (+), COL = Cathode (-, marked on diode)
+ *
+ */
+#define MATRIX_ROW_PINS { B0, B1, B2, B3, B4 }
+#define MATRIX_COL_PINS { B5, B6, B7, C0, C1, C2, C3, C4, C5, C6, C7, D0, D1, D2, D3 }
+
+#define DIODE_DIRECTION COL2ROW