aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/clawsome
diff options
context:
space:
mode:
authorAlisGraveNil <63020540+AlisGraveNil@users.noreply.github.com>2020-05-18 15:45:52 -0400
committerGitHub <noreply@github.com>2020-05-18 20:45:52 +0100
commit4604c70c4c1a0cb2cebc010dba34b04e902bd982 (patch)
tree276e938643da89b7c0a1e6e9eaad59832efab986 /keyboards/clawsome
parent010c5b12bd0bc4a53abda6d8f9d77de8a7ef1e8f (diff)
downloadfirmware-4604c70c4c1a0cb2cebc010dba34b04e902bd982.tar.gz
firmware-4604c70c4c1a0cb2cebc010dba34b04e902bd982.tar.bz2
firmware-4604c70c4c1a0cb2cebc010dba34b04e902bd982.zip
[Keyboard] Add Bookerboard support (#9097)
* 5/14/20 first push for bookerboard * Update rules.mk * Update keyboards/clawsome/bookerboard/rules.mk Co-authored-by: ridingqwerty <george.g.koenig@gmail.com> * Update keyboards/clawsome/bookerboard/keymaps/default/keymap.c Co-authored-by: Joel Challis <git@zvecr.com> * Update keyboards/clawsome/bookerboard/config.h Co-authored-by: Ryan <fauxpark@gmail.com> * Update keyboards/clawsome/bookerboard/bookerboard.c Co-authored-by: Joel Challis <git@zvecr.com> * Update keyboards/clawsome/bookerboard/bookerboard.h Co-authored-by: ridingqwerty <george.g.koenig@gmail.com> * 5/15/20 * 2 * 3 * Update keyboards/clawsome/bookerboard/config.h Co-authored-by: Ryan <fauxpark@gmail.com> * Update keyboards/clawsome/bookerboard/config.h Co-authored-by: Ryan <fauxpark@gmail.com> * Update keyboards/clawsome/bookerboard/readme.md Co-authored-by: Ryan <fauxpark@gmail.com> * Update keyboards/clawsome/bookerboard/readme.md Co-authored-by: Joel Challis <git@zvecr.com> * Update keyboards/clawsome/bookerboard/readme.md Co-authored-by: Joel Challis <git@zvecr.com> Co-authored-by: ridingqwerty <george.g.koenig@gmail.com> Co-authored-by: Joel Challis <git@zvecr.com> Co-authored-by: Ryan <fauxpark@gmail.com>
Diffstat (limited to 'keyboards/clawsome')
-rw-r--r--keyboards/clawsome/bookerboard/bookerboard.c16
-rw-r--r--keyboards/clawsome/bookerboard/bookerboard.h30
-rw-r--r--keyboards/clawsome/bookerboard/config.h47
-rw-r--r--keyboards/clawsome/bookerboard/info.json28
-rw-r--r--keyboards/clawsome/bookerboard/keymaps/default/keymap.c37
-rw-r--r--keyboards/clawsome/bookerboard/readme.md13
-rw-r--r--keyboards/clawsome/bookerboard/rules.mk33
7 files changed, 204 insertions, 0 deletions
diff --git a/keyboards/clawsome/bookerboard/bookerboard.c b/keyboards/clawsome/bookerboard/bookerboard.c
new file mode 100644
index 000000000..2cf132de5
--- /dev/null
+++ b/keyboards/clawsome/bookerboard/bookerboard.c
@@ -0,0 +1,16 @@
+/* Copyright 2020 AAClawson (AlisGraveNil)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+#include "bookerboard.h" \ No newline at end of file
diff --git a/keyboards/clawsome/bookerboard/bookerboard.h b/keyboards/clawsome/bookerboard/bookerboard.h
new file mode 100644
index 000000000..11ece7594
--- /dev/null
+++ b/keyboards/clawsome/bookerboard/bookerboard.h
@@ -0,0 +1,30 @@
+/* Copyright 2020 AAClawson (AlisGraveNil)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+#pragma once
+
+#include "quantum.h"
+
+#define LAYOUT( \
+ K00, K01, K02, \
+ K10, K11, K12, \
+ K20, K21, K22, \
+ K30, K31, K32 \
+) { \
+ { K00, K01, K02 }, \
+ { K10, K11, K12 }, \
+ { K20, K21, K22 }, \
+ { K30, K31, K32 }, \
+}
diff --git a/keyboards/clawsome/bookerboard/config.h b/keyboards/clawsome/bookerboard/config.h
new file mode 100644
index 000000000..19646e774
--- /dev/null
+++ b/keyboards/clawsome/bookerboard/config.h
@@ -0,0 +1,47 @@
+/*
+Copyright 2020 AAClawson (AlisGraveNil)
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, either version 2 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#pragma once
+
+#include "config_common.h"
+
+/* USB Device descriptor parameter */
+#define VENDOR_ID 0xFEED
+#define PRODUCT_ID 0x41CE
+#define DEVICE_VER 0x0001
+#define MANUFACTURER AlisGraveNil
+#define PRODUCT Bookerboard
+#define DESCRIPTION A 12-key QMK-powered macropod
+
+/* key matrix size */
+#define MATRIX_ROWS 4
+#define MATRIX_COLS 3
+
+/*
+ * Keyboard Matrix Assignments
+ *
+ * Change this to how you wired your keyboard
+ * COLS: AVR pins used for columns, left to right
+ * ROWS: AVR pins used for rows, top to bottom
+ * DIODE_DIRECTION: COL2ROW = COL = Anode (+), ROW = Cathode (-, marked on diode)
+ * ROW2COL = ROW = Anode (+), COL = Cathode (-, marked on diode)
+ *
+ */
+#define MATRIX_ROW_PINS { B5, B4, E6, D7 }
+#define MATRIX_COL_PINS { B6, B2, B3 }
+
+#define DIODE_DIRECTION COL2ROW
diff --git a/keyboards/clawsome/bookerboard/info.json b/keyboards/clawsome/bookerboard/info.json
new file mode 100644
index 000000000..a0eb1b598
--- /dev/null
+++ b/keyboards/clawsome/bookerboard/info.json
@@ -0,0 +1,28 @@
+{
+ "keyboard_name": "bookerboard",
+ "url": "",
+ "maintainer": "qmk",
+ "width": 3,
+ "height": 4,
+ "layouts": {
+ "LAYOUT": {
+ "key_count": 12,
+ "layout": [
+ {"label":"K00 (B5,B6)", "x":0, "y":0},
+ {"label":"K01 (B5,B2)", "x":1, "y":0},
+ {"label":"K02 (B5,B3)", "x":2, "y":0},
+ {"label":"K10 (B4,B6)", "x":0, "y":1},
+ {"label":"K11 (B4,B2)", "x":1, "y":1},
+ {"label":"K12 (B4,B3)", "x":2, "y":1},
+ {"label":"K20 (E6,B6)", "x":0, "y":2},
+ {"label":"K21 (E6,B2)", "x":1, "y":2},
+ {"label":"K22 (E6,B3)", "x":2, "y":2},
+ {"label":"K30 (D7,B6)", "x":0, "y":3},
+ {"label":"K31 (D7,B2)", "x":1, "y":3},
+ {"label":"K32 (D7,B3)", "x":2, "y":3}
+ ]
+ }
+ }
+ ,"meta": "https://noroadsleft.github.io/kbf_qmk_converter/"
+}
+
diff --git a/keyboards/clawsome/bookerboard/keymaps/default/keymap.c b/keyboards/clawsome/bookerboard/keymaps/default/keymap.c
new file mode 100644
index 000000000..a56245a30
--- /dev/null
+++ b/keyboards/clawsome/bookerboard/keymaps/default/keymap.c
@@ -0,0 +1,37 @@
+/* Copyright 2020 AAClawson (AlisGraveNil)
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+#include QMK_KEYBOARD_H
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+ /*
+ * --------------
+ * | 7 | 8 | 9 |
+ * --------------
+ * | 4 | 5 | 6 |
+ * --------------
+ * | 1 | 2 | 3 |
+ * --------------
+ * | - | 0 | = |
+ * --------------
+ */
+ [0] = LAYOUT(
+ KC_7, KC_8, KC_9,
+ KC_4, KC_5, KC_6,
+ KC_1, KC_2, KC_3,
+ KC_MINS, KC_0, KC_EQL
+ ),
+
+};
diff --git a/keyboards/clawsome/bookerboard/readme.md b/keyboards/clawsome/bookerboard/readme.md
new file mode 100644
index 000000000..7fa8d5e7a
--- /dev/null
+++ b/keyboards/clawsome/bookerboard/readme.md
@@ -0,0 +1,13 @@
+# Bookerboard
+
+This is a 4x3 macropad designed to be used with your favorite 12 keys for whatever you need 12 extra keys for.
+
+- Keyboard Maintainer: [AAClawson](https://github.com/AlisGraveNil)
+- Hardware Supported: Bookerboard, Pro Micro, Elite-C
+- Hardware Availability: Not available yet; will be sold at a later date
+
+Make example for this keyboard (after setting up your build environment):
+
+ make clawsome/bookerboard:default
+
+See the [build environment setup](https://docs.qmk.fm/#/getting_started_build_tools) and the [make instructions](https://docs.qmk.fm/#/getting_started_make_guide) for more information. Brand new to QMK? Start with our [Complete Newbs Guide](https://docs.qmk.fm/#/newbs).
diff --git a/keyboards/clawsome/bookerboard/rules.mk b/keyboards/clawsome/bookerboard/rules.mk
new file mode 100644
index 000000000..847da5a3d
--- /dev/null
+++ b/keyboards/clawsome/bookerboard/rules.mk
@@ -0,0 +1,33 @@
+# MCU name
+MCU = atmega32u4
+
+# Bootloader selection
+# Teensy halfkay
+# Pro Micro caterina
+# Atmel DFU atmel-dfu
+# LUFA DFU lufa-dfu
+# QMK DFU qmk-dfu
+# ATmega32A bootloadHID
+# ATmega328P USBasp
+BOOTLOADER = atmel-dfu
+
+# Build Options
+# change yes to no to disable
+#
+BOOTMAGIC_ENABLE = lite # Virtual DIP switch configuration
+MOUSEKEY_ENABLE = yes # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = yes # Console for debug
+COMMAND_ENABLE = yes # Commands for debug and configuration
+# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+# if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+NKRO_ENABLE = no # USB Nkey Rollover
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+RGBLIGHT_ENABLE = no # Enable keyboard RGB underglow
+MIDI_ENABLE = no # MIDI support
+UNICODE_ENABLE = no # Unicode
+BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
+AUDIO_ENABLE = no # Audio output on port C6
+FAUXCLICKY_ENABLE = no # Use buzzer to emulate clicky switches
+HD44780_ENABLE = no # Enable support for HD44780 based LCDs