aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/clueboard/card/info.json
diff options
context:
space:
mode:
authorskullydazed <skullydazed@users.noreply.github.com>2019-01-23 09:25:32 -0800
committerGitHub <noreply@github.com>2019-01-23 09:25:32 -0800
commitd1f735b6d2739295faf932dbb61e3c8b4c0b2898 (patch)
treeb1fd49248ef518b0252571d1812cd060860a1248 /keyboards/clueboard/card/info.json
parent9667c10477fb9bc91b9355dc4969ba8a5769871e (diff)
downloadfirmware-d1f735b6d2739295faf932dbb61e3c8b4c0b2898.tar.gz
firmware-d1f735b6d2739295faf932dbb61e3c8b4c0b2898.tar.bz2
firmware-d1f735b6d2739295faf932dbb61e3c8b4c0b2898.zip
Clueboard refresh (#4902)
* Cluecard: refactor - renamed layout macro KEYMAP to LAYOUT - reformatted layout macro to more closely resemble physical device layout - keymaps now use #include QMK_KEYBOARD_H - config.h files updated to use #pragma once method - deleted outdated QUANTUM_DIR code blocks from rules.mk files - white space changes on rules.mk files (alignment/readability) * Cluecard: Configurator support * Cluecard: readme update - added image - updated Docs links * Clueboard 66% HotSwap: corrected matrix and Configurator data - removed k31 and k84 from LAYOUT - both appear to be unsupported for this PCB according to images on clueboard.co - updated block comment mock-ups to match changes - rebuilt info.json file - delete removed keys from default keymap.c * Clueboard 66% HotSwap: readme update - fix make example - updated Docs links * Clueboard 66% HotSwap: 66_ansi keymap update Updated to use #include QMK_KEYBOARD_H * Clueboard 60% refactor - renamed layout macro KEYMAP to LAYOUT_all - renamed layout macro KEYMAP_AEK to LAYOUT_aek - removed redundant KC_TRNS definitions from keymaps - all keymaps now use #include QMK_KEYBOARD_H * Clueboard 17%: refactor * Clueboard 17%: Configurator support * Clueboard 17%: update Docs links in readme * Cleanup the 2x1800 files * Update Clueboard 60% to standard matrix * Update the clueboard default keymaps * Refresh and update clueboard 17 * Add the 66% hotswap to Clueboard's readme * Clarify the 66% hotswap's readme * change the image to imgur * Update the clueboard 66 to follow modern standards * update clueboard 66_hotswap to follow modern practices * Move the logo to imgur * update clueboard/card to follow modern practices * remove clueboard/66 as a valid make target * Address comments in #4902 * fix user keymaps after the changes
Diffstat (limited to 'keyboards/clueboard/card/info.json')
-rw-r--r--keyboards/clueboard/card/info.json20
1 files changed, 20 insertions, 0 deletions
diff --git a/keyboards/clueboard/card/info.json b/keyboards/clueboard/card/info.json
new file mode 100644
index 000000000..86dbb4faa
--- /dev/null
+++ b/keyboards/clueboard/card/info.json
@@ -0,0 +1,20 @@
+{
+ "keyboard_name": "Cluecard",
+ "keyboard_folder": "clueboard/card",
+ "url": "",
+ "maintainer": "skullydazed",
+ "width": 10,
+ "height": 7,
+ "layouts": {
+ "LAYOUT": {
+ "layout": [
+ {"label":"ON/OFF", "x":0, "y":0}, {"label":"SAT+", "x":4, "y":0}, {"label":"BRIGHT+", "x":8, "y":0},
+ {"label":"HUE-", "x":2, "y":1}, {"label":"HUE+", "x":6, "y":1},
+ {"label":"MODE", "x":0, "y":2}, {"label":"SAT-", "x":4, "y":2}, {"label":"BRIGHT-", "x":8, "y":2},
+ {"label":"LAYER", "x":2, "y":4},
+
+ {"label":"MX1", "x":4, "y":6, "w":2, "h":2}, {"label":"MX2", "x":6, "y":6, "w":2, "h":2}, {"label":"MX3", "x":8, "y":6, "w":2, "h":2}
+ ]
+ }
+ }
+}