aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/converter/ibm_terminal/keymaps/default/Makefile
diff options
context:
space:
mode:
authorOfer Plesser <plesserofer@gmail.com>2016-12-16 21:52:51 +0200
committerOfer Plesser <plesserofer@gmail.com>2016-12-16 21:52:51 +0200
commit6a462c818cc35ad5a51576bee96077d9614b1a8d (patch)
treecda535a4e64bd0183b800b6abe87005c3f98a74f /keyboards/converter/ibm_terminal/keymaps/default/Makefile
parent6e7cfa83b9424061914793b02757fa4ec75b356b (diff)
parentb8e13167c813b59ebd6f4484dccae37bde2bfdba (diff)
downloadfirmware-6a462c818cc35ad5a51576bee96077d9614b1a8d.tar.gz
firmware-6a462c818cc35ad5a51576bee96077d9614b1a8d.tar.bz2
firmware-6a462c818cc35ad5a51576bee96077d9614b1a8d.zip
Merge branch 'master' into feature/combos
Diffstat (limited to 'keyboards/converter/ibm_terminal/keymaps/default/Makefile')
-rw-r--r--keyboards/converter/ibm_terminal/keymaps/default/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/keyboards/converter/ibm_terminal/keymaps/default/Makefile b/keyboards/converter/ibm_terminal/keymaps/default/Makefile
new file mode 100644
index 000000000..9ec246494
--- /dev/null
+++ b/keyboards/converter/ibm_terminal/keymaps/default/Makefile
@@ -0,0 +1,27 @@
+# Build Options
+# change to "no" to disable the options, or define them in the Makefile in
+# the appropriate keymap folder that will get included automatically
+#
+BOOTMAGIC_ENABLE ?= no # Virtual DIP switch configuration(+1000)
+MOUSEKEY_ENABLE ?= yes # Mouse keys(+4700)
+EXTRAKEY_ENABLE ?= yes # Audio control and System control(+450)
+CONSOLE_ENABLE ?= no # Console for debug(+400)
+COMMAND_ENABLE ?= no # Commands for debug and configuration
+NKRO_ENABLE ?= yes # Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+BACKLIGHT_ENABLE ?= no # Enable keyboard backlight functionality
+MIDI_ENABLE ?= no # MIDI controls
+AUDIO_ENABLE ?= no # Audio output on port C6
+UNICODE_ENABLE ?= no # Unicode
+UNICODEMAP_ENABLE ?= yes
+BLUETOOTH_ENABLE ?= no # Enable Bluetooth with the Adafruit EZ-Key HID
+RGBLIGHT_ENABLE ?= no # Enable WS2812 RGB underlight. Do not enable this with audio at the same time.
+PS2_USE_USART ?= yes
+API_SYSEX_ENABLE ?= no
+
+# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
+SLEEP_LED_ENABLE ?= no # Breathing sleep LED during USB suspend
+
+ifndef QUANTUM_DIR
+ include ../../../../../Makefile
+endif
+