aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/crkbd/rev1
diff options
context:
space:
mode:
authorDanilo de Klerk <danilodeklerk@gmail.com>2020-08-06 19:36:26 +0200
committerGitHub <noreply@github.com>2020-08-06 10:36:26 -0700
commitc8b721d7c6cf683473bcf3d0af6ec561471b1dcc (patch)
tree380de15fcd2c9ce1047fc3f2cefbeb8684f2a4c4 /keyboards/crkbd/rev1
parent60d8d8677aa596120e4f3f0926b93b4d5cc0201a (diff)
downloadfirmware-c8b721d7c6cf683473bcf3d0af6ec561471b1dcc.tar.gz
firmware-c8b721d7c6cf683473bcf3d0af6ec561471b1dcc.tar.bz2
firmware-c8b721d7c6cf683473bcf3d0af6ec561471b1dcc.zip
split_3x5_3 layout support (#9624)
* Add split_3x5_3 support to Minidox * Add split_3x5_3 support to Miniaxe * Add LAYOUT_mini to Centromere This layout macro removes the need or KC_NO keycodes in the keymap. * Add split_3x5_3 support to Centromere * Add split_3x5_3 support to suihankey split * Add LAYOUT_mini to centromere/info.json * Add LAYOUT_mini to crkbd * Add split_3x5_3 support to crkbd * Change mini layout names * Rename main layouts for split_3x6_3 keyboards * Use split_3x5_3 macro for remaining keyboards * Update relevant info.json files * Fix suihankey/split/alpha macro * Add layout aliases for suihankey
Diffstat (limited to 'keyboards/crkbd/rev1')
-rw-r--r--keyboards/crkbd/rev1/rev1.h21
-rw-r--r--keyboards/crkbd/rev1/rules.mk2
2 files changed, 20 insertions, 3 deletions
diff --git a/keyboards/crkbd/rev1/rev1.h b/keyboards/crkbd/rev1/rev1.h
index 6580d73fe..2244b87f1 100644
--- a/keyboards/crkbd/rev1/rev1.h
+++ b/keyboards/crkbd/rev1/rev1.h
@@ -22,7 +22,7 @@
#endif
// clang-format off
-#define LAYOUT( \
+#define LAYOUT_split_3x6_3( \
L00, L01, L02, L03, L04, L05, R00, R01, R02, R03, R04, R05, \
L10, L11, L12, L13, L14, L15, R10, R11, R12, R13, R14, R15, \
L20, L21, L22, L23, L24, L25, R20, R21, R22, R23, R24, R25, \
@@ -39,6 +39,23 @@
{ KC_NO, KC_NO, KC_NO, R32, R31, R30 } \
}
+#define LAYOUT_split_3x5_3( \
+ L00, L01, L02, L03, L04, R00, R01, R02, R03, R04, \
+ L10, L11, L12, L13, L14, R10, R11, R12, R13, R14, \
+ L20, L21, L22, L23, L24, R20, R21, R22, R23, R24, \
+ L30, L31, L32, R30, R31, R32 \
+ ) \
+ { \
+ { KC_NO, L00, L01, L02, L03, L04 }, \
+ { KC_NO, L10, L11, L12, L13, L14 }, \
+ { KC_NO, L20, L21, L22, L23, L24 }, \
+ { KC_NO, KC_NO, KC_NO, L30, L31, L32 }, \
+ { KC_NO, R04, R03, R02, R01, R00 }, \
+ { KC_NO, R14, R13, R12, R11, R10 }, \
+ { KC_NO, R24, R23, R22, R21, R20 }, \
+ { KC_NO, KC_NO, KC_NO, R32, R31, R30 } \
+ }
+
#define LAYOUT_kc( \
L00, L01, L02, L03, L04, L05, R00, R01, R02, R03, R04, R05, \
L10, L11, L12, L13, L14, L15, R10, R11, R12, R13, R14, R15, \
@@ -53,4 +70,4 @@
)
// clang-format on
-#define LAYOUT_split_3x6_3 LAYOUT
+#define LAYOUT LAYOUT_split_3x6_3
diff --git a/keyboards/crkbd/rev1/rules.mk b/keyboards/crkbd/rev1/rules.mk
index a921e6030..21cee6bcf 100644
--- a/keyboards/crkbd/rev1/rules.mk
+++ b/keyboards/crkbd/rev1/rules.mk
@@ -2,4 +2,4 @@ SRC += matrix.c \
split_util.c \
split_scomm.c
-LAYOUTS = split_3x6_3
+LAYOUTS = split_3x5_3 split_3x6_3