aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/dilly
diff options
context:
space:
mode:
authorDanny <nooges@users.noreply.github.com>2019-02-12 19:57:24 -0500
committerDrashna Jaelre <drashna@live.com>2019-02-12 16:57:24 -0800
commitb2ee290c9f506e42dd9c4577c8147646c405aeb0 (patch)
tree4338c3ee37d2f8380c24624a24d8a4cb81d54693 /keyboards/dilly
parent994852712dbd183e2c764d624ae8ba7d3efb385a (diff)
downloadfirmware-b2ee290c9f506e42dd9c4577c8147646c405aeb0.tar.gz
firmware-b2ee290c9f506e42dd9c4577c8147646c405aeb0.tar.bz2
firmware-b2ee290c9f506e42dd9c4577c8147646c405aeb0.zip
[Keyboard] Move Keebio boards to own folder (#5109)
* Move boards into keebio folder * Rename keymap * Update BDN9 files * Update BFO-9000 files * Update Chocopad files * Update Dilly files * Update Fourier files, collapse rev1 into main * Update Iris files * Update Laplace files * Update Levinson files, fix buswerks keymap * Update Nyquist files * Fix keymap issues * Update Quefrency files * Update Rorschach files * Update TF68 files * Update Viterbi files * Update Viterbi files * Update Wavelet files * Reformat default layout * Fix up default folder for Iris * Remove already defined aliases
Diffstat (limited to 'keyboards/dilly')
-rw-r--r--keyboards/dilly/README.md14
-rw-r--r--keyboards/dilly/config.h51
-rw-r--r--keyboards/dilly/dilly.c1
-rw-r--r--keyboards/dilly/dilly.h31
-rw-r--r--keyboards/dilly/info.json13
-rw-r--r--keyboards/dilly/keymaps/default/config.h6
-rw-r--r--keyboards/dilly/keymaps/default/keymap.c69
-rw-r--r--keyboards/dilly/keymaps/default/rules.mk1
-rw-r--r--keyboards/dilly/keymaps/delmo/config.h10
-rw-r--r--keyboards/dilly/keymaps/delmo/keymap.c106
-rw-r--r--keyboards/dilly/keymaps/delmo/rules.mk1
-rw-r--r--keyboards/dilly/keymaps/pletcher/config.h11
-rw-r--r--keyboards/dilly/keymaps/pletcher/keymap.c96
-rw-r--r--keyboards/dilly/keymaps/pletcher/rules.mk2
-rw-r--r--keyboards/dilly/rules.mk58
15 files changed, 0 insertions, 470 deletions
diff --git a/keyboards/dilly/README.md b/keyboards/dilly/README.md
deleted file mode 100644
index a676313f3..000000000
--- a/keyboards/dilly/README.md
+++ /dev/null
@@ -1,14 +0,0 @@
-Dilly
-=====
-
-A 3x10 ortholinear keyboard using Kailh PG1350 Lower Profile Choc switches.
-
-Keyboard Maintainer: Keebio
-Hardware Supported: Dilly PCB, Arduino Pro Micro
-Hardware Availability: [Keebio](https://keeb.io)
-
-Make example for this keyboard (after setting up your build environment):
-
- make dilly:default
-
-See [build environment setup](https://docs.qmk.fm/#/getting_started_build_tools) then the [make instructions](https://docs.qmk.fm/#/getting_started_make_guide) for more information.
diff --git a/keyboards/dilly/config.h b/keyboards/dilly/config.h
deleted file mode 100644
index 1489ec302..000000000
--- a/keyboards/dilly/config.h
+++ /dev/null
@@ -1,51 +0,0 @@
-#ifndef CONFIG_H
-#define CONFIG_H
-
-#include "config_common.h"
-
-/* USB Device descriptor parameter */
-#define VENDOR_ID 0xCB10
-#define PRODUCT_ID 0x113a
-#define DEVICE_VER 0x0100
-#define MANUFACTURER Keebio
-#define PRODUCT Dilly
-#define DESCRIPTION 30 percent ortholinear keyboard
-
-/* key matrix size */
-#define MATRIX_ROWS 6
-#define MATRIX_COLS 5
-
-/* key matrix pins */
-#define MATRIX_ROW_PINS { D7, E6, B4, B1, B3, B2 }
-#define MATRIX_COL_PINS { D2, D4, C6, F6, F5 }
-#define UNUSED_PINS
-
-/* COL2ROW or ROW2COL */
-#define DIODE_DIRECTION COL2ROW
-
-/* number of backlight levels */
-#define BACKLIGHT_PIN B5
-#ifdef BACKLIGHT_PIN
-#define BACKLIGHT_LEVELS 3
-#endif
-
-/* Set 0 if debouncing isn't needed */
-#define DEBOUNCING_DELAY 5
-
-/* Mechanical locking support. Use KC_LCAP, KC_LNUM or KC_LSCR instead in keymap */
-#define LOCKING_SUPPORT_ENABLE
-
-/* Locking resynchronize hack */
-#define LOCKING_RESYNC_ENABLE
-
-#ifdef RGB_DI_PIN
-#define RGBLIGHT_ANIMATIONS
-#define RGBLIGHT_HUE_STEP 8
-#define RGBLIGHT_SAT_STEP 8
-#define RGBLIGHT_VAL_STEP 8
-#endif
-#define RGB_DI_PIN D3
-
-#define RGBLED_NUM 10
-
-#endif
diff --git a/keyboards/dilly/dilly.c b/keyboards/dilly/dilly.c
deleted file mode 100644
index 89affe850..000000000
--- a/keyboards/dilly/dilly.c
+++ /dev/null
@@ -1 +0,0 @@
-#include "dilly.h"
diff --git a/keyboards/dilly/dilly.h b/keyboards/dilly/dilly.h
deleted file mode 100644
index c7cc4aa72..000000000
--- a/keyboards/dilly/dilly.h
+++ /dev/null
@@ -1,31 +0,0 @@
-#ifndef DILLY_H
-#define DILLY_H
-
-#include "quantum.h"
-
-#define LAYOUT_ortho_3x10( \
- A1, A2, A3, A4, A5, A6, A7, A8, A9, A10, \
- B1, B2, B3, B4, B5, B6, B7, B8, B9, B10, \
- C1, C2, C3, C4, C5, C6, C7, C8, C9, C10 \
-) { \
- { A1, A2, A3, A4, A5 }, \
- { B1, B2, B3, B4, B5 }, \
- { C1, C2, C3, C4, C5 }, \
- { A10, A9, A8, A7, A6 }, \
- { B10, B9, B8, B7, B6 }, \
- { C10, C9, C8, C7, C6 } \
-}
-
-// Used to create a keymap using only KC_ prefixed keys
-#define LAYOUT_kc( \
- A1, A2, A3, A4, A5, A6, A7, A8, A9, A10, \
- B1, B2, B3, B4, B5, B6, B7, B8, B9, B10, \
- C1, C2, C3, C4, C5, C6, C7, C8, C9, C10 \
-) \
- LAYOUT_ortho_3x10( \
- KC_##A1, KC_##A2, KC_##A3, KC_##A4, KC_##A5, KC_##A6, KC_##A7, KC_##A8, KC_##A9, KC_##A10, \
- KC_##B1, KC_##B2, KC_##B3, KC_##B4, KC_##B5, KC_##B6, KC_##B7, KC_##B8, KC_##B9, KC_##B10, \
- KC_##C1, KC_##C2, KC_##C3, KC_##C4, KC_##C5, KC_##C6, KC_##C7, KC_##C8, KC_##C9, KC_##C10 \
- )
-
-#endif
diff --git a/keyboards/dilly/info.json b/keyboards/dilly/info.json
deleted file mode 100644
index 6b67d45b9..000000000
--- a/keyboards/dilly/info.json
+++ /dev/null
@@ -1,13 +0,0 @@
-{
- "keyboard_name": "Dilly",
- "url": "",
- "maintainer": "qmk",
- "width": 10,
- "height": 3,
- "layouts": {
- "LAYOUT_ortho_3x10": {
- "key_count": 30,
- "layout": [{"x":0, "y":0}, {"x":1, "y":0}, {"x":2, "y":0}, {"x":3, "y":0}, {"x":4, "y":0}, {"x":5, "y":0}, {"x":6, "y":0}, {"x":7, "y":0}, {"x":8, "y":0}, {"x":9, "y":0}, {"x":0, "y":1}, {"x":1, "y":1}, {"x":2, "y":1}, {"x":3, "y":1}, {"x":4, "y":1}, {"x":5, "y":1}, {"x":6, "y":1}, {"x":7, "y":1}, {"x":8, "y":1}, {"x":9, "y":1}, {"x":0, "y":2}, {"x":1, "y":2}, {"x":2, "y":2}, {"x":3, "y":2}, {"x":4, "y":2}, {"x":5, "y":2}, {"x":6, "y":2}, {"x":7, "y":2}, {"x":8, "y":2}, {"x":9, "y":2}]
- }
- }
-}
diff --git a/keyboards/dilly/keymaps/default/config.h b/keyboards/dilly/keymaps/default/config.h
deleted file mode 100644
index 7fa3bf328..000000000
--- a/keyboards/dilly/keymaps/default/config.h
+++ /dev/null
@@ -1,6 +0,0 @@
-#ifndef CONFIG_USER_H
-#define CONFIG_USER_H
-
-#include "../../config.h"
-
-#endif
diff --git a/keyboards/dilly/keymaps/default/keymap.c b/keyboards/dilly/keymaps/default/keymap.c
deleted file mode 100644
index 03b539e3d..000000000
--- a/keyboards/dilly/keymaps/default/keymap.c
+++ /dev/null
@@ -1,69 +0,0 @@
-#include QMK_KEYBOARD_H
-
-extern keymap_config_t keymap_config;
-
-#define _BASE 0
-#define _FN1 1
-#define _FN2 2
-#define _FN3 3
-#define _FN4 4
-#define _FN5 5
-
-#define _______ KC_TRNS
-
-// Tap-Hold keys
-#define KC_ASFT MT(MOD_LSFT, KC_A)
-#define KC_F_L3 LT(_FN3, KC_F)
-#define KC_ZCTL MT(MOD_LCTL, KC_Z)
-#define KC_XALT MT(MOD_LALT, KC_X)
-#define KC_CGUI MT(MOD_LGUI, KC_C)
-#define KC_V_L4 LT(_FN4, KC_V)
-#define KC_SPL2 LT(_FN2, KC_SPC)
-#define KC_B_L1 LT(_FN1, KC_B)
-#define KC_N_L5 LT(_FN5, KC_N)
-#define KC_MALT MT(MOD_RALT, KC_M)
-#define KC_BSCT MT(MOD_RCTL, KC_BSPC)
-#define KC_ENTS MT(MOD_RSFT, KC_ENT)
-#define KC_ESCS MT(MOD_RSFT, KC_ESC)
-
-#define KC_GUIC LGUI(KC_C)
-
-const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
-
- [_BASE] = LAYOUT_ortho_3x10(
- KC_Q, KC_W, KC_E, KC_R, KC_T, KC_Y, KC_U, KC_I, KC_O, KC_P,
- KC_ASFT, KC_S, KC_D, KC_F_L3, KC_G, KC_H, KC_J, KC_K, KC_L, KC_ESCS,
- KC_ZCTL, KC_XALT, KC_CGUI, KC_V_L4, KC_SPL2, KC_B_L1, KC_N_L5, KC_MALT, KC_BSCT, KC_ENTS
- ),
-
- [_FN1] = LAYOUT_ortho_3x10(
- KC_1, KC_2, KC_3, KC_4, KC_5, KC_6, KC_7, KC_8, KC_9, KC_0,
- KC_F1, KC_F2, KC_F3, KC_F4, KC_F5, KC_F6, KC_F7, KC_F8, KC_F9, KC_F10,
- _______, _______, _______, _______, KC_BSPC, _______, _______, _______, _______, _______
- ),
-
- [_FN2] = LAYOUT_ortho_3x10(
- KC_EXLM, KC_AT, KC_HASH, KC_DLR, KC_PERC, KC_CIRC, KC_AMPR, KC_ASTR, KC_LPRN, KC_RPRN,
- KC_F11, KC_F12, _______, _______, _______, _______, _______, _______, _______, KC_GRV,
- _______, _______, _______, _______, _______, KC_DEL, _______, _______, _______, _______
- ),
-
- [_FN3] = LAYOUT_ortho_3x10(
- _______, _______, _______, _______, _______, KC_MINS, KC_EQL, KC_LBRC, KC_RBRC, KC_BSLS,
- KC_TAB, _______, _______, _______, _______, KC_COMM, KC_DOT, KC_SLSH, KC_SCLN, KC_QUOT,
- _______, _______, _______, _______, KC_BSPC, _______, KC_LEFT, KC_DOWN, KC_UP, KC_RGHT
- ),
-
- [_FN4] = LAYOUT_ortho_3x10(
- _______, _______, _______, _______, _______, KC_UNDS, KC_PLUS, KC_LCBR, KC_RCBR, KC_PIPE,
- KC_TAB, _______, _______, _______, _______, KC_LT, KC_GT, KC_QUES, KC_COLN, KC_DQUO,
- _______, _______, KC_GUIC, _______, KC_BSPC, _______, KC_HOME, KC_PGDN, KC_PGUP, KC_END
- ),
-
- [_FN5] = LAYOUT_ortho_3x10(
- RGB_TOG, RGB_MOD, _______, RESET, RGB_HUI, RGB_SAI, RGB_VAI, _______, _______, _______,
- _______, _______, DEBUG, _______, RGB_HUD, RGB_SAD, RGB_VAD, _______, _______, _______,
- BL_STEP, _______, KC_GUIC, _______, _______, _______, _______, _______, _______, _______
- )
-
-};
diff --git a/keyboards/dilly/keymaps/default/rules.mk b/keyboards/dilly/keymaps/default/rules.mk
deleted file mode 100644
index 1e3cebb14..000000000
--- a/keyboards/dilly/keymaps/default/rules.mk
+++ /dev/null
@@ -1 +0,0 @@
-RGBLIGHT_ENABLE = yes
diff --git a/keyboards/dilly/keymaps/delmo/config.h b/keyboards/dilly/keymaps/delmo/config.h
deleted file mode 100644
index 4d704c17e..000000000
--- a/keyboards/dilly/keymaps/delmo/config.h
+++ /dev/null
@@ -1,10 +0,0 @@
-#ifndef CONFIG_USER_H
-#define CONFIG_USER_H
-
-#include "../../config.h"
-
-#define TAPPING_TERM 200
-#define RETRO_TAPPING
-#define PERMISSIVE_HOLD
-
-#endif
diff --git a/keyboards/dilly/keymaps/delmo/keymap.c b/keyboards/dilly/keymaps/delmo/keymap.c
deleted file mode 100644
index d3e8c5daf..000000000
--- a/keyboards/dilly/keymaps/delmo/keymap.c
+++ /dev/null
@@ -1,106 +0,0 @@
-#include QMK_KEYBOARD_H
-
-extern keymap_config_t keymap_config;
-
-#define _BASE 0
-#define _FN1 1
-#define _FN2 2
-#define _FN3 3
-#define _FN4 4
-#define _FN5 5
-
-#define KC_ KC_TRNS
-#define _______ KC_TRNS
-
-// Tap-Hold keys
-//#define KC_ASFT MT(MOD_LSFT, KC_A)
-#define KC_F_L3 LT(_FN3, KC_F)
-#define KC_ZCTL MT(MOD_LCTL, KC_Z)
-#define KC_XALT MT(MOD_LALT, KC_X)
-//#define KC_CGUI MT(MOD_LGUI, KC_C)
-#define KC_V_L4 LT(_FN4, KC_V)
-#define KC_SPL2 LT(_FN2, KC_SPC)
-#define KC_B_L1 LT(_FN1, KC_B)
-#define KC_N_L5 LT(_FN5, KC_N)
-//#define KC_MALT MT(MOD_RALT, KC_M)
-//#define KC_BSCT MT(MOD_RCTL, KC_BSPC)
-#define KC_ENTS MT(MOD_RSFT, KC_ENT)
-#define KC_BSCS MT(MOD_RSFT, KC_BSPC)
-
-#define KC_GUIC LGUI(KC_C)
-
-#define KC_RST RESET
-#define KC_BL_S BL_STEP
-#define KC_DBUG DEBUG
-#define KC_RTOG RGB_TOG
-#define KC_RMOD RGB_MOD
-#define KC_RHUI RGB_HUI
-#define KC_RHUD RGB_HUD
-#define KC_RSAI RGB_SAI
-#define KC_RSAD RGB_SAD
-#define KC_RVAI RGB_VAI
-#define KC_RVAD RGB_VAD
-
-const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
-
- [_BASE] = LAYOUT_kc(
- //,----+----+----+----+----+----+----+----+----+----.
- Q , W , E , R , T , Y , U , I , O , P ,
- //|----+----+----+----+----+----+----+----+----+----|
- A , S , D ,F_L3, G , H , J , K , L ,BSCS,
- //|----+----+----+----+----+----+----+----+----+----|
- ZCTL,XALT,C ,V_L4,B_L1,SPL2,N_L5,M ,DOT ,ENTS
- //`----+----+----+----+----+----+----+----+----+----'
- ),
-
- [_FN1] = LAYOUT_kc(
- //,----+----+----+----+----+----+----+----+----+----.
- 1 , 2 , 3 , 4 , 5 , 6 , 7 , 8 , 9 , 0 ,
- //|----+----+----+----+----+----+----+----+----+----|
- F1 , F2 , F3 , F4 , F5 , F6 , F7 , F8 , F9 ,F10 ,
- //|----+----+----+----+----+----+----+----+----+----|
- , , , , ,BSPC, , , ,CAPS
- //`----+----+----+----+----+----+----+----+----+----'
- ),
-
- [_FN2] = LAYOUT_kc(
- //,----+----+----+----+----+----+----+----+----+----.
- EXLM, AT ,HASH,DLR ,PERC,CIRC,AMPR,ASTR,LPRN,RPRN,
- //|----+----+----+----+----+----+----+----+----+----|
- F11 ,F12 , , , , , , , ,GRV ,
- //|----+----+----+----+----+----+----+----+----+----|
- , , , ,DEL , , , , ,
- //`----+----+----+----+----+----+----+----+----+----'
- ),
-
- [_FN3] = LAYOUT_kc(
- //,----+----+----+----+----+----+----+----+----+----.
- ESC , , , , ,MINS,EQL ,LBRC,RBRC,BSLS,
- //|----+----+----+----+----+----+----+----+----+----|
- TAB , , , , ,COMM,DOT ,SLSH,SCLN,QUOT,
- //|----+----+----+----+----+----+----+----+----+----|
- , , , ,BSPC, ,LEFT,DOWN, UP ,RGHT
- //`----+----+----+----+----+----+----+----+----+----'
- ),
-
- [_FN4] = LAYOUT_kc(
- //,----+----+----+----+----+----+----+----+----+----.
- , , , , ,UNDS,PLUS,LCBR,RCBR,PIPE,
- //|----+----+----+----+----+----+----+----+----+----|
- TAB , , , , , LT , GT ,QUES,COLN,DQUO,
- //|----+----+----+----+----+----+----+----+----+----|
- , ,GUIC, ,BSPC, ,HOME,PGDN,PGUP,END
- //`----+----+----+----+----+----+----+----+----+----'
- ),
-
- [_FN5] = LAYOUT_kc(
- //,----+----+----+----+----+----+----+----+----+----.
- RTOG,RMOD, ,RST ,RHUI,RSAI,RVAI, , , ,
- //|----+----+----+----+----+----+----+----+----+----|
- , ,DBUG, ,RHUD,RSAD,RVAD, , , ,
- //|----+----+----+----+----+----+----+----+----+----|
- BL_S, ,GUIC, , , , , , ,
- //`----+----+----+----+----+----+----+----+----+----'
- )
-
-}; \ No newline at end of file
diff --git a/keyboards/dilly/keymaps/delmo/rules.mk b/keyboards/dilly/keymaps/delmo/rules.mk
deleted file mode 100644
index 1e3cebb14..000000000
--- a/keyboards/dilly/keymaps/delmo/rules.mk
+++ /dev/null
@@ -1 +0,0 @@
-RGBLIGHT_ENABLE = yes
diff --git a/keyboards/dilly/keymaps/pletcher/config.h b/keyboards/dilly/keymaps/pletcher/config.h
deleted file mode 100644
index 805bef418..000000000
--- a/keyboards/dilly/keymaps/pletcher/config.h
+++ /dev/null
@@ -1,11 +0,0 @@
-#ifndef CONFIG_USER_H
-#define CONFIG_USER_H
-
-#include "../../config.h"
-
-#define AUTO_SHIFT_TIMEOUT 150
-#define NO_AUTO_SHIFT_SPECIAL
-#define NO_AUTO_SHIFT_NUMERIC
-#define USB_MAX_POWER_CONSUMPTION 50
-
-#endif
diff --git a/keyboards/dilly/keymaps/pletcher/keymap.c b/keyboards/dilly/keymaps/pletcher/keymap.c
deleted file mode 100644
index 4e7a5c89d..000000000
--- a/keyboards/dilly/keymaps/pletcher/keymap.c
+++ /dev/null
@@ -1,96 +0,0 @@
-#include QMK_KEYBOARD_H
-
-extern keymap_config_t keymap_config;
-
-#define _BASE 0
-#define _FN1 1
-#define _FN2 2
-#define _FN3 3
-#define _FN4 4
-#define _FN5 5
-
-#define KC_ KC_TRNS
-#define _______ KC_TRNS
-
-// Tap-Hold keys
-#define KC_F_L3 LT(_FN3, KC_F)
-#define KC_ZCTL MT(MOD_LCTL, KC_Z)
-#define KC_XALT MT(MOD_LALT, KC_X)
-#define KC_CGUI MT(MOD_LGUI, KC_C)
-#define KC_V_L4 LT(_FN4, KC_V)
-#define KC_SPL2 LT(_FN2, KC_SPC)
-#define KC_B_L1 LT(_FN1, KC_B)
-#define KC_N_L5 LT(_FN5, KC_N)
-#define KC_MALT MT(MOD_RALT, KC_M)
-#define KC_BSCT MT(MOD_RCTL, KC_BSPC)
-#define KC_ENTS MT(MOD_RSFT, KC_ENT)
-#define KC_ESCS MT(MOD_RSFT, KC_ESC)
-
-#define KC_GUIC LGUI(KC_C)
-
-#define KC_RST RESET
-#define KC_DBUG DEBUG
-
-const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
-
- [_BASE] = LAYOUT_kc(
- //,----+----+----+----+----+----+----+----+----+----.
- Q , W , E , R , T , Y , U , I , O , P ,
- //|----+----+----+----+----+----+----+----+----+----|
- A , S , D ,F_L3, G , H , J , K , L ,ESCS,
- //|----+----+----+----+----+----+----+----+----+----|
- ZCTL,XALT,CGUI,V_L4,SPL2,B_L1,N_L5,MALT,BSCT,ENTS
- //`----+----+----+----+----+----+----+----+----+----'
- ),
-
- [_FN1] = LAYOUT_kc(
- //,----+----+----+----+----+----+----+----+----+----.
- 1 , 2 , 3 , 4 , 5 , 6 , 7 , 8 , 9 , 0 ,
- //|----+----+----+----+----+----+----+----+----+----|
- F1 , F2 , F3 , F4 , F5 , F6 , F7 , F8 , F9 ,F10 ,
- //|----+----+----+----+----+----+----+----+----+----|
- , , , ,BSPC, , , , ,
- //`----+----+----+----+----+----+----+----+----+----'
- ),
-
- [_FN2] = LAYOUT_kc(
- //,----+----+----+----+----+----+----+----+----+----.
- EXLM, AT ,HASH,DLR ,PERC,CIRC,AMPR,ASTR,LPRN,RPRN,
- //|----+----+----+----+----+----+----+----+----+----|
- F11 ,F12 , , , , , , , ,GRV ,
- //|----+----+----+----+----+----+----+----+----+----|
- , , , ,TAB , DEL, , , ,
- //`----+----+----+----+----+----+----+----+----+----'
- ),
-
- [_FN3] = LAYOUT_kc(
- //,----+----+----+----+----+----+----+----+----+----.
- , , , , ,MINS,EQL ,LBRC,RBRC,BSLS,
- //|----+----+----+----+----+----+----+----+----+----|
- TAB , , , , ,COMM,DOT ,SLSH,SCLN,QUOT,
- //|----+----+----+----+----+----+----+----+----+----|
- , , , ,BSPC, ,LEFT,DOWN, UP ,RGHT
- //`----+----+----+----+----+----+----+----+----+----'
- ),
-
- [_FN4] = LAYOUT_kc(
- //,----+----+----+----+----+----+----+----+----+----.
- , , , , ,UNDS,PLUS,LCBR,RCBR,PIPE,
- //|----+----+----+----+----+----+----+----+----+----|
- TAB , , , , , LT , GT ,QUES,COLN,DQUO,
- //|----+----+----+----+----+----+----+----+----+----|
- , ,GUIC, ,BSPC, ,HOME,PGDN,PGUP,END
- //`----+----+----+----+----+----+----+----+----+----'
- ),
-
- [_FN5] = LAYOUT_kc(
- //,----+----+----+----+----+----+----+----+----+----.
- , , ,RST , , ,MSTP,VOLD,VOLU,MPLY,
- //|----+----+----+----+----+----+----+----+----+----|
- , ,DBUG, , , , ,ASDN,ASUP,ASRP,
- //|----+----+----+----+----+----+----+----+----+----|
- , ,GUIC, , , , , , ,ASTG
- //`----+----+----+----+----+----+----+----+----+----'
- )
-
-};
diff --git a/keyboards/dilly/keymaps/pletcher/rules.mk b/keyboards/dilly/keymaps/pletcher/rules.mk
deleted file mode 100644
index 9b9dd8341..000000000
--- a/keyboards/dilly/keymaps/pletcher/rules.mk
+++ /dev/null
@@ -1,2 +0,0 @@
-AUTO_SHIFT_ENABLE = yes
-RGBLIGHT_ENABLE = no
diff --git a/keyboards/dilly/rules.mk b/keyboards/dilly/rules.mk
deleted file mode 100644
index 812362567..000000000
--- a/keyboards/dilly/rules.mk
+++ /dev/null
@@ -1,58 +0,0 @@
-# MCU name
-MCU = atmega32u4
-
-# Processor frequency.
-# This will define a symbol, F_CPU, in all source code files equal to the
-# processor frequency in Hz. You can then use this symbol in your source code to
-# calculate timings. Do NOT tack on a 'UL' at the end, this will be done
-# automatically to create a 32-bit value in your source code.
-#
-# This will be an integer division of F_USB below, as it is sourced by
-# F_USB after it has run through any CPU prescalers. Note that this value
-# does not *change* the processor frequency - it should merely be updated to
-# reflect the processor speed set externally so that the code can use accurate
-# software delays.
-F_CPU = 16000000
-
-#
-# LUFA specific
-#
-# Target architecture (see library "Board Types" documentation).
-ARCH = AVR8
-
-# Input clock frequency.
-# This will define a symbol, F_USB, in all source code files equal to the
-# input clock frequency (before any prescaling is performed) in Hz. This value may
-# differ from F_CPU if prescaling is used on the latter, and is required as the
-# raw input clock is fed directly to the PLL sections of the AVR for high speed
-# clock generation for the USB and other AVR subsections. Do NOT tack on a 'UL'
-# at the end, this will be done automatically to create a 32-bit value in your
-# source code.
-#
-# If no clock division is performed on the input clock inside the AVR (via the
-# CPU clock adjust registers or the clock division fuses), this will be equal to F_CPU.
-F_USB = $(F_CPU)
-
-# Interrupt driven control endpoint task(+60)
-OPT_DEFS += -DINTERRUPT_CONTROL_ENDPOINT
-
-
-# Boot Section Size in *bytes*
-OPT_DEFS += -DBOOTLOADER_SIZE=4096
-
-
-# Build Options
-# comment out to disable the options.
-#
-BOOTMAGIC_ENABLE = yes # Virtual DIP switch configuration(+1000)
-MOUSEKEY_ENABLE = yes # Mouse keys(+4700)
-EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
-CONSOLE_ENABLE = no # Console for debug(+400)
-COMMAND_ENABLE = no # Commands for debug and configuration
-SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
-NKRO_ENABLE = yes # USB Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
-BACKLIGHT_ENABLE = yes # Enable keyboard backlight functionality
-AUDIO_ENABLE = no
-RGBLIGHT_ENABLE = yes
-
-LAYOUTS = ortho_3x10