aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/duck/lightsaver/indicator_leds.c
diff options
context:
space:
mode:
authorMechMerlin <30334081+mechmerlin@users.noreply.github.com>2019-04-03 10:17:25 -0700
committerDrashna Jaelre <drashna@live.com>2019-04-03 10:17:25 -0700
commitcb2f2fd258011e6637ed182f484a4317ac510db8 (patch)
treee0ffc4ff80b4467110787575ea581daa3fa140af /keyboards/duck/lightsaver/indicator_leds.c
parentcaefb1c61eca10dcb70ca6481a8a592057de7318 (diff)
downloadfirmware-cb2f2fd258011e6637ed182f484a4317ac510db8.tar.gz
firmware-cb2f2fd258011e6637ed182f484a4317ac510db8.tar.bz2
firmware-cb2f2fd258011e6637ed182f484a4317ac510db8.zip
[Keyboard] Small Refactor of Duck boards (#5521)
* first [ass at pulling out common duck library functions * use new library in jetfire * use new library in duck lightsaver * use new library in octagon v2 * put Device into the library * refactor send_value * refactor send_value and send_color * use pragma once * use pragma once * use pragma once * use pragma once * rename backlight_led to indicator_leds to match with other duck boards * rename enum * make #define names consistent * rename ducklib to duck_led * update rules.mk ?= to = * put rgb in the correct order * add debounce debugging printouts * turn on bootmagic lite and set it to the top left most key commonly programmed as Escape * add reset key documentation * fix that typo * Update keyboards/duck/duck_led/duck_led.c Co-Authored-By: mechmerlin <30334081+mechmerlin@users.noreply.github.com> * include the correct library
Diffstat (limited to 'keyboards/duck/lightsaver/indicator_leds.c')
-rw-r--r--keyboards/duck/lightsaver/indicator_leds.c49
1 files changed, 21 insertions, 28 deletions
diff --git a/keyboards/duck/lightsaver/indicator_leds.c b/keyboards/duck/lightsaver/indicator_leds.c
index 0a54e151e..5d2e1ad9f 100644
--- a/keyboards/duck/lightsaver/indicator_leds.c
+++ b/keyboards/duck/lightsaver/indicator_leds.c
@@ -18,17 +18,12 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
#include <avr/io.h>
#include <stdbool.h>
#include <util/delay.h>
+#include "duck_led/duck_led.h"
-#define T1H 900
-#define T1L 600
-#define T0H 400
-#define T0L 900
-#define RES 6000
-
-#define NS_PER_SEC (1000000000L)
-#define CYCLES_PER_SEC (F_CPU)
-#define NS_PER_CYCLE (NS_PER_SEC / CYCLES_PER_SEC)
-#define NS_TO_CYCLES(n) ((n) / NS_PER_CYCLE)
+#define LED_T1H 900
+#define LED_T1L 600
+#define LED_T0H 400
+#define LED_T0L 900
void send_bit_d4(bool bitVal) {
if(bitVal) {
@@ -44,8 +39,8 @@ void send_bit_d4(bool bitVal) {
::
[port] "I" (_SFR_IO_ADDR(PORTD)),
[bit] "I" (4),
- [onCycles] "I" (NS_TO_CYCLES(T1H) - 2),
- [offCycles] "I" (NS_TO_CYCLES(T1L) - 2));
+ [onCycles] "I" (NS_TO_CYCLES(LED_T1H) - 2),
+ [offCycles] "I" (NS_TO_CYCLES(LED_T1L) - 2));
} else {
asm volatile (
"sbi %[port], %[bit] \n\t"
@@ -59,33 +54,31 @@ void send_bit_d4(bool bitVal) {
::
[port] "I" (_SFR_IO_ADDR(PORTD)),
[bit] "I" (4),
- [onCycles] "I" (NS_TO_CYCLES(T0H) - 2),
- [offCycles] "I" (NS_TO_CYCLES(T0L) - 2));
+ [onCycles] "I" (NS_TO_CYCLES(LED_T0H) - 2),
+ [offCycles] "I" (NS_TO_CYCLES(LED_T0L) - 2));
}
}
-void show(void) {
- _delay_us((RES / 1000UL) + 1);
-}
-
-void send_value(uint8_t byte) {
+void send_value(uint8_t byte, enum Device device) {
for(uint8_t b = 0; b < 8; b++) {
- send_bit_d4(byte & 0b10000000);
- byte <<= 1;
+ if(device == Device_STATUSLED) {
+ send_bit_d4(byte & 0b10000000);
+ byte <<= 1;
+ }
}
}
-void send_color(uint8_t r, uint8_t g, uint8_t b) {
- send_value(g);
- send_value(r);
- send_value(b);
+void send_color(uint8_t r, uint8_t g, uint8_t b, enum Device device) {
+ send_value(r, device);
+ send_value(g, device);
+ send_value(b, device);
}
void indicator_leds_set(bool leds[8]) {
cli();
- send_color(leds[1] ? 255 : 0, leds[2] ? 255 : 0, leds[0] ? 255 : 0);
- send_color(leds[4] ? 255 : 0, leds[5] ? 255 : 0, leds[3] ? 255 : 0);
- send_color(leds[6] ? 255 : 0, leds[7] ? 255 : 0, 0);
+ send_color(leds[1] ? 255 : 0, leds[2] ? 255 : 0, leds[0] ? 255 : 0, Device_STATUSLED);
+ send_color(leds[4] ? 255 : 0, leds[5] ? 255 : 0, leds[3] ? 255 : 0, Device_STATUSLED);
+ send_color(leds[6] ? 255 : 0, leds[7] ? 255 : 0, 0, Device_STATUSLED);
sei();
show();
}