aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/eagle_viper/v2/readme.md
diff options
context:
space:
mode:
authorMechMerlin <30334081+mechmerlin@users.noreply.github.com>2018-01-03 09:17:09 -0800
committerJack Humbert <jack.humb@gmail.com>2018-01-03 12:17:09 -0500
commitcbc5de67be36d5b9b3872a3c41c9619b93b04b9f (patch)
tree32229052d1fa08a19f49c41112c6724b0245be4a /keyboards/eagle_viper/v2/readme.md
parent9cb1d36974b7ea4c380c0b7818812f6f5aae56c1 (diff)
downloadfirmware-cbc5de67be36d5b9b3872a3c41c9619b93b04b9f.tar.gz
firmware-cbc5de67be36d5b9b3872a3c41c9619b93b04b9f.tar.bz2
firmware-cbc5de67be36d5b9b3872a3c41c9619b93b04b9f.zip
Duck Eagle/Viper V2 support (#2216)
* Preliminary support for Duck Eagle/Viper V2 60% board. This is a copy of the octagon/v2 with things changed to reach a compiling state * Get a 60% keymap compiling, this might not be what the eagle/viper really supports * Update readme to point to correct GeekHack link * Get keymap working on a Duck Eagle * Add code submitted by profanum429 - Add HHKB style top row to v2.h - Modify read_rows function to take into accout the caps lock firmware key - Modify default keymap to match the new v2.h - Adjust readmes * Fix bug related to col 0 not working * Add keymap for mechmerlin * Add profanum429's viper hhkb layout * Add visual representation for mechmerlin layout Add navigation keys to keymap * Add a better visual representation to the mechmerlin keymap * Add profanum429's Viper layout! * Updated profanum429 keymap to match a full HHKB Enabled media keys in rules.mk * Revert "Updated profanum429 keymap to match a full HHKB" This reverts commit ed914160d7e27e6412d2c7c5c1c4fa0a04838667. * Fix default keymap for Eagle * Enable extra keys for audio control support * Modified timings in indicator_leds to accomodate the WS2811S chips on the Eagle/Viper2 PCBs at 800kHz with a 16mHz clock Modified the backlight settings to not interfere with the default RGB underglow code from QMK Modified the order of the LEDs in the LED status bar at the top of the Eagle/Viper2 PCBs (3,2,1,6,5,4,8,7 order) * Cleaned up indicator code to remove unused functions as the RGB underglow uses the default driver provided by QMK Commented out backlighting code in v2.c * update readmes to reflect profanum's awesome contributions and fix typo in make instructions * Remove custom RGB logic and just rely on QMK RGB underglow. We'll leave the backlighting in place for now
Diffstat (limited to 'keyboards/eagle_viper/v2/readme.md')
-rw-r--r--keyboards/eagle_viper/v2/readme.md30
1 files changed, 30 insertions, 0 deletions
diff --git a/keyboards/eagle_viper/v2/readme.md b/keyboards/eagle_viper/v2/readme.md
new file mode 100644
index 000000000..b613b63b9
--- /dev/null
+++ b/keyboards/eagle_viper/v2/readme.md
@@ -0,0 +1,30 @@
+# Duck Eagle/Viper V2
+
+Non official firmware for custom Korean keyboard with 60% key layout made by Duck.
+Group buy was run November 2016 via [geekhack](https://geekhack.org/index.php?topic=86087.0) with 100 keyboards total.
+
+Keyboard Maintainer: [MechMerlin](https://github.com/mechmerlin)
+Hardware Supported: Duck Eagle/Viper PCB Ver 2.0, Atmega32u4
+Hardware Availability: Wait until GB of the next revision
+
+Make example for this keyboard (after setting up your build environment):
+
+ make eagle_viper/v2:default
+
+See [build environment setup](https://docs.qmk.fm/build_environment_setup.html) then the [make instructions](https://docs.qmk.fm/make_instructions.html) for more information.
+
+## Hardware Notes
+
+The Duck Eagle/Viper V2 PCB consists of:
+
+### Microchips
+2 74HC237D 3-to-8 line decoders
+1 Atmega32u4 microcontroller
+2 WS2811 LED controller
+
+## Notes
+Thanks to Ralf Schmitt for previous implementations in his [TMK fork](https://github.com/xauser/tmk_keyboard/tree/xauser/) and few helping words.
+
+Based heavily on Rasmus Schults [Duck Lightsaver QMK Port](https://github.com/qmk/qmk_firmware/tree/master/keyboards/lightsaver)
+
+Special thanks to profanum429 for debugging help and contributions to support the Viper and LED indicators.