aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/efreet/rules.mk
diff options
context:
space:
mode:
authorAmber Holly <halcyonsilver@gmail.com>2019-09-25 21:06:57 +0100
committerDrashna Jaelre <drashna@live.com>2019-09-25 13:06:57 -0700
commit475f832b0f434615b9b32ca3f600c4b770d6e1e5 (patch)
tree34f7941509148d984e7debe8c3eb1ae4b15b9076 /keyboards/efreet/rules.mk
parenta76a79b8275740e218a31e1e45ec22bfeb80d3ba (diff)
downloadfirmware-475f832b0f434615b9b32ca3f600c4b770d6e1e5.tar.gz
firmware-475f832b0f434615b9b32ca3f600c4b770d6e1e5.tar.bz2
firmware-475f832b0f434615b9b32ca3f600c4b770d6e1e5.zip
[Keyboard] Add Efreet keyboard (#6811)
* start wraith firmware * completed initial setup * added amber keymap to wraith * fixed LEDs, wrote readme files * reverted bootloader type after troubleshooting * decapitalised files and directory as per qmk standards * Update Wraith keyboard folder - Add timer keymap with documentation - Remove boilerplate in rules.mk, ready for pull request - Update info.json with ISO and ANSI layouts, ready for QMK Configurator * Add Efreet keyboard * Remove unnecessary keyboard folders * Enable community layout support for Efreet - Rename LAYOUT macro to LAYOUT_ortho_4x12 - Add layout macro named LAYOUT_planck_mit - Remove unnecessary magic key command, as we are using the default - Fix readme.md formatting for GitHub * Fix community layout support for Efreet - Fix 2u spacebar keycodes in LAYOUT_planck_mit to denote absence of switch - Turn on Community Layouts in rules.mk * Update default keymap.c to use community layout
Diffstat (limited to 'keyboards/efreet/rules.mk')
-rw-r--r--keyboards/efreet/rules.mk32
1 files changed, 32 insertions, 0 deletions
diff --git a/keyboards/efreet/rules.mk b/keyboards/efreet/rules.mk
new file mode 100644
index 000000000..f3c51f7a6
--- /dev/null
+++ b/keyboards/efreet/rules.mk
@@ -0,0 +1,32 @@
+# MCU name
+MCU = atmega32u2
+
+# Bootloader selection
+# Teensy halfkay
+# Pro Micro caterina
+# Atmel DFU atmel-dfu
+# LUFA DFU lufa-dfu
+# QMK DFU qmk-dfu
+# ATmega32A bootloadHID
+# ATmega328P USBasp
+BOOTLOADER = atmel-dfu
+
+# Build Options
+# change yes to no to disable
+#
+BOOTMAGIC_ENABLE = yes # Virtual DIP switch configuration(+1000)
+MOUSEKEY_ENABLE = yes # Mouse keys(+4700)
+EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
+CONSOLE_ENABLE = no # Console for debug(+400)
+COMMAND_ENABLE = yes # Commands for debug and configuration
+NKRO_ENABLE = yes # USB Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+BACKLIGHT_ENABLE = yes # Enable keyboard backlight functionality
+RGBLIGHT_ENABLE = no # Enable keyboard RGB underglow
+MIDI_ENABLE = no # MIDI support (+2400 to 4200, depending on config)
+UNICODE_ENABLE = no # Unicode
+BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
+AUDIO_ENABLE = no # Audio output on port C6
+FAUXCLICKY_ENABLE = no # Use buzzer to emulate clicky switches
+HD44780_ENABLE = no # Enable support for HD44780 based LCDs (+400)
+
+LAYOUTS = ortho_4x12 planck_mit