aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/ergo42/rules.mk
diff options
context:
space:
mode:
authorzvecr <git@zvecr.com>2020-01-17 18:50:58 +0000
committerzvecr <git@zvecr.com>2020-01-17 18:50:58 +0000
commit952e805edb5b5c42a8bbe35b6689c28943a53858 (patch)
tree6d0056c1f64b0504fbe1c08596ec5ec0871f527f /keyboards/ergo42/rules.mk
parent619ee543b8093f643585870db87bad06630c39d4 (diff)
downloadfirmware-952e805edb5b5c42a8bbe35b6689c28943a53858.tar.gz
firmware-952e805edb5b5c42a8bbe35b6689c28943a53858.tar.bz2
firmware-952e805edb5b5c42a8bbe35b6689c28943a53858.zip
Initial refactor of ergo42 to split common
Diffstat (limited to 'keyboards/ergo42/rules.mk')
-rw-r--r--keyboards/ergo42/rules.mk38
1 files changed, 16 insertions, 22 deletions
diff --git a/keyboards/ergo42/rules.mk b/keyboards/ergo42/rules.mk
index a02e3ca74..3f55da67a 100644
--- a/keyboards/ergo42/rules.mk
+++ b/keyboards/ergo42/rules.mk
@@ -12,32 +12,26 @@ MCU = atmega32u4
BOOTLOADER = caterina
# Build Options
-# change to "no" to disable the options, or define them in the Makefile in
-# the appropriate keymap folder that will get included automatically
+# change yes to no to disable
#
-BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration(+1000)
-MOUSEKEY_ENABLE = yes # Mouse keys(+4700)
-EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
-CONSOLE_ENABLE = no # Console for debug(+400)
+BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration
+MOUSEKEY_ENABLE = yes # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = no # Console for debug
COMMAND_ENABLE = yes # Commands for debug and configuration
-NKRO_ENABLE = no # Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
-BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
-MIDI_ENABLE = no # MIDI controls
-AUDIO_ENABLE = no # Audio output on port C6
-UNICODE_ENABLE = no # Unicode
-BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
-RGBLIGHT_ENABLE = no # Enable WS2812 RGB underlight.
-SUBPROJECT_rev1 = yes
-USE_I2C = yes
# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
-SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+# if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+NKRO_ENABLE = no # USB Nkey Rollover
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+RGBLIGHT_ENABLE = no # Enable keyboard RGB underglow
+MIDI_ENABLE = no # MIDI support
+BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
+AUDIO_ENABLE = no # Audio output on port C6
+FAUXCLICKY_ENABLE = no # Use buzzer to emulate clicky switches
+HD44780_ENABLE = no # Enable support for HD44780 based LCDs
-CUSTOM_MATRIX = yes
-SRC += matrix.c \
- i2c.c \
- split_util.c \
- serial.c \
- ssd1306.c
+SPLIT_KEYBOARD = yes
LAYOUTS = ortho_4x14