aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/ergodox_infinity/rules.mk
diff options
context:
space:
mode:
authorRyan <fauxpark@gmail.com>2020-08-12 12:28:20 +1000
committerGitHub <noreply@github.com>2020-08-12 12:28:20 +1000
commite2d4cd1a41c667da186891e3dbaf535c6b0717df (patch)
tree8ae44fc6f6b80efb522ca523862ce511eab1161e /keyboards/ergodox_infinity/rules.mk
parent98e1e18f6bcae6977ef56747243158eb94c6bd69 (diff)
downloadfirmware-e2d4cd1a41c667da186891e3dbaf535c6b0717df.tar.gz
firmware-e2d4cd1a41c667da186891e3dbaf535c6b0717df.tar.bz2
firmware-e2d4cd1a41c667da186891e3dbaf535c6b0717df.zip
Add Kiibohd bootloader type to bootloader.mk (#9908)
Diffstat (limited to 'keyboards/ergodox_infinity/rules.mk')
-rw-r--r--keyboards/ergodox_infinity/rules.mk18
1 files changed, 2 insertions, 16 deletions
diff --git a/keyboards/ergodox_infinity/rules.mk b/keyboards/ergodox_infinity/rules.mk
index 31bc20454..572bda2a9 100644
--- a/keyboards/ergodox_infinity/rules.mk
+++ b/keyboards/ergodox_infinity/rules.mk
@@ -1,32 +1,18 @@
# MCU name
MCU = MK20DX256
-# Linker script to use
-# - it should exist either in <chibios>/os/common/ports/ARMCMx/compilers/GCC/ld/
-# or <this_dir>/ld/
-# - NOTE: a custom ld script is needed for EEPROM on Teensy LC
-# - LDSCRIPT =
-# - MKL26Z64 for Teensy LC
-# - MK20DX128 for Teensy 3.0
-# - MK20DX256 for Teensy 3.1 and 3.2
-# - MK20DX128BLDR4 for Infinity 60% with Kiibohd bootloader
-# - MK20DX256BLDR8 for Infinity ErgoDox with Kiibohd bootloader
-MCU_LDSCRIPT = MK20DX256BLDR8
-
# Vector table for application
# 0x00000000-0x00001000 area is occupied by bootlaoder.*/
# The CORTEX_VTOR... is needed only for MCHCK/Infinity KB
OPT_DEFS += -DCORTEX_VTOR_INIT=0x00002000
-BOOTLOADER = dfu
+# Bootloader selection
+BOOTLOADER = kiibohd
# Build Options
# comment out to disable the options.
#
-DFU_ARGS = -d 1c11:b007
-DFU_SUFFIX_ARGS = -p b007 -v 1c11
-
BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration
MOUSEKEY_ENABLE = yes # Mouse keys
EXTRAKEY_ENABLE = yes # Audio control and System control