aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/ergosaurus/ergosaurus.c
diff options
context:
space:
mode:
authorCody Bender <50554676+cfbender@users.noreply.github.com>2020-01-30 02:16:11 -0700
committerGitHub <noreply@github.com>2020-01-30 01:16:11 -0800
commit6d5812a86c7eaa3e84d8a69126aa04195713be62 (patch)
treea4c0a6ab924d1549b016942d3fba917bd8a2763f /keyboards/ergosaurus/ergosaurus.c
parent1249594cf0b09a45f28593c75f9d8f413ccf0424 (diff)
downloadfirmware-6d5812a86c7eaa3e84d8a69126aa04195713be62.tar.gz
firmware-6d5812a86c7eaa3e84d8a69126aa04195713be62.tar.bz2
firmware-6d5812a86c7eaa3e84d8a69126aa04195713be62.zip
[Keyboard] Add Ergosaurus Support (#8013)
Initialize config * Update matrix size * Update Keymap * Rename files to remove hyphen * Rename board and folders * Fix ergosaurus.h typo * Fix ergosaurus.h layout matrix * Update column pins * Fixed ergosaurus * Add Reggie layout * Update Ergo keymap * Update with fixes from PR #8013 * Fix KeyHive link * Remove config.h and extra whitespace from README * Update PID, README and rules spacing * Update rules.mk
Diffstat (limited to 'keyboards/ergosaurus/ergosaurus.c')
-rw-r--r--keyboards/ergosaurus/ergosaurus.c17
1 files changed, 17 insertions, 0 deletions
diff --git a/keyboards/ergosaurus/ergosaurus.c b/keyboards/ergosaurus/ergosaurus.c
new file mode 100644
index 000000000..4c3145512
--- /dev/null
+++ b/keyboards/ergosaurus/ergosaurus.c
@@ -0,0 +1,17 @@
+
+/* Copyright 2019 cfbender
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+#include "ergosaurus.h"