aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/exclusive/e6_rgb/config.h
diff options
context:
space:
mode:
authoryulei <yuleiz@gmail.com>2020-01-08 16:11:45 +0800
committerJames Young <18669334+noroadsleft@users.noreply.github.com>2020-01-08 00:11:45 -0800
commitfe860131dd60e38d95e12da3d5ecaf22f82aa344 (patch)
treec7a30be7fd784574f8d25405bfdddbb5b4724499 /keyboards/exclusive/e6_rgb/config.h
parent4a09679d740a68ba0cf3020cdaf4d010bd2beca5 (diff)
downloadfirmware-fe860131dd60e38d95e12da3d5ecaf22f82aa344.tar.gz
firmware-fe860131dd60e38d95e12da3d5ecaf22f82aa344.tar.bz2
firmware-fe860131dd60e38d95e12da3d5ecaf22f82aa344.zip
[Keyboard] fixed hhkb keymap issue on e6_rgb (#7684)
* fixed hhkb keymap issue and added allleds configuration * fixed layout mismatch * add more matrix control * remove redundent define in rules.mk * turn NKRO on * remove allled macro, adding readme in allleds mode, add via support * add two more layers for via * update readme file * Update keyboards/exclusive/e6_rgb/keymaps/allleds/readme * Update keyboards/exclusive/e6_rgb/keymaps/allleds/readme.md
Diffstat (limited to 'keyboards/exclusive/e6_rgb/config.h')
-rw-r--r--keyboards/exclusive/e6_rgb/config.h30
1 files changed, 2 insertions, 28 deletions
diff --git a/keyboards/exclusive/e6_rgb/config.h b/keyboards/exclusive/e6_rgb/config.h
index cb213c25e..3a6131181 100644
--- a/keyboards/exclusive/e6_rgb/config.h
+++ b/keyboards/exclusive/e6_rgb/config.h
@@ -7,8 +7,8 @@
#include "config_common.h"
/* USB Device descriptor parameter */
-#define VENDOR_ID 0xDEAD
-#define PRODUCT_ID 0xFEED
+#define VENDOR_ID 0x4154 //AT
+#define PRODUCT_ID 0x4536 //E6
#define DEVICE_VER 0x0062
#define MANUFACTURER astro
#define PRODUCT e6rgb
@@ -23,27 +23,6 @@
#define UNUSED_PINS
#define DIODE_DIRECTION COL2ROW
-/* Debounce reduces chatter (unintended double-presses) - set 0 if debouncing is not needed */
-#define DEBOUNCE 5
-
-/*
- * Feature disable options
- * These options are also useful to firmware size reduction.
- */
-
-/* disable debug print */
-//#define NO_DEBUG
-
-/* disable print */
-//#define NO_PRINT
-
-/* disable action features */
-//#define NO_ACTION_LAYER
-//#define NO_ACTION_TAPPING
-//#define NO_ACTION_ONESHOT
-//#define NO_ACTION_MACRO
-//#define NO_ACTION_FUNCTION
-
//rgb light setting
#define RGBLED_NUM 6
#define RGB_DI_PIN B7
@@ -58,8 +37,3 @@
#define DRIVER_COUNT 2
#define DRIVER_1_LED_TOTAL 63
#define DRIVER_LED_TOTAL DRIVER_1_LED_TOTAL
-
-// tapping setting
-#define TAPPING_TERM 200
-#define RETRO_TAPPING
-#define PERMISSIVE_HOLD