aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/fluorite/rules.mk
diff options
context:
space:
mode:
authorihotsuno <52576847+ihotsuno@users.noreply.github.com>2019-12-02 07:50:47 +0900
committerJames Young <18669334+noroadsleft@users.noreply.github.com>2019-12-01 14:50:47 -0800
commitd9cf6c6730715ff3e80367d77a5b5ade21ef05ba (patch)
tree7d1a8edc113dbd8a3ef1c57104acb0a8dc6ea395 /keyboards/fluorite/rules.mk
parentb386ccc78608fa004f51ed245fc14cf5fbd0877c (diff)
downloadfirmware-d9cf6c6730715ff3e80367d77a5b5ade21ef05ba.tar.gz
firmware-d9cf6c6730715ff3e80367d77a5b5ade21ef05ba.tar.bz2
firmware-d9cf6c6730715ff3e80367d77a5b5ade21ef05ba.zip
[Keyboard] 140% keyboard fluorite keymaps (#7473)
* fluorite keymaps * Update config.h * Update fluorite.c I corrected the points that were pointed out. * Update fluorite.h I corrected the points that were pointed out. * Update config.h I corrected the points that were pointed out. * Update keymap.c I corrected the points that were pointed out. * Update keyboards/fluorite/config.h thanks! * Update keyboards/fluorite/readme.md thanks! * Update keyboards/fluorite/rules.mk thanks! * Update keyboards/fluorite/rules.mk thanks! * Update keyboards/fluorite/rules.mk thanks! * Update keyboards/fluorite/rules.mk thanks! * Update keyboards/fluorite/rules.mk thanks! * Update keyboards/fluorite/readme.md thanks! * Update keyboards/fluorite/readme.md thanks! * Update keyboards/fluorite/rules.mk thanks! * Update keyboards/fluorite/rules.mk thanks! * Update keyboards/fluorite/rules.mk thanks! * Update keymap.c I corrected the points that were pointed out. * Update fluorite.c I corrected the points that were pointed out. * Update rules.mk I corrected the points that were pointed out. * Update keyboards/fluorite/rules.mk Thanks! * Update keyboards/fluorite/rules.mk Thanks! * Update keymap.c I corrected the points that were pointed out. * Update fluorite.h I corrected the points that were pointed out. * Update keymap.c I corrected the points that were pointed out. * Update keymap.c I corrected the points. c:165:68 XDXXXXX >> XXXXXXX Reverted,because error log. ADJUST, * Update keymap.c I corrected the points that were pointed out. * Update readme.md link added * Update readme.md photo link added * Update readme.md link Modify * Update keyboards/fluorite/readme.md Thanks! * Update keyboards/fluorite/readme.md Thanks!
Diffstat (limited to 'keyboards/fluorite/rules.mk')
-rw-r--r--keyboards/fluorite/rules.mk35
1 files changed, 35 insertions, 0 deletions
diff --git a/keyboards/fluorite/rules.mk b/keyboards/fluorite/rules.mk
new file mode 100644
index 000000000..107da9b95
--- /dev/null
+++ b/keyboards/fluorite/rules.mk
@@ -0,0 +1,35 @@
+# MCU name
+MCU = atmega32u4
+
+# Bootloader selection
+# Teensy halfkay
+# Pro Micro caterina
+# Atmel DFU atmel-dfu
+# LUFA DFU lufa-dfu
+# QMK DFU qmk-dfu
+# ATmega32A bootloadHID
+# ATmega328P USBasp
+BOOTLOADER = atmel-dfu
+
+# Build Options
+# change yes to no to disable
+#
+BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration
+MOUSEKEY_ENABLE = no # Mouse keys
+EXTRAKEY_ENABLE = no # Audio control and System control
+CONSOLE_ENABLE = no # Console for debug
+COMMAND_ENABLE = no # Commands for debug and configuration
+# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+# if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+NKRO_ENABLE = no # USB Nkey Rollover
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality on B7 by default
+RGBLIGHT_ENABLE = no # Enable keyboard RGB underglow
+MIDI_ENABLE = no # MIDI support
+UNICODE_ENABLE = no # Unicode
+BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
+AUDIO_ENABLE = no # Audio output on port C6
+FAUXCLICKY_ENABLE = no # Use buzzer to emulate clicky switches
+HD44780_ENABLE = no # Enable support for HD44780 based LCDs
+
+SPLIT_KEYBOARD = yes