aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/fortitude60/rules.mk
diff options
context:
space:
mode:
authorJoel Challis <git@zvecr.com>2020-03-06 01:39:54 +0000
committerGitHub <noreply@github.com>2020-03-06 01:39:54 +0000
commitb368db9e027015ba393e87cee416d8d5b2b56a8c (patch)
tree413707612cca0b75339c9d2a7962e6b5b3bf4046 /keyboards/fortitude60/rules.mk
parent76189d9a282cc32bf2ff88a84a6374ebb8908433 (diff)
downloadfirmware-b368db9e027015ba393e87cee416d8d5b2b56a8c.tar.gz
firmware-b368db9e027015ba393e87cee416d8d5b2b56a8c.tar.bz2
firmware-b368db9e027015ba393e87cee416d8d5b2b56a8c.zip
Refactor fortitude60 to use split_common (#8113)
Diffstat (limited to 'keyboards/fortitude60/rules.mk')
-rw-r--r--keyboards/fortitude60/rules.mk25
1 files changed, 11 insertions, 14 deletions
diff --git a/keyboards/fortitude60/rules.mk b/keyboards/fortitude60/rules.mk
index 43d682cce..707f6a375 100644
--- a/keyboards/fortitude60/rules.mk
+++ b/keyboards/fortitude60/rules.mk
@@ -12,28 +12,25 @@ MCU = atmega32u4
BOOTLOADER = caterina
# Build Options
-# change to "no" to disable the options, or define them in the Makefile in
-# the appropriate keymap folder that will get included automatically
+# change yes to no to disable
#
BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration
MOUSEKEY_ENABLE = yes # Mouse keys
EXTRAKEY_ENABLE = yes # Audio control and System control
CONSOLE_ENABLE = no # Console for debug
COMMAND_ENABLE = yes # Commands for debug and configuration
-NKRO_ENABLE = no # Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
+SLEEP_LED_ENABLE = yes # Breathing sleep LED during USB suspend
+# if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+NKRO_ENABLE = no # USB Nkey Rollover
BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
-MIDI_ENABLE = no # MIDI controls
-AUDIO_ENABLE = no # Audio output on port C6
-UNICODE_ENABLE = no # Unicode
+RGBLIGHT_ENABLE = no # Enable keyboard RGB underglow
+MIDI_ENABLE = no # MIDI support
BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
-RGBLIGHT_ENABLE = no # Enable WS2812 RGB underlight.
-USE_SERIAL = yes # Serial support only on fortitude60
-# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
-SLEEP_LED_ENABLE = yes # Breathing sleep LED during USB suspend
+AUDIO_ENABLE = no # Audio output on port C6
+FAUXCLICKY_ENABLE = no # Use buzzer to emulate clicky switches
+HD44780_ENABLE = no # Enable support for HD44780 based LCDs
-CUSTOM_MATRIX = yes
-SRC += matrix.c \
- split_util.c \
- serial.c
+SPLIT_KEYBOARD = yes
DEFAULT_FOLDER = fortitude60/rev1