aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/frosty_flake/keymaps/nikchi/Makefile
diff options
context:
space:
mode:
authorJack Humbert <jack.humb@gmail.com>2017-05-24 13:59:30 -0400
committerGitHub <noreply@github.com>2017-05-24 13:59:30 -0400
commit7a4ec3bd926865e490fbf7c5ec68d762e998683f (patch)
treeec50b19b9031b1f3f24e003879f95cf9690d61af /keyboards/frosty_flake/keymaps/nikchi/Makefile
parentad420e7205bb2483348056d6b77adb837010ad5a (diff)
parent006ba4bf36e026d6b6c91ef52a5d0e32c7eefe34 (diff)
downloadfirmware-7a4ec3bd926865e490fbf7c5ec68d762e998683f.tar.gz
firmware-7a4ec3bd926865e490fbf7c5ec68d762e998683f.tar.bz2
firmware-7a4ec3bd926865e490fbf7c5ec68d762e998683f.zip
Merge pull request #1316 from nikchi/master
FrostyFlake Keymap
Diffstat (limited to 'keyboards/frosty_flake/keymaps/nikchi/Makefile')
-rw-r--r--keyboards/frosty_flake/keymaps/nikchi/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/keyboards/frosty_flake/keymaps/nikchi/Makefile b/keyboards/frosty_flake/keymaps/nikchi/Makefile
new file mode 100644
index 000000000..ad86e82d2
--- /dev/null
+++ b/keyboards/frosty_flake/keymaps/nikchi/Makefile
@@ -0,0 +1,23 @@
+# Build Options
+# change to "no" to disable the options, or define them in the Makefile in
+# the appropriate keymap folder that will get included automatically
+#
+BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration(+1000)
+MOUSEKEY_ENABLE = yes # Mouse keys(+4700)
+EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
+CONSOLE_ENABLE = no # Console for debug(+400)
+COMMAND_ENABLE = no # Commands for debug and configuration
+NKRO_ENABLE = yes # Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+MIDI_ENABLE = no # MIDI controls
+AUDIO_ENABLE = no # Audio output on port C6
+UNICODE_ENABLE = no # Unicode
+UNICODEMAP_ENABLE = yes # unicodemap
+BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
+RGBLIGHT_ENABLE = no # Enable WS2812 RGB underlight. Do not enable this with audio at the same time.
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+TAP_DANCE_ENABLE = yes
+
+ifndef QUANTUM_DIR
+ include ../../../../Makefile
+endif