aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/frosty_flake/keymaps/tkl/Makefile
diff options
context:
space:
mode:
authorJason Milkins <jasonm23@users.noreply.github.com>2017-09-07 08:42:19 +0800
committerskullydazed <skullydazed@users.noreply.github.com>2017-09-06 17:42:19 -0700
commit43a1ea30355bb31248ba54522f8eee1cd0db8754 (patch)
tree0664961f50ab63b3a6fbeac95f2d62938ae55cd1 /keyboards/frosty_flake/keymaps/tkl/Makefile
parentaf14e672c9c82b4a906ab9e3eae649d96158d2bd (diff)
downloadfirmware-43a1ea30355bb31248ba54522f8eee1cd0db8754.tar.gz
firmware-43a1ea30355bb31248ba54522f8eee1cd0db8754.tar.bz2
firmware-43a1ea30355bb31248ba54522f8eee1cd0db8754.zip
Add TKL keymap for Frosty_Flake (#1666)
* Add TKL keymap for Frosty_Flake * Update readme.md * Add spaces for ghfm newlines * add note for dfu target
Diffstat (limited to 'keyboards/frosty_flake/keymaps/tkl/Makefile')
-rw-r--r--keyboards/frosty_flake/keymaps/tkl/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/keyboards/frosty_flake/keymaps/tkl/Makefile b/keyboards/frosty_flake/keymaps/tkl/Makefile
new file mode 100644
index 000000000..3b2efd6e7
--- /dev/null
+++ b/keyboards/frosty_flake/keymaps/tkl/Makefile
@@ -0,0 +1,21 @@
+# Build Options
+# change to "no" to disable the options, or define them in the Makefile in
+# the appropriate keymap folder that will get included automatically
+#
+BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration(+1000)
+MOUSEKEY_ENABLE = no # Mouse keys(+4700)
+EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
+CONSOLE_ENABLE = yes # Console for debug(+400)
+COMMAND_ENABLE = yes # Commands for debug and configuration
+NKRO_ENABLE = no # Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+MIDI_ENABLE = no # MIDI controls
+AUDIO_ENABLE = no # Audio output on port C6
+UNICODE_ENABLE = no # Unicode
+BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
+RGBLIGHT_ENABLE = no # Enable WS2812 RGB underlight. Do not enable this with audio at the same time.
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+
+ifndef QUANTUM_DIR
+ include ../../../../Makefile
+endif