aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/funky40/funky40.h
diff options
context:
space:
mode:
authorTheFourthCow <63170386+TheFourthCow@users.noreply.github.com>2020-04-27 17:19:06 -0400
committerGitHub <noreply@github.com>2020-04-27 14:19:06 -0700
commit4c51049b2baf4e686c257f21849159a7908c7275 (patch)
treec75765c7e4983c1272297cf1deab2709130450fc /keyboards/funky40/funky40.h
parentdd60fcda2836a79428a5a1b11f2fcfb1b0ce80ea (diff)
downloadfirmware-4c51049b2baf4e686c257f21849159a7908c7275.tar.gz
firmware-4c51049b2baf4e686c257f21849159a7908c7275.tar.bz2
firmware-4c51049b2baf4e686c257f21849159a7908c7275.zip
[Keyboard] Add Funky40 support (#8942)
* Adding all relevant files for the Funky40 This should add all proper files for the funky40 a keyboard I designed for myself, /u/TheFourthcow, a 40% ortholinear with split spacebar. * Second attempt to add all relevant files for the funky40, includes all reccomended changes from my previous pull request * Revised most files for Funky40 including reccomenations from my previous pull request * further modifications made to default funky40 board, compiles on my side with no errors hopefully this one works! * Update keyboards/funky40/readme.mk.mk * Update keyboards/funky40/keymaps/default/readme.md.md * Update keyboards/funky40/keymaps/default/keymap.c * Update keyboards/funky40/keymaps/default/keymap.c * Update keyboards/funky40/keymaps/default/keymap.c * Update keyboards/funky40/config.h * updating readmes and keymap * final update to keymap and readmes should function correctly with updates requested * made changes as requested by noroadsleft to config and readme
Diffstat (limited to 'keyboards/funky40/funky40.h')
-rw-r--r--keyboards/funky40/funky40.h15
1 files changed, 15 insertions, 0 deletions
diff --git a/keyboards/funky40/funky40.h b/keyboards/funky40/funky40.h
new file mode 100644
index 000000000..f82a731b3
--- /dev/null
+++ b/keyboards/funky40/funky40.h
@@ -0,0 +1,15 @@
+#pragma once
+
+#include "quantum.h"
+
+#define LAYOUT( \
+ K000, K001, K002, K003, K004, K005, K006, K007, K008, K009, K010, K011, \
+ K100, K101, K102, K103, K104, K105, K106, K107, K108, K109, K110, K111, \
+ K200, K201, K202, K203, K204, K205, K206, K207, K208, K209, K210, K211, \
+ K300, K301, K302, K303, K304, K305, K306, K307, K308, K309 \
+) { \
+ { K000, K001, K002, K003, K004, K005, K006, K007, K008, K009, K010, K011 }, \
+ { K100, K101, K102, K103, K104, K105, K106, K107, K108, K109, K110, K111 }, \
+ { K200, K201, K202, K203, K204, K205, K206, K207, K208, K209, K210, K211 }, \
+ { K300, K301, K302, K303, K304, K305, K306, K307, K308, K309, KC_NO, KC_NO } \
+}