aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/georgi/keymaps/default-flipped/rules.mk
diff options
context:
space:
mode:
authorJeremy Bernhardt <jeremythegeek@gmail.com>2019-05-29 11:57:38 -0600
committerDrashna Jaelre <drashna@live.com>2019-05-29 10:57:38 -0700
commita1a7a84831230515bac68c9fe2c93cd90c02acb8 (patch)
treefa00e0bfe2953f221af44106dbfea69634f137e5 /keyboards/georgi/keymaps/default-flipped/rules.mk
parentd16056e60a4ac20ad4b2d7bef3ecebe82d22674b (diff)
downloadfirmware-a1a7a84831230515bac68c9fe2c93cd90c02acb8.tar.gz
firmware-a1a7a84831230515bac68c9fe2c93cd90c02acb8.tar.bz2
firmware-a1a7a84831230515bac68c9fe2c93cd90c02acb8.zip
[Keymap] Georgi flippydippy layout (#6005)
* keymap(gergo): colemak * added flipped numbers * Updated as per Drash
Diffstat (limited to 'keyboards/georgi/keymaps/default-flipped/rules.mk')
-rw-r--r--keyboards/georgi/keymaps/default-flipped/rules.mk41
1 files changed, 41 insertions, 0 deletions
diff --git a/keyboards/georgi/keymaps/default-flipped/rules.mk b/keyboards/georgi/keymaps/default-flipped/rules.mk
new file mode 100644
index 000000000..90d8057c3
--- /dev/null
+++ b/keyboards/georgi/keymaps/default-flipped/rules.mk
@@ -0,0 +1,41 @@
+#----------------------------------------------------------------------------
+# make georgi:default:dfu
+# Make sure you have dfu-programmer installed!
+#----------------------------------------------------------------------------
+
+NO_REPEAT = no
+VERBOSE = yes
+KEYBOARD_SHARED_EP = yes
+CUSTOM_MATRIX = yes
+
+#Firmware reduction options
+MOUSEKEY_ENABLE = yes # 1500 bytes
+NO_TAPPING = no # 2000 bytes
+NO_PRINT = yes
+
+#Debug options
+CONSOLE_ENABLE = no
+DEBUG_MATRIX_SCAN_RATE = no
+DEBUG_MATRIX = no
+ONLY_QWERTY = no
+
+# A bunch of stuff that you shouldn't touch unless you
+# know what you're doing.
+#
+# No touchy, capiche?
+SRC += matrix.c i2c_master.c
+ifeq ($(strip $(DEBUG_MATRIX)), yes)
+ OPT_DEFS += -DDEBUG_MATRIX
+endif
+ifeq ($(strip $(NO_REPEAT)), yes)
+ OPT_DEFS += -DNO_REPEAT
+endif
+ifeq ($(strip $(NO_PRINT)), yes)
+ OPT_DEFS += -DNO_PRINT -DNO_DEBUG
+endif
+ifeq ($(strip $(ONLY_QWERTY)), yes)
+ OPT_DEFS += -DONLYQWERTY
+endif
+ifeq ($(strip $(NO_TAPPING)), yes)
+ OPT_DEFS += -DNO_ACTION_TAPPING
+endif