aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/georgi
diff options
context:
space:
mode:
authorWilliam Chang <william@factual.com>2019-11-20 22:17:07 -0800
committerWilliam Chang <william@factual.com>2019-11-20 22:17:07 -0800
commite7f4d56592b3975c38af329e77b4efd9108495e8 (patch)
tree0a416bccbf70bfdbdb9ffcdb3bf136b47378c014 /keyboards/georgi
parent71493b2f9bbd5f3d18373c518fa14ccafcbf48fc (diff)
parent8416a94ad27b3ff058576f09f35f0704a8b39ff3 (diff)
downloadfirmware-e7f4d56592b3975c38af329e77b4efd9108495e8.tar.gz
firmware-e7f4d56592b3975c38af329e77b4efd9108495e8.tar.bz2
firmware-e7f4d56592b3975c38af329e77b4efd9108495e8.zip
Merge remote-tracking branch 'upstream/master'
Diffstat (limited to 'keyboards/georgi')
-rw-r--r--keyboards/georgi/matrix.c32
-rw-r--r--keyboards/georgi/rules.mk26
-rw-r--r--keyboards/georgi/sten.c2
3 files changed, 14 insertions, 46 deletions
diff --git a/keyboards/georgi/matrix.c b/keyboards/georgi/matrix.c
index 58f0776c4..f0b69c841 100644
--- a/keyboards/georgi/matrix.c
+++ b/keyboards/georgi/matrix.c
@@ -27,10 +27,6 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
#include "util.h"
#include "keymap_steno.h"
#include QMK_KEYBOARD_H
-#ifdef DEBUG_MATRIX_SCAN_RATE
-#include "timer.h"
-#endif
-
#ifndef DEBOUNCE
# define DEBOUNCE 5
@@ -92,12 +88,6 @@ static void select_row(uint8_t row);
static uint8_t mcp23018_reset_loop;
// static uint16_t mcp23018_reset_loop;
-#ifdef DEBUG_MATRIX_SCAN_RATE
-uint32_t matrix_timer;
-uint32_t matrix_scan_count;
-#endif
-
-
__attribute__ ((weak))
void matrix_init_user(void) {}
@@ -143,10 +133,6 @@ void matrix_init(void)
}
}
-#ifdef DEBUG_MATRIX_SCAN_RATE
- matrix_timer = timer_read32();
- matrix_scan_count = 0;
-#endif
matrix_init_quantum();
}
@@ -160,12 +146,6 @@ void matrix_power_up(void) {
for (uint8_t i=0; i < MATRIX_ROWS; i++) {
matrix[i] = 0;
}
-
-#ifdef DEBUG_MATRIX_SCAN_RATE
- matrix_timer = timer_read32();
- matrix_scan_count = 0;
-#endif
-
}
// Returns a matrix_row_t whose bits are set if the corresponding key should be
@@ -214,18 +194,6 @@ uint8_t matrix_scan(void)
}
}
-#ifdef DEBUG_MATRIX_SCAN_RATE
- matrix_scan_count++;
- uint32_t timer_now = timer_read32();
- if (TIMER_DIFF_32(timer_now, matrix_timer)>1000) {
- print("matrix scan frequency: ");
- pdec(matrix_scan_count);
- print("\n");
-
- matrix_timer = timer_now;
- matrix_scan_count = 0;
- }
-#endif
for (uint8_t i = 0; i < MATRIX_ROWS_PER_SIDE; i++) {
select_row(i);
// and select on left hand
diff --git a/keyboards/georgi/rules.mk b/keyboards/georgi/rules.mk
index a87b448e3..412a318f0 100644
--- a/keyboards/georgi/rules.mk
+++ b/keyboards/georgi/rules.mk
@@ -1,18 +1,15 @@
-#----------------------------------------------------------------------------
-# make georgi:default:dfu
-# Make sure you have dfu-programmer installed!
-# Do not edit this file! Make a copy of keymaps/default and modify that!
-#----------------------------------------------------------------------------
-# Source includes
-SRC += matrix.c i2c_master.c sten.c
-
-# Hardware info
+# MCU name
MCU = atmega32u4
-F_CPU = 16000000
-ARCH = AVR8
+
+# Bootloader selection
+# Teensy halfkay
+# Pro Micro caterina
+# Atmel DFU atmel-dfu
+# LUFA DFU lufa-dfu
+# QMK DFU qmk-dfu
+# ATmega32A bootloadHID
+# ATmega328P USBasp
BOOTLOADER = atmel-dfu
-F_USB = $(F_CPU)
-EXTRAFLAGS += -flto
CUSTOM_MATRIX = yes
MOUSEKEY_ENABLE = no
@@ -21,3 +18,6 @@ EXTRAKEY_ENABLE = yes
CONSOLE_ENABLE = yes
COMMAND_ENABLE = no
NKRO_ENABLE = yes
+
+EXTRAFLAGS += -flto
+SRC += matrix.c i2c_master.c sten.c
diff --git a/keyboards/georgi/sten.c b/keyboards/georgi/sten.c
index 197abaf92..c7469b639 100644
--- a/keyboards/georgi/sten.c
+++ b/keyboards/georgi/sten.c
@@ -253,7 +253,7 @@ uint32_t processFakeSteno(bool lookup) {
P( RB, SEND(KC_K););
P( RG, SEND(KC_L););
P( RS, SEND(KC_SCLN););
- P( RZ, SEND(KC_COMM););
+ P( RZ, SEND(KC_QUOT););
P( LNO, SEND(KC_1););
P( RNO, SEND(KC_1););