aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/gh60/gh60.h
diff options
context:
space:
mode:
authorJack Humbert <jack.humb@gmail.com>2017-08-23 22:29:07 -0400
committerGitHub <noreply@github.com>2017-08-23 22:29:07 -0400
commitd2ff66a985b938e87fffe55c1d9f1dc55e356f91 (patch)
tree561b3e203033849573a17f5ac6248077ab687676 /keyboards/gh60/gh60.h
parent7260fc3eef98fb7b0e2ed24d3d0d14cf2e613000 (diff)
downloadfirmware-d2ff66a985b938e87fffe55c1d9f1dc55e356f91.tar.gz
firmware-d2ff66a985b938e87fffe55c1d9f1dc55e356f91.tar.bz2
firmware-d2ff66a985b938e87fffe55c1d9f1dc55e356f91.zip
Creates a layouts/ folder for keymaps shared between keyboards (#1609)
* include variables and .h files as pp directives * start layout compilation * split ergodoxes up * don't compile all layouts for everything * might seg fault * reset layouts variable * actually reset layouts * include rules.mk instead * remove includes from rules.mk * update variable setting * load visualizer from path * adds some more examples * adds more layouts * more boards added * more boards added * adds documentation for layouts * use lowercase names for LAYOUT_ * add layout.json files for each layout * add community folder, default keymaps for layouts * touch-up default layouts * touch-up layouts, some keyboard rules.mk * update documentation for layouts * fix up serial/i2c switches
Diffstat (limited to 'keyboards/gh60/gh60.h')
-rw-r--r--keyboards/gh60/gh60.h3
1 files changed, 3 insertions, 0 deletions
diff --git a/keyboards/gh60/gh60.h b/keyboards/gh60/gh60.h
index 99ccf1757..be823676d 100644
--- a/keyboards/gh60/gh60.h
+++ b/keyboards/gh60/gh60.h
@@ -72,4 +72,7 @@ inline void gh60_wasd_leds_off(void) { DDRF &= ~(1<<7); PORTF &= ~(1<<7); }
{ K40, K41, K42, KC_NO, KC_NO, K45, KC_NO, KC_NO, KC_NO, K49, K4A, K4B, K4C, K4D } \
}
+#define LAYOUT_60_ansi KEYMAP_ANSI
+#define LAYOUT_60_iso KEYMAP
+
#endif \ No newline at end of file