aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/gingham/gingham.c
diff options
context:
space:
mode:
authoryiancar <yiangosyiangou@cytanet.com.cy>2019-07-01 21:11:38 +0100
committerDrashna Jaelre <drashna@live.com>2019-07-01 13:11:38 -0700
commitc45b751b147255229bf7afc65cb4ca9a3979c6d8 (patch)
tree32d9561f4afe05cde0a2d411191904b5493fa0c4 /keyboards/gingham/gingham.c
parent58641572cb478486ebd543da9eabd73eb044299f (diff)
downloadfirmware-c45b751b147255229bf7afc65cb4ca9a3979c6d8.tar.gz
firmware-c45b751b147255229bf7afc65cb4ca9a3979c6d8.tar.bz2
firmware-c45b751b147255229bf7afc65cb4ca9a3979c6d8.zip
[Keyboard] Gingham (#6212)
* Initial * Prepare for final release * Final * Update keyboards/gingham/matrix.c Co-Authored-By: Drashna Jaelre <drashna@live.com> * Update keyboards/gingham/rules.mk Co-Authored-By: Drashna Jaelre <drashna@live.com> * Update keyboards/gingham/rules.mk Co-Authored-By: fauxpark <fauxpark@gmail.com> * Update keyboards/gingham/config.h Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Update keyboards/gingham/gingham.h Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Update keyboards/hs60/v1/rules.mk Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Update keyboards/gingham/info.json Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Update keyboards/gingham/info.json Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Update keyboards/gingham/info.json Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Update keyboards/gingham/gingham.h Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Update keyboards/gingham/gingham.h Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Fixing copypastas * Update keyboards/gingham/info.json Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Update keyboards/gingham/info.json Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Update keyboards/gingham/info.json Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * Update keyboards/gingham/info.json Co-Authored-By: noroadsleft <18669334+noroadsleft@users.noreply.github.com> * More thingies
Diffstat (limited to 'keyboards/gingham/gingham.c')
-rw-r--r--keyboards/gingham/gingham.c40
1 files changed, 40 insertions, 0 deletions
diff --git a/keyboards/gingham/gingham.c b/keyboards/gingham/gingham.c
new file mode 100644
index 000000000..9a5ffe453
--- /dev/null
+++ b/keyboards/gingham/gingham.c
@@ -0,0 +1,40 @@
+/* Copyright 2019 Yiancar
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+#include "gingham.h"
+#include "i2c_master.h"
+
+uint8_t send_data;
+
+void matrix_init_kb(void) {
+ // Due to the way the port expander is setup both LEDs are already outputs. This is set n matrix.copy
+ //Turn the red LED on as power indicator.
+ send_data = 0x10;
+ i2c_writeReg((PORT_EXPANDER_ADDRESS << 1), 0x09, &send_data, 1, 20);
+
+ matrix_init_user();
+}
+
+void led_set_kb(uint8_t usb_led) {
+ // Bit 3 is Green LED, bit 4 is Red LED.
+ if (IS_LED_ON(usb_led, USB_LED_CAPS_LOCK)) {
+ send_data = 0x18;
+ } else {
+ send_data = 0x10;
+ }
+ i2c_writeReg((PORT_EXPANDER_ADDRESS << 1), 0x09, &send_data, 1, 20);
+
+ led_set_user(usb_led);
+}