aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/gray_studio/think65/solder/rules.mk
diff options
context:
space:
mode:
authorMechMerlin <30334081+mechmerlin@users.noreply.github.com>2019-10-29 22:33:46 -0700
committerDrashna Jaelre <drashna@live.com>2019-10-29 22:33:46 -0700
commitb1c2bf071bcfd0d5badf79656f523dd8f5146f25 (patch)
tree62b92843c82d963d84aea604e736d3f9837f623c /keyboards/gray_studio/think65/solder/rules.mk
parente258b10d71049645c2e6ce50f652ce3f11578603 (diff)
downloadfirmware-b1c2bf071bcfd0d5badf79656f523dd8f5146f25.tar.gz
firmware-b1c2bf071bcfd0d5badf79656f523dd8f5146f25.tar.bz2
firmware-b1c2bf071bcfd0d5badf79656f523dd8f5146f25.zip
[Keyboard] Think 6.5 (#7199)
* generated files * create the physical and electrical matrix, thanks noroadsleft * add an appropriate keymap * add qmk configurator support * add readme * add keyboard configuration and rules * move over the think6.5 to the gray_studio directory * move to hotswap in anticipation of non hotswap pcb support * update readme to have the correct make path * rename to hotswap * add community layout support by using the LAYOUT_65_ansi_blocker LAYOUT macro name * thanks to cygnus for pointing out the solder json file to me. This commit is pretty much the same as the hotswap as it uses the same pins and switch matrix. * update readme to state that LAYOUT_65_ansi_blocker works for both hotswap and solder. * wrong pound include * add LED support. Soldered PCB only supports caps lock LED * add readme notes for indicator led * Update keyboards/gray_studio/think65/hotswap/keymaps/default/keymap.c Co-Authored-By: fauxpark <fauxpark@gmail.com> * Update keyboards/gray_studio/think65/hotswap/rules.mk Co-Authored-By: fauxpark <fauxpark@gmail.com> * Update keyboards/gray_studio/think65/hotswap/rules.mk Co-Authored-By: fauxpark <fauxpark@gmail.com> * Update keyboards/gray_studio/think65/solder/keymaps/default/keymap.c Co-Authored-By: fauxpark <fauxpark@gmail.com> * Update keyboards/gray_studio/think65/solder/rules.mk Co-Authored-By: fauxpark <fauxpark@gmail.com> * Update keyboards/gray_studio/think65/solder/rules.mk Co-Authored-By: fauxpark <fauxpark@gmail.com>
Diffstat (limited to 'keyboards/gray_studio/think65/solder/rules.mk')
-rw-r--r--keyboards/gray_studio/think65/solder/rules.mk40
1 files changed, 40 insertions, 0 deletions
diff --git a/keyboards/gray_studio/think65/solder/rules.mk b/keyboards/gray_studio/think65/solder/rules.mk
new file mode 100644
index 000000000..2d789ff59
--- /dev/null
+++ b/keyboards/gray_studio/think65/solder/rules.mk
@@ -0,0 +1,40 @@
+# MCU name
+MCU = atmega32u4
+
+# Bootloader selection
+# Teensy halfkay
+# Pro Micro caterina
+# Atmel DFU atmel-dfu
+# LUFA DFU lufa-dfu
+# QMK DFU qmk-dfu
+# ATmega32A bootloadHID
+# ATmega328P USBasp
+BOOTLOADER = atmel-dfu
+
+# Build Options
+# change yes to no to disable
+#
+BOOTMAGIC_ENABLE = lite # Virtual DIP switch configuration
+MOUSEKEY_ENABLE = yes # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = yes # Console for debug
+COMMAND_ENABLE = yes # Commands for debug and configuration
+# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+# if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+NKRO_ENABLE = no # USB Nkey Rollover
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+RGBLIGHT_ENABLE = yes # Enable keyboard RGB underglow
+MIDI_ENABLE = no # MIDI support
+UNICODE_ENABLE = no # Unicode
+BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
+AUDIO_ENABLE = no # Audio output on port C6
+FAUXCLICKY_ENABLE = no # Use buzzer to emulate clicky switches
+HD44780_ENABLE = no # Enable support for HD44780 based LCDs
+
+LINK_TIME_OPTIMIZATION_ENABLE = yes
+
+LAYOUTS = 65_ansi_blocker
+
+# generated by KBFirmware JSON to QMK Parser
+# https://noroadsleft.github.io/kbf_qmk_converter/