aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/handwired/MS_sculpt_mobile/rules.mk
diff options
context:
space:
mode:
authorjpetermans <tibcmhhm@gmail.com>2017-05-24 11:51:20 -0700
committerjpetermans <tibcmhhm@gmail.com>2017-05-24 11:51:20 -0700
commit2dcd6c38fa478b40a973c9411c3f5b4c87ae0ba7 (patch)
tree289d5cce94ad5883741f0b637749d87680c14d33 /keyboards/handwired/MS_sculpt_mobile/rules.mk
parentd89114400c398b900e27bf324a7973d1e0f25e58 (diff)
parent7a4ec3bd926865e490fbf7c5ec68d762e998683f (diff)
downloadfirmware-2dcd6c38fa478b40a973c9411c3f5b4c87ae0ba7.tar.gz
firmware-2dcd6c38fa478b40a973c9411c3f5b4c87ae0ba7.tar.bz2
firmware-2dcd6c38fa478b40a973c9411c3f5b4c87ae0ba7.zip
Merge remote-tracking branch 'upstream/master' into infinity60
Diffstat (limited to 'keyboards/handwired/MS_sculpt_mobile/rules.mk')
-rw-r--r--keyboards/handwired/MS_sculpt_mobile/rules.mk48
1 files changed, 48 insertions, 0 deletions
diff --git a/keyboards/handwired/MS_sculpt_mobile/rules.mk b/keyboards/handwired/MS_sculpt_mobile/rules.mk
new file mode 100644
index 000000000..680389c84
--- /dev/null
+++ b/keyboards/handwired/MS_sculpt_mobile/rules.mk
@@ -0,0 +1,48 @@
+
+## Project specific files
+SRC= babblePaste.c
+
+
+ifdef ASTAR
+ CFLAGS=-D ASTAR
+ OPT_DEFS += -DBOOTLOADER_SIZE=4096
+ MCU = atmega32u4
+ OPT_DEFS += -DCATERINA_BOOTLOADER
+ SCULPT_UPLOAD_COMMAND = while [ ! -r $(USB) ]; do sleep 1; done ; \
+ avrdude -p $(MCU) -c avr109 -U flash:w:$(TARGET).hex -P $(USB)
+
+else
+ MCU = at90usb1286
+ OPT_DEFS += -DBOOTLOADER_SIZE=2048
+ SCULPT_UPLOAD_COMMAND = teensy_loader_cli -w -mmcu=$(MCU) $(TARGET).hex
+endif
+
+F_CPU = 16000000
+ARCH = AVR8
+F_USB = $(F_CPU)
+# Interrupt driven control endpoint task(+60)
+OPT_DEFS += -DINTERRUPT_CONTROL_ENDPOINT
+
+#
+BOOTMAGIC_ENABLE ?= no # Virtual DIP switch configuration(+1000)
+MOUSEKEY_ENABLE ?= no # Mouse keys(+4700)
+EXTRAKEY_ENABLE ?= yes # Audio control and System control(+450)
+CONSOLE_ENABLE ?= yes # Console for debug(+400)
+COMMAND_ENABLE ?= yes # Commands for debug and configuration
+# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
+SLEEP_LED_ENABLE ?= no # Breathing sleep LED during USB suspend
+# if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+NKRO_ENABLE ?= no # USB Nkey Rollover
+BACKLIGHT_ENABLE ?= no # Enable keyboard backlight functionality on B7 by default
+MIDI_ENABLE ?= no # MIDI controls
+UNICODE_ENABLE ?= no # Unicode
+BLUETOOTH_ENABLE ?= no # Enable Bluetooth with the Adafruit EZ-Key HID
+AUDIO_ENABLE ?= no # Audio output on port C6
+
+
+USB ?= /dev/cu.usbmodem14141
+
+
+
+upload: build
+ $(SCULPT_UPLOAD_COMMAND)