aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/handwired/colorlice/rules.mk
diff options
context:
space:
mode:
authormarhalloweenvt <marhalloweenvt@gmail.com>2019-12-10 00:44:07 +0700
committerJames Young <18669334+noroadsleft@users.noreply.github.com>2019-12-09 09:44:07 -0800
commit5acb7e37072d924cf38c8f43ec89aa9b8e2e8541 (patch)
tree865c6728f40cbb680960251b3d274a83c3b16cb5 /keyboards/handwired/colorlice/rules.mk
parent6c834dea7b506db480ae7a96f3b35f955824d4ec (diff)
downloadfirmware-5acb7e37072d924cf38c8f43ec89aa9b8e2e8541.tar.gz
firmware-5acb7e37072d924cf38c8f43ec89aa9b8e2e8541.tar.bz2
firmware-5acb7e37072d924cf38c8f43ec89aa9b8e2e8541.zip
[Keyboard] Adjust ColorLice to work with QMK configurator (#7572)
* [Keyboard] Add new keyboard Symmetry60 * Add new keyboard Symmetry60 * Fix Typo * Update keyboards/handwired/symmetry60/config.h * Update keyboards/handwired/symmetry60/readme.md * Update keyboards/handwired/symmetry60/readme.md * Update keyboards/handwired/symmetry60/readme.md * Update keyboards/handwired/symmetry60/rules.mk * Update keyboards/handwired/symmetry60/symmetry60.h * Update keyboards/handwired/symmetry60/symmetry60.h * Update keyboards/handwired/symmetry60/symmetry60.h * Update readme.md * Update keymap.c * Update keymap.c * Update keymap.c * Update rules.mk * Update symmetry60.c * Update keyboards/handwired/symmetry60/rules.mk * Add ColorLice * Update ColorLice - Adjust info.json to support Configurator - Adjust layout name to fit with info.json - Seperate 2 feature: RGB Switch and RGB Underglow * Update new way of control lock leds * Remove #ifndef COLORLICE_H * Update make example * Revert Helix * Revert Helix * Revert Helix * Revert Helix * Update keyboards/handwired/colorlice/colorlice.h * Update keyboards/handwired/colorlice/colorlice.h * Update default keymap * Revert Helix * Update keyboards/handwired/colorlice/readme.md * Update keyboards/handwired/colorlice/rules.mk * Update keyboards/handwired/colorlice/colorlice.c * Update keyboards/handwired/colorlice/colorlice.c * Remove unnecessary function * Update keyboards/handwired/colorlice/colorlice.c * Adjust rules option for working with Configurator - Move RGB_MATRIX_ENABLE and RGBLIGHT_ENABLE to keyboard rule. - Add RGB_DI_PIN in keyboard config * Update keyboards/helix/rev2/keymaps/default/keymap.c * Update keyboards/handwired/colorlice/readme.md * Update keymap for Colorlice * Adjust rules.mk to use space indent * Update ColorLice to work with QMK online configurator - Delete rgb_underglow keymap - Move config from keymap layer to keyboard layer - Tweak a little layout so it can appear default layout on QMK config * Update keyboards/handwired/colorlice/rules.mk * Update keyboards/handwired/colorlice/rules.mk
Diffstat (limited to 'keyboards/handwired/colorlice/rules.mk')
-rw-r--r--keyboards/handwired/colorlice/rules.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/keyboards/handwired/colorlice/rules.mk b/keyboards/handwired/colorlice/rules.mk
index b9091e19e..02da465d3 100644
--- a/keyboards/handwired/colorlice/rules.mk
+++ b/keyboards/handwired/colorlice/rules.mk
@@ -17,7 +17,7 @@ BOOTLOADER = atmel-dfu
BOOTMAGIC_ENABLE = yes # Virtual DIP switch configuration
MOUSEKEY_ENABLE = yes # Mouse keys
EXTRAKEY_ENABLE = yes # Audio control and System control
-CONSOLE_ENABLE = yes # Console for debug
+CONSOLE_ENABLE = no # Console for debug
COMMAND_ENABLE = no # Commands for debug and configuration
# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
@@ -30,7 +30,6 @@ BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
AUDIO_ENABLE = no # Audio output on port C6
FAUXCLICKY_ENABLE = no # Use buzzer to emulate clicky switches
HD44780_ENABLE = no # Enable support for HD44780 based LCDs
-LTO_ENABLE = yes # Use link time optimization
+LTO_ENABLE = no # Use link time optimization
RGB_MATRIX_ENABLE = WS2812 # Enable keyboard RGB backlight functionality with ws2812 driver
RGBLIGHT_ENABLE = no # Enable keyboard RGB underglow
-NO_USB_STARTUP_CHECK = no # Disable initialization only when usb is plugged in