aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/handwired/practice60/rules.mk
diff options
context:
space:
mode:
authorAndrew Kannan <andrew.kannan@klaviyo.com>2018-11-12 19:31:22 -0500
committerDrashna Jaelre <drashna@live.com>2018-11-12 16:31:22 -0800
commite653cc198e3a535f23ae33d677115f192979ee55 (patch)
tree5cfd500f945829e3d8dcfaf687940e15f6a93ec4 /keyboards/handwired/practice60/rules.mk
parent599b21b9f4b450392380870675b136449839f6e5 (diff)
downloadfirmware-e653cc198e3a535f23ae33d677115f192979ee55.tar.gz
firmware-e653cc198e3a535f23ae33d677115f192979ee55.tar.bz2
firmware-e653cc198e3a535f23ae33d677115f192979ee55.zip
The "Practice60" Board, Blue Pill powered (#4407)
* Starting point for blue pill based practice60 * Changes * add * try raw bin no botloader * swap back to bootloader version * edit * Remove debug LED flash * Disable JTAG to open up B3 and B4 * Add led backlight support (no breathing yet) * Update matrix for correctness * RGB Underglow working in a very simple state * not as bright * Move to handwired * revert ChibiOS_Test changes * Changes based on PR comments * Address PR comments v2 * Move files
Diffstat (limited to 'keyboards/handwired/practice60/rules.mk')
-rw-r--r--keyboards/handwired/practice60/rules.mk56
1 files changed, 56 insertions, 0 deletions
diff --git a/keyboards/handwired/practice60/rules.mk b/keyboards/handwired/practice60/rules.mk
new file mode 100644
index 000000000..915b07320
--- /dev/null
+++ b/keyboards/handwired/practice60/rules.mk
@@ -0,0 +1,56 @@
+# project specific files
+SRC = led.c \
+ underglow.c \
+ hsv2rgb.c
+
+# GENERIC STM32F103C8T6 board - stm32duino bootloader
+OPT_DEFS = -DCORTEX_VTOR_INIT=0x2000
+MCU_LDSCRIPT = STM32F103x8_stm32duino_bootloader
+BOARD = GENERIC_STM32_F103
+
+# OPT_DEFS =
+# MCU_LDSCRIPT = STM32F103x8
+# BOARD = GENERIC_STM32_F103
+
+## chip/board settings
+# the next two should match the directories in
+# <chibios>/os/hal/ports/$(MCU_FAMILY)/$(MCU_SERIES)
+MCU_FAMILY = STM32
+MCU_SERIES = STM32F1xx
+# linker script to use
+# it should exist either in <chibios>/os/common/ports/ARMCMx/compilers/GCC/ld/
+# or <this_dir>/ld/
+# startup code to use
+# is should exist in <chibios>/os/common/ports/ARMCMx/compilers/GCC/mk/
+MCU_STARTUP = stm32f1xx
+# it should exist either in <chibios>/os/hal/boards/
+# or <this_dir>/boards
+# Cortex version
+# Teensy LC is cortex-m0; Teensy 3.x are cortex-m4
+MCU = cortex-m3
+# ARM version, CORTEX-M0/M1 are 6, CORTEX-M3/M4/M7 are 7
+ARMV = 7
+# If you want to be able to jump to bootloader from firmware on STM32 MCUs,
+# set the correct BOOTLOADER_ADDRESS. Either set it here, or define it in
+# ./bootloader_defs.h or in ./boards/<FOO>/bootloader_defs.h (if you have
+# a custom board definition that you plan to reuse).
+# If you're not setting it here, leave it commented out.
+# It is chip dependent, the correct number can be looked up here (page 175):
+# http://www.st.com/web/en/resource/technical/document/application_note/CD00167594.pdf
+# This also requires a patch to chibios:
+# <tmk_dir>/tmk_core/tool/chibios/ch-bootloader-jump.patch
+#STM32_BOOTLOADER_ADDRESS = 0x1FFFC800
+
+
+#BOOTMAGIC_ENABLE = yes # Virtual DIP switch configuration
+MOUSEKEY_ENABLE = yes # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = yes # Console for debug
+COMMAND_ENABLE = yes # Commands for debug and configuration
+SLEEP_LED_ENABLE = yes # Breathing sleep LED during USB suspend
+NKRO_ENABLE = yes # USB Nkey Rollover
+BACKLIGHT_ENABLE = yes
+
+LAYOUTS = 60_ansi
+
+DEFAULT_FOLDER = handwired/practice60