aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/handwired/terminus_mini/keymaps/default/rules.mk
diff options
context:
space:
mode:
authormogranjm <32807665+mogranjm@users.noreply.github.com>2017-10-18 03:42:27 +1100
committerJack Humbert <jack.humb@gmail.com>2017-10-17 06:42:27 -1000
commitd3fe6a0588965b71c6876b060d05abfceabacbb5 (patch)
treefd38fecbd5b0f962e411a35c30e0ed163fad1740 /keyboards/handwired/terminus_mini/keymaps/default/rules.mk
parentaf4697cba5114d79027b900d94fc1462324c006a (diff)
downloadfirmware-d3fe6a0588965b71c6876b060d05abfceabacbb5.tar.gz
firmware-d3fe6a0588965b71c6876b060d05abfceabacbb5.tar.bz2
firmware-d3fe6a0588965b71c6876b060d05abfceabacbb5.zip
Add terminus_mini keyboard and nyquist/DivergeJM layout (#1851)
* First commit of the Terminus_Mini firmware and the DivergeJM version of the Nyquist firmware * Fix terminus_mini & nyquist/DivergeJM readme files Previously an outdated copy of the default readme. Updated to match the Nyquist/DivergeJM format (DivergeJM is a split 5x12 implementation of the terminus_mini layout) * Update makefiles to rules.mk Renamed both Makefiles to rules.mk, removed references to makefiles * Updated rules.mk Inadvertantly removed important code from the rules.mk in previous commit. This has been restored. Also disabled Tap_Dance in both rules.mk files * Moved terminus_mini to handwired Realised that existing directory was not appropriate for the terminus_mini project, moved to handwired.
Diffstat (limited to 'keyboards/handwired/terminus_mini/keymaps/default/rules.mk')
-rw-r--r--keyboards/handwired/terminus_mini/keymaps/default/rules.mk34
1 files changed, 34 insertions, 0 deletions
diff --git a/keyboards/handwired/terminus_mini/keymaps/default/rules.mk b/keyboards/handwired/terminus_mini/keymaps/default/rules.mk
new file mode 100644
index 000000000..1485c0832
--- /dev/null
+++ b/keyboards/handwired/terminus_mini/keymaps/default/rules.mk
@@ -0,0 +1,34 @@
+# Copyright 2013 Jun Wako <wakojun@gmail.com>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+
+# QMK Build Options
+# change to "no" to disable the options, or define them in the rules.mk in
+# the appropriate keymap folder that will get included automatically
+#
+BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration(+1000)
+MOUSEKEY_ENABLE = yes # Mouse keys(+4700)
+EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
+CONSOLE_ENABLE = no # Console for debug(+400)
+COMMAND_ENABLE = yes # Commands for debug and configuration
+NKRO_ENABLE = yes # Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+MIDI_ENABLE = no # MIDI support (+2400 to 4200, depending on config)
+AUDIO_ENABLE = no # Audio output on port C6
+UNICODE_ENABLE = no # Unicode
+BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
+RGBLIGHT_ENABLE = no # Enable WS2812 RGB underlight. Do not enable this with audio at the same time.
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+TAP_DANCE_ENABLE = no # Enable Tap Dance