aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/handwired/xeal60/keymaps/drashna_old/rules.mk
diff options
context:
space:
mode:
authoralex-ong <the.onga@gmail.com>2018-08-12 17:23:58 +1000
committeralex-ong <the.onga@gmail.com>2018-08-12 17:23:58 +1000
commit2758158a4bb15b0f5ec30de92760133248afe1f8 (patch)
treeab6cbaa941139c8c397284465f15e5537d0ba533 /keyboards/handwired/xeal60/keymaps/drashna_old/rules.mk
parent619b5d1e6d40c37eb77036158b8f2b99d673e2ba (diff)
downloadfirmware-2758158a4bb15b0f5ec30de92760133248afe1f8.tar.gz
firmware-2758158a4bb15b0f5ec30de92760133248afe1f8.tar.bz2
firmware-2758158a4bb15b0f5ec30de92760133248afe1f8.zip
Added xeal60 via clone of lets split
Diffstat (limited to 'keyboards/handwired/xeal60/keymaps/drashna_old/rules.mk')
-rw-r--r--keyboards/handwired/xeal60/keymaps/drashna_old/rules.mk28
1 files changed, 28 insertions, 0 deletions
diff --git a/keyboards/handwired/xeal60/keymaps/drashna_old/rules.mk b/keyboards/handwired/xeal60/keymaps/drashna_old/rules.mk
new file mode 100644
index 000000000..14ac6a6b3
--- /dev/null
+++ b/keyboards/handwired/xeal60/keymaps/drashna_old/rules.mk
@@ -0,0 +1,28 @@
+BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration(+1000)
+MOUSEKEY_ENABLE = no # Mouse keys(+4700)
+EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
+CONSOLE_ENABLE = no # Console for debug(+400)
+COMMAND_ENABLE = no # Commands for debug and configuration
+TAP_DANCE_ENABLE = no
+RGBLIGHT_ENABLE = yes
+AUDIO_ENABLE = yes
+NKRO_ENABLE = yes
+
+NO_SECRETS = yes
+MACROS_ENABLED = yes
+INDICATOR_LIGHTS = no
+RGBLIGHT_TWINKLE = no
+
+LAYOUTS = ortho_5x7
+
+# SRC := $(filter-out serial.c matrix.c i2c.c split_util.c,$(SRC))
+# SRC := $(filter-out serial.c,$(SRC))
+# SRC := $(filter-out matrix.c,$(SRC))
+# SRC := $(filter-out i2c.c,$(SRC))
+# SRC := $(filter-out split_util.c,$(SRC))
+# SRC += quantum/matrix.c
+
+USER_NAME := drashna
+SRC += ../drashna/keymap.c
+
+BOOTLOADER = qmk-dfu