aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/hecomi/alpha
diff options
context:
space:
mode:
authortakashiski <takashiskibb@gmail.com>2019-05-12 15:20:45 +0900
committerDrashna Jaelre <drashna@live.com>2019-05-11 23:20:45 -0700
commit0db65190c2f4f72fd99d676d7e8aed6e0cc834f6 (patch)
tree6da10243faef5d5aabd02d4d6783d13b08c76f2e /keyboards/hecomi/alpha
parent2b78840ef7e6227949bf6e2f9643449e11df0ac5 (diff)
downloadfirmware-0db65190c2f4f72fd99d676d7e8aed6e0cc834f6.tar.gz
firmware-0db65190c2f4f72fd99d676d7e8aed6e0cc834f6.tar.bz2
firmware-0db65190c2f4f72fd99d676d7e8aed6e0cc834f6.zip
[Keyboard] Enable RGBLED_SPLIT on hecomi/alpha (#5836)
* remove not need file * set RGBLIGHT_SPLIT * set RGBLIGHT by layer * exchange LED color on layer * Update keyboards/hecomi/alpha/rules.mk I misunderstand RGBLIGHT_SPLIT Co-Authored-By: Drashna Jaelre <drashna@live.com>
Diffstat (limited to 'keyboards/hecomi/alpha')
-rw-r--r--keyboards/hecomi/alpha/config.h23
-rw-r--r--keyboards/hecomi/alpha/rules.mk6
2 files changed, 15 insertions, 14 deletions
diff --git a/keyboards/hecomi/alpha/config.h b/keyboards/hecomi/alpha/config.h
index 40bb8c2f0..8a65f146b 100644
--- a/keyboards/hecomi/alpha/config.h
+++ b/keyboards/hecomi/alpha/config.h
@@ -45,7 +45,7 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
#define MATRIX_ROW_PINS { C6,D7,E6,B4,B5 }
#define MATRIX_COL_PINS { F4,F5,F6,F7,B1,B3,B2,B6 }
#define UNUSED_PINS
-#define SOFT_SERIAL_PIN D0 // or D1, D2, D3, E6
+#define SOFT_SERIAL_PIN D1 // or D1, D2, D3, E6
//#define USE_I2C
/* COL2ROW, ROW2COL, or CUSTOM_MATRIX */
@@ -62,20 +62,20 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
#define RGB_DI_PIN D4
#ifdef RGB_DI_PIN
- #define RGBLED_NUM 8
+ #define RGBLED_NUM 16
#define RGBLIGHT_HUE_STEP 8
#define RGBLIGHT_SAT_STEP 8
#define RGBLIGHT_VAL_STEP 8
/*== or choose animations ==*/
- #define RGBLIGHT_EFFECT_BREATHING
- #define RGBLIGHT_EFFECT_RAINBOW_MOOD
- #define RGBLIGHT_EFFECT_RAINBOW_SWIRL
- #define RGBLIGHT_EFFECT_SNAKE
- #define RGBLIGHT_EFFECT_KNIGHT
- #define RGBLIGHT_EFFECT_CHRISTMAS
- #define RGBLIGHT_EFFECT_STATIC_GRADIENT
- #define RGBLIGHT_EFFECT_RGB_TEST
- #define RGBLIGHT_EFFECT_ALTERNATING
+// #define RGBLIGHT_EFFECT_BREATHING
+// #define RGBLIGHT_EFFECT_RAINBOW_MOOD
+// #define RGBLIGHT_EFFECT_RAINBOW_SWIRL
+// #define RGBLIGHT_EFFECT_SNAKE
+// #define RGBLIGHT_EFFECT_KNIGHT
+// #define RGBLIGHT_EFFECT_CHRISTMAS
+// #define RGBLIGHT_EFFECT_STATIC_GRADIENT
+// #define RGBLIGHT_EFFECT_RGB_TEST
+// #define RGBLIGHT_EFFECT_ALTERNATING
#endif
/* Debounce reduces chatter (unintended double-presses) - set 0 if debouncing is not needed */
@@ -244,3 +244,4 @@ along with this program. If not, see <http://www.gnu.org/licenses/>.
#define MASTER_LEFT
#define EEHANDS
*/
+#define RGBLED_SPLIT {8,8}
diff --git a/keyboards/hecomi/alpha/rules.mk b/keyboards/hecomi/alpha/rules.mk
index ae9192be3..3e726f1d6 100644
--- a/keyboards/hecomi/alpha/rules.mk
+++ b/keyboards/hecomi/alpha/rules.mk
@@ -62,8 +62,8 @@ BOOTLOADER = caterina
# Build Options
# change yes to no to disable
#
-BOOTMAGIC_ENABLE = yes # Virtual DIP switch configuration(+1000)
-MOUSEKEY_ENABLE = yes # Mouse keys(+4700)
+BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration(+1000)
+MOUSEKEY_ENABLE = no # Mouse keys(+4700)
EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
CONSOLE_ENABLE = yes # Console for debug(+400)
COMMAND_ENABLE = yes # Commands for debug and configuration
@@ -72,7 +72,7 @@ SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
# if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
NKRO_ENABLE = no # USB Nkey Rollover
BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality on B7 by default
-RGBLIGHT_ENABLE = no # Enable keyboard RGB underglow
+RGBLIGHT_ENABLE = yes # Enable keyboard RGB underglow
MIDI_ENABLE = no # MIDI support (+2400 to 4200, depending on config)
UNICODE_ENABLE = no # Unicode
BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID