aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/helix/rev2/keymaps/default/rules.mk
diff options
context:
space:
mode:
authorMakotoKurauchi <pluis@me.com>2018-01-29 02:14:12 +0900
committerJack Humbert <jack.humb@gmail.com>2018-01-28 12:14:12 -0500
commitbceffdefcac30dd8b08ec3b803af372cbf254a7b (patch)
tree600173b95bdfc43a9efd75cdd3beec8b3577a4af /keyboards/helix/rev2/keymaps/default/rules.mk
parent86225ccc9b22f6b7b3cbbb9c5c578ea31f2214fa (diff)
downloadfirmware-bceffdefcac30dd8b08ec3b803af372cbf254a7b.tar.gz
firmware-bceffdefcac30dd8b08ec3b803af372cbf254a7b.tar.bz2
firmware-bceffdefcac30dd8b08ec3b803af372cbf254a7b.zip
Add helix keyboard (#2308)
* Fork from Let's Split * Organizing files * Delete some keymaps * I2C and serial enabled at the same time * Change readme * add #define HELIX_ROWS for multiple rows * Delete avrdude flashing script * Delete makefiles * Subproject elimination * Fix lufa path * Remove PLAY_NOTE_ARRAY usages to get rid of warning. Fix conflicting function name * Mousekey change default to off * Fix to oled display adjust * make rev2 change pin assign change keymap * use master_buffer * Timing adjustment * Organizing files * Change Keymap * Change Keymap Add EISU and KANA Correct 4rows * NKRO default to disable * EXTRAKEY_ENABLE default to disable * add rgb reset key * rgb custom function enable * Extend font * add RGBLED_POWER default folder to helix/rev2 RGB_ENABLE to no * renamed directory * Disable RGBLIGHT_CUSTOM_DRIVER * Disable LOCKING_SUPPORT_ENABLE * Update bootloader setting * Change readme * Fixed argument error
Diffstat (limited to 'keyboards/helix/rev2/keymaps/default/rules.mk')
-rw-r--r--keyboards/helix/rev2/keymaps/default/rules.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/keyboards/helix/rev2/keymaps/default/rules.mk b/keyboards/helix/rev2/keymaps/default/rules.mk
new file mode 100644
index 000000000..ce3ef6cd9
--- /dev/null
+++ b/keyboards/helix/rev2/keymaps/default/rules.mk
@@ -0,0 +1,25 @@
+
+# Build Options
+# change to "no" to disable the options, or define them in the Makefile in
+# the appropriate keymap folder that will get included automatically
+#
+BOOTMAGIC_ENABLE = no # Virtual DIP switch configuration(+1000)
+MOUSEKEY_ENABLE = no # Mouse keys(+4700)
+EXTRAKEY_ENABLE = no # Audio control and System control(+450)
+CONSOLE_ENABLE = no # Console for debug(+400)
+COMMAND_ENABLE = no # Commands for debug and configuration
+NKRO_ENABLE = no # Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+BACKLIGHT_ENABLE = no # Enable keyboard backlight functionality
+MIDI_ENABLE = no # MIDI controls
+AUDIO_ENABLE = no # Audio output on port C6
+UNICODE_ENABLE = no # Unicode
+BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
+RGBLIGHT_ENABLE = no # Enable WS2812 RGB underlight. Do not enable this with audio at the same time.
+ONEHAND_ENABLE = no # Enable one-hand typing
+
+# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+
+ifndef QUANTUM_DIR
+ include ../../../../Makefile
+endif