aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/hhkb/rules.mk
diff options
context:
space:
mode:
authorskullydazed <skullydazed@users.noreply.github.com>2017-07-06 18:43:22 -0700
committerGitHub <noreply@github.com>2017-07-06 18:43:22 -0700
commitecd3dbf085826459af9728b6529a504ba7d3de14 (patch)
tree7ca3733c63b5f720ae1f0118516dda0984d54fe0 /keyboards/hhkb/rules.mk
parent9cadba7b895a81f329a4c2eee253e57c11715b80 (diff)
parent1896c76a2928c96f9ab7947bec2ef8dd37623cff (diff)
downloadfirmware-ecd3dbf085826459af9728b6529a504ba7d3de14.tar.gz
firmware-ecd3dbf085826459af9728b6529a504ba7d3de14.tar.bz2
firmware-ecd3dbf085826459af9728b6529a504ba7d3de14.zip
Merge branch 'master' into docs
Diffstat (limited to 'keyboards/hhkb/rules.mk')
-rw-r--r--keyboards/hhkb/rules.mk24
1 files changed, 12 insertions, 12 deletions
diff --git a/keyboards/hhkb/rules.mk b/keyboards/hhkb/rules.mk
index e4190039f..d31e755ef 100644
--- a/keyboards/hhkb/rules.mk
+++ b/keyboards/hhkb/rules.mk
@@ -58,19 +58,19 @@ OPT_DEFS += -DBOOTLOADER_SIZE=4096
# Build Options
# comment out to disable the options.
#
-BOOTMAGIC_ENABLE ?= yes # Virtual DIP switch configuration(+1000)
-MOUSEKEY_ENABLE ?= yes # Mouse keys(+4700)
-EXTRAKEY_ENABLE ?= yes # Audio control and System control(+450)
-CONSOLE_ENABLE ?= yes # Console for debug(+400)
-COMMAND_ENABLE ?= yes # Commands for debug and configuration
-CUSTOM_MATRIX ?= yes # Custom matrix file for the HHKB
+BOOTMAGIC_ENABLE = yes # Virtual DIP switch configuration(+1000)
+MOUSEKEY_ENABLE = yes # Mouse keys(+4700)
+EXTRAKEY_ENABLE = yes # Audio control and System control(+450)
+CONSOLE_ENABLE = yes # Console for debug(+400)
+COMMAND_ENABLE = yes # Commands for debug and configuration
+CUSTOM_MATRIX = yes # Custom matrix file for the HHKB
# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
-# SLEEP_LED_ENABLE ?= yes # Breathing sleep LED during USB suspend
-# NKRO_ENABLE ?= yes # USB Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
-# BACKLIGHT_ENABLE ?= yes # Enable keyboard backlight functionality
-# MIDI_ENABLE ?= yes # MIDI controls
-# UNICODE_ENABLE ?= yes # Unicode
-# BLUETOOTH_ENABLE ?= yes # Enable Bluetooth with the Adafruit EZ-Key HID
+# SLEEP_LED_ENABLE = yes # Breathing sleep LED during USB suspend
+# NKRO_ENABLE = yes # USB Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+# BACKLIGHT_ENABLE = yes # Enable keyboard backlight functionality
+# MIDI_ENABLE = yes # MIDI controls
+# UNICODE_ENABLE = yes # Unicode
+# BLUETOOTH_ENABLE = yes # Enable Bluetooth with the Adafruit EZ-Key HID
debug-on: EXTRAFLAGS += -DDEBUG -DDEBUG_ACTION
debug-on: all