aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/hub16/keymaps
diff options
context:
space:
mode:
authorJosh Johnson <josh@joshajohnson.com>2020-07-17 22:35:44 +1000
committerGitHub <noreply@github.com>2020-07-17 13:35:44 +0100
commit07a817d3e5454f9dc3ecd5f7e7b49197bfb36599 (patch)
tree79eff4d7426a6243c9b45672804ca2dc43bcab08 /keyboards/hub16/keymaps
parent56beaf7d3f5bb135fbb516b4824d3e8c3643978f (diff)
downloadfirmware-07a817d3e5454f9dc3ecd5f7e7b49197bfb36599.tar.gz
firmware-07a817d3e5454f9dc3ecd5f7e7b49197bfb36599.tar.bz2
firmware-07a817d3e5454f9dc3ecd5f7e7b49197bfb36599.zip
[keymap] Add VIA support for Hub16 (#9638)
* fix encoder switch not staying depressed * add via support * change default keymap * change VID-PID * remove LTO * fix hold bug keeping debouncing
Diffstat (limited to 'keyboards/hub16/keymaps')
-rwxr-xr-xkeyboards/hub16/keymaps/via/keymap.c66
-rw-r--r--keyboards/hub16/keymaps/via/rules.mk4
2 files changed, 70 insertions, 0 deletions
diff --git a/keyboards/hub16/keymaps/via/keymap.c b/keyboards/hub16/keymaps/via/keymap.c
new file mode 100755
index 000000000..c6f119adb
--- /dev/null
+++ b/keyboards/hub16/keymaps/via/keymap.c
@@ -0,0 +1,66 @@
+/* Copyright 2019 Josh Johnson
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+#include QMK_KEYBOARD_H
+
+const uint16_t PROGMEM keymaps[][MATRIX_ROWS][MATRIX_COLS] = {
+ [0] = LAYOUT( /* Base */
+ KC_MUTE, KC_MPLY,
+ KC_7, KC_8, KC_9, KC_PAST,
+ KC_4, KC_5, KC_6, KC_PMNS,
+ KC_1, KC_2, KC_3, KC_PPLS,
+ MO(1), KC_0, KC_PDOT, KC_PENT
+ ),
+
+ [1] = LAYOUT( /* LED Control */
+ _______, _______,
+ _______, RGB_MOD, RGB_RMOD, RGB_TOG,
+ RGB_VAD, RGB_VAI, RGB_HUD, RGB_HUI,
+ RGB_SAD, RGB_SAI, _______, _______,
+ _______, _______, RESET, _______
+ ),
+
+ [2] = LAYOUT(
+ _______, _______,
+ _______, _______, _______, _______,
+ _______, _______, _______, _______,
+ _______, _______, _______, _______,
+ _______, _______, _______, _______
+ ),
+
+ [3] = LAYOUT(
+ _______, _______,
+ _______, _______, _______, _______,
+ _______, _______, _______, _______,
+ _______, _______, _______, _______,
+ _______, _______, _______, _______
+ ),
+};
+
+void encoder_update_user(uint8_t index, bool clockwise) {
+ if (index == 0) { /* Left Encoder */
+ if (clockwise) {
+ tap_code(KC_VOLD);
+ } else {
+ tap_code(KC_VOLU);
+ }
+ } else if (index == 1) { /* Right Encoder */
+ if (clockwise) {
+ tap_code(KC_MPRV);
+ } else {
+ tap_code(KC_MNXT);
+ }
+ }
+}
diff --git a/keyboards/hub16/keymaps/via/rules.mk b/keyboards/hub16/keymaps/via/rules.mk
new file mode 100644
index 000000000..b1c00b69f
--- /dev/null
+++ b/keyboards/hub16/keymaps/via/rules.mk
@@ -0,0 +1,4 @@
+VIA_ENABLE = yes
+CONSOLE_ENABLE = no
+COMMAND_ENABLE = no
+TAP_DANCE_ENABLE = no