aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/jj4x4/config.h
diff options
context:
space:
mode:
authorsprayed <32306510+sprayed@users.noreply.github.com>2019-02-05 13:01:35 -0500
committerDrashna Jaelre <drashna@live.com>2019-02-05 10:01:35 -0800
commit7df9e584fa1ee31ab5bb35b1c7fa09845cba0a80 (patch)
tree3d04a2c8e38652a7baf434ea5e04278ddc463d11 /keyboards/jj4x4/config.h
parentd4e1e712f68567dfed6ff19cf762d01f6bb3d60c (diff)
downloadfirmware-7df9e584fa1ee31ab5bb35b1c7fa09845cba0a80.tar.gz
firmware-7df9e584fa1ee31ab5bb35b1c7fa09845cba0a80.tar.bz2
firmware-7df9e584fa1ee31ab5bb35b1c7fa09845cba0a80.zip
[Keyboard] Add support for jj4x4 numpad/macropad by Kprepublic (#5016)
* added keyboard jj4x4, a shorter version of the jj40 * removed useless file * edited jj4x4 readme.md * optimized array size in jj4x4 config.h, removed reference to jj40 layouts from rules.mk * removed custom matrix for this ps2avrgb board, refactored column and row pins
Diffstat (limited to 'keyboards/jj4x4/config.h')
-rw-r--r--keyboards/jj4x4/config.h53
1 files changed, 53 insertions, 0 deletions
diff --git a/keyboards/jj4x4/config.h b/keyboards/jj4x4/config.h
new file mode 100644
index 000000000..d48df5f1d
--- /dev/null
+++ b/keyboards/jj4x4/config.h
@@ -0,0 +1,53 @@
+/*
+Copyright 2017 Luiz Ribeiro <luizribeiro@gmail.com>
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, either version 2 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#include "config_common.h"
+
+#ifndef CONFIG_H
+#define CONFIG_H
+
+#define VENDOR_ID 0x20A0
+#define PRODUCT_ID 0x422D
+// TODO: share these strings with usbconfig.h
+// Edit usbconfig.h to change these.
+#define MANUFACTURER Kprepublic
+#define PRODUCT jj4x4
+
+/* matrix size */
+#define MATRIX_ROWS 4
+#define MATRIX_COLS 4
+#define MATRIX_ROW_PINS { B5, B0, B3, B4 }
+#define MATRIX_COL_PINS { A1, A0, A2, A3 }
+
+/* COL2ROW or ROW2COL */
+#define DIODE_DIRECTION COL2ROW
+
+#define BACKLIGHT_LEVELS 12
+// #define BACKLIGHT_BREATHING // works, but BL_TOGG might not work
+
+#define TAPPING_TOGGLE 3
+
+#define NO_UART 1
+
+/* RGB underglow */
+// The RGB_DI_PIN value seems to be shared between all PS2AVRGB boards.
+// The same pin is used on the JJ40, at least.
+#define RGBLED_NUM 5
+#define RGB_DI_PIN E2 // NOTE: for PS2AVRGB boards, underglow commands are sent via I2C to 0xB0.
+#define RGBLIGHT_ANIMATIONS
+
+#endif