aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/jj4x4/tools
diff options
context:
space:
mode:
authorsprayed <32306510+sprayed@users.noreply.github.com>2019-02-05 13:01:35 -0500
committerDrashna Jaelre <drashna@live.com>2019-02-05 10:01:35 -0800
commit7df9e584fa1ee31ab5bb35b1c7fa09845cba0a80 (patch)
tree3d04a2c8e38652a7baf434ea5e04278ddc463d11 /keyboards/jj4x4/tools
parentd4e1e712f68567dfed6ff19cf762d01f6bb3d60c (diff)
downloadfirmware-7df9e584fa1ee31ab5bb35b1c7fa09845cba0a80.tar.gz
firmware-7df9e584fa1ee31ab5bb35b1c7fa09845cba0a80.tar.bz2
firmware-7df9e584fa1ee31ab5bb35b1c7fa09845cba0a80.zip
[Keyboard] Add support for jj4x4 numpad/macropad by Kprepublic (#5016)
* added keyboard jj4x4, a shorter version of the jj40 * removed useless file * edited jj4x4 readme.md * optimized array size in jj4x4 config.h, removed reference to jj40 layouts from rules.mk * removed custom matrix for this ps2avrgb board, refactored column and row pins
Diffstat (limited to 'keyboards/jj4x4/tools')
-rw-r--r--keyboards/jj4x4/tools/README.md16
-rw-r--r--keyboards/jj4x4/tools/usb_detach.c33
2 files changed, 49 insertions, 0 deletions
diff --git a/keyboards/jj4x4/tools/README.md b/keyboards/jj4x4/tools/README.md
new file mode 100644
index 000000000..081984ed4
--- /dev/null
+++ b/keyboards/jj4x4/tools/README.md
@@ -0,0 +1,16 @@
+# JJ40 Tools
+
+## usb_detach.c
+
+When trying to flash on Linux, you may encounter a "Resource Unavailable" error. This means that Linux's HID driver has taken exclusive control of the keyboard, and the program script can't flash it.
+This program can force Linux to give up a device, so that the programming script can reset it.
+
+### To compile:
+```
+gcc usb_detach.c -o usb_detach
+```
+
+### To run:
+1. Use `lsusb` to discover the Bus and Device numbers for your keyboard.
+2. Run the program: `sudo ./usb_detach /dev/bus/usb/<BUS>/<DEVICE>`.
+3. Build and program the firmware as normal.
diff --git a/keyboards/jj4x4/tools/usb_detach.c b/keyboards/jj4x4/tools/usb_detach.c
new file mode 100644
index 000000000..c21e47a7a
--- /dev/null
+++ b/keyboards/jj4x4/tools/usb_detach.c
@@ -0,0 +1,33 @@
+/* Found at https://www.linuxquestions.org/questions/linux-hardware-18/how-to-unclaim-usb-device-558138/#post3406986 */
+#include <stdio.h>
+#include <sys/types.h>
+#include <sys/stat.h>
+#include <fcntl.h>
+#include <linux/ioctl.h>
+#include <linux/usbdevice_fs.h>
+
+int main(int argc, char**argv)
+{
+ struct usbdevfs_ioctl command;
+ int ret;
+ int fd;
+ int i;
+ if (argc>1) {
+ fd = open(argv[1],O_RDWR);
+ if (fd<1){
+ perror("unable to open file");
+ return 1;
+ }
+ for (i=0;i<255;i++){ // hack: should fetch how many interface there is.
+ command.ifno = i;
+ command.ioctl_code = USBDEVFS_DISCONNECT;
+ command.data = NULL;
+ ret = ioctl(fd, USBDEVFS_IOCTL, &command);
+ if(ret!=-1)
+ printf("un claimed interface %d %d\n",i,ret);
+ }
+ } else {
+ printf ("usage: %s /dev/bus/usb/BUS/DEVICE\n",argv[0]);
+ printf("Release all interfaces of this usb device for usage in virtualisation\n");
+ }
+} \ No newline at end of file