aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/jj50/rules.mk
diff options
context:
space:
mode:
authorGuillaume GĂ©rard <1322081+GreatWizard@users.noreply.github.com>2020-06-28 19:45:16 +0200
committerGitHub <noreply@github.com>2020-06-28 18:45:16 +0100
commit092849622017fcd32c1b3e4708030b1cf2fd6ade (patch)
tree8e597689ee2c22a033e390925ff8ed4a28d35c95 /keyboards/jj50/rules.mk
parenta8904d47b745518e9bbab8f20f05828d77f7f42d (diff)
downloadfirmware-092849622017fcd32c1b3e4708030b1cf2fd6ade.tar.gz
firmware-092849622017fcd32c1b3e4708030b1cf2fd6ade.tar.bz2
firmware-092849622017fcd32c1b3e4708030b1cf2fd6ade.zip
[Keyboard] Refactor JJ50 keyboard mapping to current standard (#9415)
Diffstat (limited to 'keyboards/jj50/rules.mk')
-rw-r--r--keyboards/jj50/rules.mk25
1 files changed, 11 insertions, 14 deletions
diff --git a/keyboards/jj50/rules.mk b/keyboards/jj50/rules.mk
index 73be71d35..8f78a7674 100644
--- a/keyboards/jj50/rules.mk
+++ b/keyboards/jj50/rules.mk
@@ -12,19 +12,16 @@ MCU = atmega32a
BOOTLOADER = bootloadHID
# build options
-BOOTMAGIC_ENABLE = yes
-MOUSEKEY_ENABLE = no
-EXTRAKEY_ENABLE = yes
-CONSOLE_ENABLE = no
-COMMAND_ENABLE = yes
-BACKLIGHT_ENABLE = yes
-RGBLIGHT_ENABLE = yes
-WS2812_DRIVER = i2c
-NKRO_ENABLE = no
-# Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
-
-KEY_LOCK_ENABLE = yes
-# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
-SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
+BOOTMAGIC_ENABLE = lite # Virtual DIP switch configuration
+MOUSEKEY_ENABLE = no # Mouse keys
+EXTRAKEY_ENABLE = yes # Audio control and System control
+CONSOLE_ENABLE = no # Console for debug
+COMMAND_ENABLE = no # Commands for debug and configuration
+NKRO_ENABLE = no # Nkey Rollover - if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
+BACKLIGHT_ENABLE = yes # Enable keyboard backlight functionality
+RGBLIGHT_ENABLE = yes # Enable keyboard underlight functionality
+WS2812_DRIVER = i2c # This driver powers the RGB Lighting and RGB Matrix features
+SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend - # Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
+LTO_ENABLE = yes # Enable link time optimization
LAYOUTS = ortho_5x12