aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/just60/config.h
diff options
context:
space:
mode:
authorJianfei Wang <me@thinxer.com>2020-01-02 14:28:05 +0800
committerJames Young <18669334+noroadsleft@users.noreply.github.com>2020-01-01 22:28:05 -0800
commit77f66cc5e1e2a4624305526d6ff9ffee60e17588 (patch)
tree19c1cce5a0963ffc5e459e7435a5aa3a45b9257f /keyboards/just60/config.h
parent86815edc3140d926e272abf9a4c48b7ba0b4fd3b (diff)
downloadfirmware-77f66cc5e1e2a4624305526d6ff9ffee60e17588.tar.gz
firmware-77f66cc5e1e2a4624305526d6ff9ffee60e17588.tar.bz2
firmware-77f66cc5e1e2a4624305526d6ff9ffee60e17588.zip
[Keyboard] add Just60 keyboard (#7752)
* [Keyboard] add Just60 keyboard * [Keyboard] just60: fixes per suggestions * Update keyboards/just60/rules.mk * Update keyboards/just60/readme.md * Update keyboards/just60/rules.mk * [Keyboard] just60: add keymap specific bootloader * Revert "[Keyboard] just60: add keymap specific bootloader" This reverts commit 0357e0a6f40233eec43f42c32fb405f60e7fbb1c.
Diffstat (limited to 'keyboards/just60/config.h')
-rw-r--r--keyboards/just60/config.h54
1 files changed, 54 insertions, 0 deletions
diff --git a/keyboards/just60/config.h b/keyboards/just60/config.h
new file mode 100644
index 000000000..ef0af7c61
--- /dev/null
+++ b/keyboards/just60/config.h
@@ -0,0 +1,54 @@
+/*
+Copyright 2019 Jianfei Wang
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, either version 2 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful,
+but WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+GNU General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
+*/
+
+#pragma once
+
+#include "config_common.h"
+
+/* USB Device descriptor parameter */
+#define VENDOR_ID 0xFEED
+#define PRODUCT_ID 0x1960
+#define DEVICE_VER 0x0001
+#define MANUFACTURER YDKB
+#define PRODUCT Just60
+#define DESCRIPTION Just60 Keyboard
+
+/* key matrix size */
+#define MATRIX_ROWS 5
+#define MATRIX_COLS 14
+
+#define MATRIX_ROW_PINS { E2, C7, B3, B2, B1 }
+#define MATRIX_COL_PINS { D6, D7, B4, B6, B5, B7, F7, F6, F5, F4, F1, F0, E6, B0 }
+#define UNUSED_PINS
+#define DIODE_DIRECTION COL2ROW
+
+#define QMK_ESC_OUTPUT D6 // usually COL
+#define QMK_ESC_INPUT E2 // usually ROW
+
+/* Debounce reduces chatter (unintended double-presses) - set 0 if debouncing is not needed */
+#define DEBOUNCE 5
+
+/* Mechanical locking support. Use KC_LCAP, KC_LNUM or KC_LSCR instead in keymap */
+#define LOCKING_SUPPORT_ENABLE
+/* Locking resynchronize hack */
+#define LOCKING_RESYNC_ENABLE
+
+/* disable these deprecated features by default */
+#ifndef LINK_TIME_OPTIMIZATION_ENABLE
+ #define NO_ACTION_MACRO
+ #define NO_ACTION_FUNCTION
+#endif