aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/kbdfans/kbd67/rev2/rev2.c
diff options
context:
space:
mode:
authorPaul J. Miller <miller874@gmail.com>2019-05-11 12:24:49 -0400
committerMechMerlin <30334081+mechmerlin@users.noreply.github.com>2019-05-11 09:24:49 -0700
commitd591ab6263a4c5581d1614b006b5ef52b012c9a8 (patch)
tree4e05e4a95dd1c785e360aa6ae881931d9d68f009 /keyboards/kbdfans/kbd67/rev2/rev2.c
parent7871a465d36d11c4f9216a9e862104e0e770c6f4 (diff)
downloadfirmware-d591ab6263a4c5581d1614b006b5ef52b012c9a8.tar.gz
firmware-d591ab6263a4c5581d1614b006b5ef52b012c9a8.tar.bz2
firmware-d591ab6263a4c5581d1614b006b5ef52b012c9a8.zip
feat: add kbd67v2 support (#5777)
* feat: add kbd67v2 support * update cr * Update keyboards/kbdfans/kbd67/rev2/config.h Co-Authored-By: Vorror <paul@dgtlrepublic.com> * Update keyboards/kbdfans/kbd67/rev2/config.h Co-Authored-By: Vorror <paul@dgtlrepublic.com> * Update keyboards/kbdfans/kbd67/rev2/rev2.c Co-Authored-By: Vorror <paul@dgtlrepublic.com> * Update keyboards/kbdfans/kbd67/rev2/rules.mk Co-Authored-By: MechMerlin <30334081+mechmerlin@users.noreply.github.com> * Update keyboards/kbdfans/kbd67/rev2/readme.md Co-Authored-By: MechMerlin <30334081+mechmerlin@users.noreply.github.com>
Diffstat (limited to 'keyboards/kbdfans/kbd67/rev2/rev2.c')
-rw-r--r--keyboards/kbdfans/kbd67/rev2/rev2.c42
1 files changed, 42 insertions, 0 deletions
diff --git a/keyboards/kbdfans/kbd67/rev2/rev2.c b/keyboards/kbdfans/kbd67/rev2/rev2.c
new file mode 100644
index 000000000..8aa83f586
--- /dev/null
+++ b/keyboards/kbdfans/kbd67/rev2/rev2.c
@@ -0,0 +1,42 @@
+/* Copyright 2019 Vorror
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+#include "rev2.h"
+
+void matrix_init_kb(void) {
+ // put your keyboard start-up code here
+ // runs once when the firmware starts up
+
+ matrix_init_user();
+}
+
+void matrix_scan_kb(void) {
+ // put your looping keyboard code here
+ // runs every cycle (a lot)
+
+ matrix_scan_user();
+}
+
+bool process_record_kb(uint16_t keycode, keyrecord_t *record) {
+ // put your per-action keyboard code here
+ // runs for every action, just before processing by the firmware
+
+ return process_record_user(keycode, record);
+}
+
+void led_set_kb(uint8_t usb_led) {
+ // put your keyboard LED indicator (ex: Caps Lock LED) toggling code here
+ led_set_user(usb_led);
+}