aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/kbdfans/kbdpad_mk2/kbdpad_mk2.h
diff options
context:
space:
mode:
authorai03 <sarcaphx510@gmail.com>2019-06-01 22:02:33 -0700
committerDrashna Jaelre <drashna@live.com>2019-06-01 22:02:33 -0700
commit3449000f425ba2dfe2fa1119435b3f61bc22be76 (patch)
treed0f2d0dcd1a2d710673cb92f7e43d9453738c4ea /keyboards/kbdfans/kbdpad_mk2/kbdpad_mk2.h
parent155be34a1d2b782a73318cc507315b33cc86cc49 (diff)
downloadfirmware-3449000f425ba2dfe2fa1119435b3f61bc22be76.tar.gz
firmware-3449000f425ba2dfe2fa1119435b3f61bc22be76.tar.bz2
firmware-3449000f425ba2dfe2fa1119435b3f61bc22be76.zip
[Keyboard] Add support for KBDPAD MKII (#6034)
* Build some testing keymaps * Match naming convention to 8x * Add configurator json * Forgot to build the readme * Apply suggestions from code review Co-Authored-By: Elliot Powell <32494740+e11i0t23@users.noreply.github.com> Co-Authored-By: Drashna Jaelre <drashna@live.com> * Update keyboards/kbdfans/kbdpad_mk2/rules.mk Co-Authored-By: Drashna Jaelre <drashna@live.com>
Diffstat (limited to 'keyboards/kbdfans/kbdpad_mk2/kbdpad_mk2.h')
-rw-r--r--keyboards/kbdfans/kbdpad_mk2/kbdpad_mk2.h43
1 files changed, 43 insertions, 0 deletions
diff --git a/keyboards/kbdfans/kbdpad_mk2/kbdpad_mk2.h b/keyboards/kbdfans/kbdpad_mk2/kbdpad_mk2.h
new file mode 100644
index 000000000..328aeaac9
--- /dev/null
+++ b/keyboards/kbdfans/kbdpad_mk2/kbdpad_mk2.h
@@ -0,0 +1,43 @@
+/* Copyright 2019 Ryota Goto
+ *
+ * This program is free software: you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation, either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.
+ */
+#pragma once
+
+#include "quantum.h"
+
+/* This a shortcut to help you visually see your layout.
+ *
+ * The first section contains all of the arguments representing the physical
+ * layout of the board and position of the keys.
+ *
+ * The second converts the arguments into a two-dimensional array which
+ * represents the switch matrix.
+ */
+#define LAYOUT_ortho_6x4( \
+ K00, K01, K02, K03, \
+ K10, K11, K12, K13, \
+ K20, K21, K22, K23, \
+ K30, K31, K32, K33, \
+ K40, K41, K42, K43, \
+ K50, K51, K52, K53 \
+) \
+{ \
+ { K00, K01, K02, K03 }, \
+ { K10, K11, K12, K13 }, \
+ { K20, K21, K22, K23 }, \
+ { K30, K31, K32, K33 }, \
+ { K40, K41, K42, K43 }, \
+ { K50, K51, K52, K53 } \
+}