aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/kc60/keymaps/ws2812/rules.mk
diff options
context:
space:
mode:
authorJames Young <18669334+noroadsleft@users.noreply.github.com>2020-04-15 13:31:09 -0700
committerGitHub <noreply@github.com>2020-04-15 22:31:09 +0200
commit3cc68543ca8c69048ffc0655d92be238afcee376 (patch)
tree93a3e3208c8980c68ad50ea36de50e63f8974456 /keyboards/kc60/keymaps/ws2812/rules.mk
parentdaf6dedb02d96af789deccc2f96fe281486207c0 (diff)
downloadfirmware-3cc68543ca8c69048ffc0655d92be238afcee376.tar.gz
firmware-3cc68543ca8c69048ffc0655d92be238afcee376.tar.bz2
firmware-3cc68543ca8c69048ffc0655d92be238afcee376.zip
KC60 Refactor (#8782)
Diffstat (limited to 'keyboards/kc60/keymaps/ws2812/rules.mk')
-rw-r--r--keyboards/kc60/keymaps/ws2812/rules.mk24
1 files changed, 2 insertions, 22 deletions
diff --git a/keyboards/kc60/keymaps/ws2812/rules.mk b/keyboards/kc60/keymaps/ws2812/rules.mk
index 393ff863e..72a3d6f6c 100644
--- a/keyboards/kc60/keymaps/ws2812/rules.mk
+++ b/keyboards/kc60/keymaps/ws2812/rules.mk
@@ -1,22 +1,2 @@
-
-
-# Build Options
-# change yes to no to disable
-#
-BOOTMAGIC_ENABLE = yes # Virtual DIP switch configuration
-MOUSEKEY_ENABLE = yes # Mouse keys
-EXTRAKEY_ENABLE = yes # Audio control and System control
-CONSOLE_ENABLE = yes # Console for debug
-COMMAND_ENABLE = yes # Commands for debug and configuration
-KEYBOARD_LOCK_ENABLE = yes # Allow locking of keyboard via magic key
-BACKLIGHT_ENABLE = yes # Enable keyboard backlight functionality
-RGBLIGHT_ENABLE = yes # Enable WS2812 underglow RGB strip
-MIDI_ENABLE = no # MIDI controls
-UNICODE_ENABLE = no # Unicode
-BLUETOOTH_ENABLE = no # Enable Bluetooth with the Adafruit EZ-Key HID
-AUDIO_ENABLE = no # Audio output on port C6
-# Do not enable SLEEP_LED_ENABLE. it uses the same timer as BACKLIGHT_ENABLE
-SLEEP_LED_ENABLE = no # Breathing sleep LED during USB suspend
-# if this doesn't work, see here: https://github.com/tmk/tmk_keyboard/wiki/FAQ#nkro-doesnt-work
-NKRO_ENABLE = no # USB Nkey Rollover
-
+COMMAND_ENABLE = no
+RGBLIGHT_ENABLE = yes