aboutsummaryrefslogtreecommitdiffstats
path: root/keyboards/keebio/bdn9
diff options
context:
space:
mode:
authorfauxpark <fauxpark@gmail.com>2019-10-22 15:43:18 +1100
committernoroadsleft <18669334+noroadsleft@users.noreply.github.com>2019-10-21 21:43:18 -0700
commit2ee961c9e873d577e711431ae0960aa21629525e (patch)
tree0ab1aa27f879c732cf29a75f49e7d6ab3e4ad125 /keyboards/keebio/bdn9
parentc44aff5f18b287bae718c934a9943eae97585cba (diff)
downloadfirmware-2ee961c9e873d577e711431ae0960aa21629525e.tar.gz
firmware-2ee961c9e873d577e711431ae0960aa21629525e.tar.bz2
firmware-2ee961c9e873d577e711431ae0960aa21629525e.zip
Cleanup rules.mk for 32U4 keyboards, I-K (#7097)
* Cleanup rules.mk for 32U4 keyboards, I-K * Clean up ivy rules.mk
Diffstat (limited to 'keyboards/keebio/bdn9')
-rw-r--r--keyboards/keebio/bdn9/rules.mk22
1 files changed, 3 insertions, 19 deletions
diff --git a/keyboards/keebio/bdn9/rules.mk b/keyboards/keebio/bdn9/rules.mk
index 3ab849108..8b4bb334e 100644
--- a/keyboards/keebio/bdn9/rules.mk
+++ b/keyboards/keebio/bdn9/rules.mk
@@ -1,11 +1,5 @@
+# MCU name
MCU = atmega32u4
-F_CPU = 16000000
-ARCH = AVR8
-F_USB = $(F_CPU)
-
-# Interrupt driven control endpoint task(+60)
-OPT_DEFS += -DINTERRUPT_CONTROL_ENDPOINT
-
# Bootloader selection
# Teensy halfkay
@@ -13,20 +7,10 @@ OPT_DEFS += -DINTERRUPT_CONTROL_ENDPOINT
# Atmel DFU atmel-dfu
# LUFA DFU lufa-dfu
# QMK DFU qmk-dfu
-# atmega32a bootloadHID
+# ATmega32A bootloadHID
+# ATmega328P USBasp
BOOTLOADER = caterina
-
-# If you don't know the bootloader type, then you can specify the
-# Boot Section Size in *bytes* by uncommenting out the OPT_DEFS line
-# Teensy halfKay 512
-# Teensy++ halfKay 1024
-# Atmel DFU loader 4096
-# LUFA bootloader 4096
-# USBaspLoader 2048
-# OPT_DEFS += -DBOOTLOADER_SIZE=4096
-
-
# Build Options
# change yes to no to disable
#